Updating from 16.04 to 18.04

Asked by Tony Martinez on 2019-02-12

I read it is because of some PPA. I used the ubuntu tool to remove all of them, but I keep on getting that error. I tried several things that I read online, but nothing worked for me. I would really appreciate any help.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: ubuntu-release-upgrader-core 1:16.04.26
Uname: Linux 4.4.25-040425-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.20.1-0ubuntu2.18
Architecture: amd64
CrashDB: ubuntu
CurrentDesktop: Unity
Date: Tue Feb 12 16:07:40 2019
InstallationDate: Installed on 2016-09-18 (877 days ago)
InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
PackageArchitecture: all
SourcePackage: ubuntu-release-upgrader
UpgradeStatus: Upgraded to xenial on 2019-02-12 (0 days ago)
VarLogDistupgradeTermlog:

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu ubuntu-release-upgrader Edit question
Assignee:
No assignee Edit question
Last query:
2019-02-12
Last reply:
2019-02-13

This question was originally filed as bug #1815687.

Cody Skinner (wskinner) said : #1

I am happy that we were able to get this resolved for you. I'm going to go ahead and convert this report to a question, because this is more of a support request than a bug in the release-upgrader. From here we can mark the issue as "Solved" so that others with similar issues are able to easily find it.

Cody Skinner (wskinner) said : #2

Solution from the original bug report:
"Hi Tony, thank you for taking the time to submit this bug.
The log indicates several broken packages still on your system that appear to be interfering with the upgrade. Try running 'sudo apt-get remove libblas3 libpython2.7-stdlib libopenblas-base python-scipy' and then attempting the upgrade again and let me know how that goes."

Can you help with this problem?

Provide an answer of your own, or ask Tony Martinez for more information if necessary.

To post a message you must log in.