Ubuntu 16.10 -> 17.04 upgrade left system in unknown state

Asked by Bob Stutes on 2017-04-28

I just executed the upgrade process from 16.10 to 17.04. In the past, an upgrade like this has been painless. This time there are 30 packages that remain in an unconfigured state because of errors emitted by scripts used during the upgrade process.

This list of packages follows:

url-dispatcher-tools, ubuntu-app-launch-tools, libubuntu-app-launch4:amd64, unity8-private:amd64,
ubuntu-system-settings-online-accounts, pay-ui, pay-service, unity8, account-plugin-ubuntuone, indicator-datetime,
indicator-transfer-download-manager, libcontent-hub0:amd64, content-hub, unity-greeter-session-broadcast,
qtmir-desktop:amd64, unity8-desktop-session, ubuntu-push-client, qtdeclarative5-qtmir-plugin:amd64, qtubuntu-desktop:amd64,
qtubuntu-print, ubuntu-system-settings, unity8-common, unity-control-center, libertine-xmir-tools, qtdeclarative5-ubuntu-content1,
ubuntu-printing-app, webbrowser-app, ubuntu-desktop, indicator-bluetooth, webapp-container

At this time I have concern that if I reboot the system I may end up with an unusable system. I have the logs from the upgrade process. Any suggestion what can be done to get my system straightened out again? I have no problem with backing out the upgrade but have no idea what command I would need to run to accomplish this.

Any help would be appreciated.

Thanks!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ubuntu-release-upgrader Edit question
Assignee:
No assignee Edit question
Solved by:
Bob Stutes
Solved:
2017-04-29
Last query:
2017-04-29
Last reply:
2017-04-28
Manfred Hampl (m-hampl) said : #1

For diagnostic purposes, what is the current output of the commands

uname -a
lsb_release -crid
sudo dpkg --audit
sudo dpkg --configure -a

(There is no command to undo the upgrade.)

Bob Stutes (bstutes) said : #2

Here is the output from the above commands:

bstutes@bob:/var/log/dist-upgrade$ uname -a
Linux bob 4.8.0-39-generic #42-Ubuntu SMP Mon Feb 20 11:47:27 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
bstutes@bob:/var/log/dist-upgrade$ lsb_release -crid
Distributor ID: Ubuntu
Description: Ubuntu 17.04
Release: 17.04
Codename: zesty
bstutes@bob:/var/log/dist-upgrade$ sudo dpkg --audit
The following packages have been unpacked but not yet configured.
They must be configured using dpkg --configure or the configure
menu option in dselect for them to work:
 account-plugin-ubuntuone Ubuntu One authentication library - account settings
 content-hub content sharing/picking service
 indicator-bluetooth System bluetooth indicator.
 indicator-datetime Simple clock
 indicator-transfer-download-manager Download manager plugin for trasfer indica
 libcontent-hub0:amd64 content sharing/picking library
 libertine-xmir-tools helper apps for using and interacting with Xmir
 libubuntu-app-launch4:amd64 library for sending requests to the ubuntu app launch
 pay-service service to allow requesting payment for an item
 pay-ui service to allow requesting payment for an item - user in
 qtdeclarative5-qtmir-plugin:amd64 Qt plugin for Unity specific Mir APIs
 qtdeclarative5-ubuntu-content1 QML binding for libcontent-hub
 qtmir-desktop:amd64 Qt platform abstraction (QPA) plugin for a Mir server (de
 qtubuntu-desktop:amd64 Qt plugins for Ubuntu Platform API (desktop)
 qtubuntu-print Print plugin for Qt sending PDFs over content-hub
 ubuntu-app-launch-tools Tools for working wtih launched applications
 ubuntu-desktop The Ubuntu desktop system
 ubuntu-printing-app Printing app which consumes a PDF from content-hub
 ubuntu-push-client Ubuntu Push Notifications client-side daemon
 ubuntu-system-settings System Settings application for Ubuntu Touch
 ubuntu-system-settings-online-accounts Online Accounts setup for Ubuntu Touch
 unity-control-center utilities to configure the GNOME desktop
 unity-greeter-session-broadcast Service to allow the greeter to communicate to
 unity8 Unity 8 shell
 unity8-common Unity 8 shell (common files)
 unity8-desktop-session Unity8 desktop session for Mir
 unity8-private:amd64 Unity 8 private libs
 url-dispatcher-tools tools for working with the URL Dispatcher.
 webapp-container Ubuntu web applications container
 webbrowser-app Ubuntu web browser

I have tried running "dpkg --configure --pending" and for each application the result was failure due to a dependence issue. Below is the output of that run:

bstutes@bob:/var/log/dist-upgrade$ sudo dpkg --configure --pending
dpkg: dependency problems prevent configuration of url-dispatcher-tools:
 url-dispatcher-tools depends on url-dispatcher (= 0.1+17.04.20170328-0ubuntu2); however:
  Version of url-dispatcher:amd64 on system is 0.1+16.10.20160816.1-0ubuntu1.

dpkg: error processing package url-dispatcher-tools (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ubuntu-app-launch-tools:
 ubuntu-app-launch-tools depends on ubuntu-app-launch (= 0.12+17.04.20170404.2-0ubuntu2); however:
  Version of ubuntu-app-launch on system is 0.9+16.10.20160928-0ubuntu1.

dpkg: error processing package ubuntu-app-launch-tools (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libubuntu-app-launch4:amd64:
 libubuntu-app-launch4:amd64 depends on ubuntu-app-launch (= 0.12+17.04.20170404.2-0ubuntu2); however:
  Version of ubuntu-app-launch on system is 0.9+16.10.20160928-0ubuntu1.

dpkg: error processing package libubuntu-app-launch4:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of unity8-private:amd64:
 unity8-private:amd64 depends on libubuntu-app-launch4 (>= 0.10); however:
  Package libubuntu-app-launch4:amd64 is not configured yet.

dpkg: error processing package unity8-private:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ubuntu-system-settings-online-accounts:
 ubuntu-system-settings-online-accounts depends on libubuntu-app-launch4 (>= 0.10); however:
  Package libubuntu-app-launch4:amd64 is not configured yet.

dpkg: error processing package ubuntu-system-settings-online-accounts (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of unity8:
 unity8 depends on unity-launcher-impl-12; however:
  Package unity-launcher-impl-12 is not installed.
  Package unity8-private:amd64 which provides unity-launcher-impl-12 is not configured yet.
 unity8 depends on unity8-private (= 8.15+17.04.20170404.7-0ubuntu3); however:
  Package unity8-private:amd64 is not configured yet.

dpkg: error processing package unity8 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of indicator-datetime:
 indicator-datetime depends on libubuntu-app-launch4 (>= 0.10); however:
  Package libubuntu-app-launch4:amd64 is not configured yet.

dpkg: error processing package indicator-datetime (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of indicator-transfer-download-manager:
 indicator-transfer-download-manager depends on libubuntu-app-launch4 (>= 0.10); however:
  Package libubuntu-app-launch4:amd64 is not configured yet.

dpkg: error processing package indicator-transfer-download-manager (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libcontent-hub0:amd64:
 libcontent-hub0:amd64 depends on libubuntu-app-launch4 (>= 0.10); however:
  Package libubuntu-app-launch4:amd64 is not configured yet.

dpkg: error processing package libcontent-hub0:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of content-hub:
 content-hub depends on libcontent-hub0; however:
  Package libcontent-hub0:amd64 is not configured yet.
 content-hub depends on libubuntu-app-launch4 (>= 0.10); however:
  Package libubuntu-app-launch4:amd64 is not configured yet.

dpkg: error processing package content-hub (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of unity-greeter-session-broadcast:
 unity-greeter-session-broadcast depends on url-dispatcher-tools; however:
  Package url-dispatcher-tools is not configured yet.

dpkg: error processing package unity-greeter-session-broadcast (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of qtmir-desktop:amd64:
 qtmir-desktop:amd64 depends on libcontent-hub0; however:
  Package libcontent-hub0:amd64 is not configured yet.

dpkg: error processing package qtmir-desktop:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of unity8-desktop-session:
 unity8-desktop-session depends on qtmir-desktop; however:
  Package qtmir-desktop:amd64 is not configured yet.
 unity8-desktop-session depends on unity8; however:
  Package unity8 is not configured yet.

dpkg: error processing package unity8-desktop-session (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of qtdeclarative5-qtmir-plugin:amd64:
 qtdeclarative5-qtmir-plugin:amd64 depends on qtmir-desktop (= 0.5.1+17.04.20170404-0ubuntu2) | qtmir-android (= 0.5.1+17.04.20170404-0ubuntu2); however:
  Package qtmir-desktop:amd64 is not configured yet.
  Package qtmir-android is not installed.
 qtdeclarative5-qtmir-plugin:amd64 depends on libubuntu-app-launch4 (>= 0.10); however:
  Package libubuntu-app-launch4:amd64 is not configured yet.

dpkg: error processing package qtdeclarative5-qtmir-plugin:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of qtubuntu-desktop:amd64:
 qtubuntu-desktop:amd64 depends on libcontent-hub0; however:
  Package libcontent-hub0:amd64 is not configured yet.

dpkg: error processing package qtubuntu-desktop:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of qtubuntu-print:
 qtubuntu-print depends on content-hub; however:
  Package content-hub is not configured yet.
 qtubuntu-print depends on libcontent-hub0; however:
  Package libcontent-hub0:amd64 is not configured yet.

dpkg: error processing package qtubuntu-print (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ubuntu-system-settings:
 ubuntu-system-settings depends on indicator-datetime; however:
  Package indicator-datetime is not configured yet.

dpkg: error processing package ubuntu-system-settings (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of unity8-common:
 unity8-common depends on unity-application-impl-27; however:
  Package unity-application-impl-27 is not installed.
  Package qtdeclarative5-qtmir-plugin:amd64 which provides unity-application-impl-27 is not configured yet.
 unity8-common depends on unity8-tests | unity-application-impl; however:
  Package unity8-tests is not installed.
  Package unity-application-impl is not installed.
  Package qtdeclarative5-qtmir-plugin:amd64 which provides unity-application-impl is not configured yet.

dpkg: error processing package unity8-common (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of unity-control-center:
 unity-control-center depends on indicator-datetime; however:
  Package indicator-datetime is not configured yet.

dpkg: error processing package unity-control-center (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libertine-xmir-tools:
 libertine-xmir-tools depends on libcontent-hub0; however:
  Package libcontent-hub0:amd64 is not configured yet.

dpkg: error processing package libertine-xmir-tools (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of qtdeclarative5-ubuntu-content1:
 qtdeclarative5-ubuntu-content1 depends on libcontent-hub0; however:
  Package libcontent-hub0:amd64 is not configured yet.

dpkg: error processing package qtdeclarative5-ubuntu-content1 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ubuntu-printing-app:
 ubuntu-printing-app depends on qtdeclarative5-ubuntu-content1; however:
  Package qtdeclarative5-ubuntu-content1 is not configured yet.

dpkg: error processing package ubuntu-printing-app (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of webbrowser-app:
 webbrowser-app depends on qtdeclarative5-ubuntu-content1; however:
  Package qtdeclarative5-ubuntu-content1 is not configured yet.

dpkg: error processing package webbrowser-app (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ubuntu-desktop:
 ubuntu-desktop depends on unity-control-center; however:
  Package unity-control-center is not configured yet.

dpkg: error processing package ubuntu-desktop (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of indicator-bluetooth:
 indicator-bluetooth depends on unity-control-center | gnome-control-center | ubuntu-system-settings; however:
  Package unity-control-center is not configured yet.
  Package gnome-control-center is not installed.
  Package ubuntu-system-settings is not configured yet.

dpkg: error processing package indicator-bluetooth (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of webapp-container:
 webapp-container depends on qtdeclarative5-ubuntu-content1; however:
  Package qtdeclarative5-ubuntu-content1 is not configured yet.
 webapp-container depends on webbrowser-app (= 0.23+17.04.20170321-0ubuntu1); however:
  Package webbrowser-app is not configured yet.

dpkg: error processing package webapp-container (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 url-dispatcher-tools
 ubuntu-app-launch-tools
 libubuntu-app-launch4:amd64
 unity8-private:amd64
 ubuntu-system-settings-online-accounts
 unity8
 indicator-datetime
 indicator-transfer-download-manager
 libcontent-hub0:amd64
 content-hub
 unity-greeter-session-broadcast
 qtmir-desktop:amd64
 unity8-desktop-session
 qtdeclarative5-qtmir-plugin:amd64
 qtubuntu-desktop:amd64
 qtubuntu-print
 ubuntu-system-settings
 unity8-common
 unity-control-center
 libertine-xmir-tools
 qtdeclarative5-ubuntu-content1
 ubuntu-printing-app
 webbrowser-app
 ubuntu-desktop
 indicator-bluetooth
 webapp-container
bstutes@bob:/var/log/dist-upgrade$

Bob Stutes (bstutes) said : #3

After much digging around I found the problem was a local install of the "click" utility which was tripping up the Ubuntu click utility. Once I removed the offending version of click I was able to manually complete the Ubuntu 17.04 (Zesty) upgrade.
All is good with the world again. :-)