graphical web browsers stopped working

Asked by Janos G. Komaromi on 2017-03-26

This is a fully up-to-date 16.04 on a 32-bit machine, kernel is ...-66. Recently I noticed that Firefox crashed, would not start. I removed it, also autoclean and autoremove, reinstalled - same thing. Tried Chrome - same thing, would not start. Tried links2 - it works in text mode (so the problem has nothing to do with my Internet connection), but would not display graphical pages. midori crashes (from terminal) with SIGILL in call init(), but does show a fleeting opening window. vivaldi crashes at start (from terminal) with apport-gtk 'utf-8' codec can't decode.

My suspicion is that something must have happened with the display part accessed by the web browser programs during various Ubuntu upgrades.

Everything else works fine (pictures, movies, etc.).

My questions are: Is this a bug? What is the solution?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ubuntu-release-upgrader Edit question
Assignee:
No assignee Edit question
Solved by:
Janos G. Komaromi
Solved:
2017-03-27
Last query:
2017-03-27
Last reply:
2017-03-27
Manfred Hampl (m-hampl) said : #1

If you open a terminal window and issue the command

firefox

do you see any error messages there?
In addition please provide the output of the commands

uname -a
lsb_release -crid
apt-cache policy firefox

Does it work OK in the guest session?

..

Janos G. Komaromi (jankom) said : #4

No, it does not work in guest session, the same crash report window pops up (mozilla, sorry, etc...)
Below is copy of screen following suggestions:

janos@AndrasXubuntu:~/Desktop$ firefox
ExceptionHandler::GenerateDump cloned child 2511
ExceptionHandler::SendContinueSignalToChild sent continue signal to child
ExceptionHandler::WaitForContinueSignal waiting for continue signal...
janos@AndrasXubuntu:~/Desktop$ uname -a
Linux AndrasXubuntu 4.4.0-66-generic #87-Ubuntu SMP Fri Mar 3 15:27:09 UTC 2017 i686 athlon i686 GNU/Linux
janos@AndrasXubuntu:~/Desktop$ lsb_release -crid
Distributor ID: Ubuntu
Description: Ubuntu 16.04.2 LTS
Release: 16.04
Codename: xenial
janos@AndrasXubuntu:~/Desktop$ apt-cache policy firefox
firefox:
  Installed: 52.0.1+build2-0ubuntu0.16.04.1
  Candidate: 52.0.1+build2-0ubuntu0.16.04.1
  Version table:
 *** 52.0.1+build2-0ubuntu0.16.04.1 500
        500 http://us.archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages
        500 http://security.ubuntu.com/ubuntu xenial-security/main i386 Packages
        100 /var/lib/dpkg/status
     45.0.2+build1-0ubuntu1 500
        500 http://us.archive.ubuntu.com/ubuntu xenial/main i386 Packages
janos@AndrasXubuntu:~/Desktop$

Needless to say I do t his from another machine (64-bit laptop), on my same home network. Thanks for looking into the matter.
Janos

Manfred Hampl (m-hampl) said : #5

Do you get the same crash or is it working, when you start firefox with

firefox -safe-mode

Janos G. Komaromi (jankom) said : #6

Yes. This time I checked boxes in Mozilla Crash Report. Also, I did a dmsg immediately after the crash window closed, and to me it reveals nothing, everything looks OK at the kernel level - at least to my untrained eye. See screen copy below.

janos@AndrasXubuntu:~/Desktop$ firefox safe-mode
ExceptionHandler::GenerateDump cloned child 2242
ExceptionHandler::SendContinueSignalToChild sent continue signal to child
ExceptionHandler::WaitForContinueSignal waiting for continue signal...
janos@AndrasXubuntu:~/Desktop$ Failed to open curl lib from binary, use libcurl.so instead

janos@AndrasXubuntu:~/Desktop$ dmesg | tail
[ 66.632400] wlp1s7: authenticate with 00:12:17:27:44:1b
[ 66.681202] wlp1s7: send auth to 00:12:17:27:44:1b (try 1/3)
[ 66.684355] wlp1s7: authenticated
[ 66.700139] ath9k 0000:01:07.0 wlp1s7: disabling HT/VHT due to WEP/TKIP use
[ 66.700152] ath9k 0000:01:07.0 wlp1s7: disabling HT as WMM/QoS is not supported by the AP
[ 66.700156] ath9k 0000:01:07.0 wlp1s7: disabling VHT as WMM/QoS is not supported by the AP
[ 66.705714] wlp1s7: associate with 00:12:17:27:44:1b (try 1/3)
[ 66.708982] wlp1s7: RX AssocResp from 00:12:17:27:44:1b (capab=0x411 status=0 aid=6)
[ 66.709149] wlp1s7: associated
[ 66.709233] IPv6: ADDRCONF(NETDEV_CHANGE): wlp1s7: link becomes ready
janos@AndrasXubuntu:~/Desktop$

Manfred Hampl (m-hampl) said : #7

For the test with safe mode the command should have been
firefox -safe-mode
and not
firefox safe-mode

Please try again.

Do you have any idea where that "Failed to open curl lib from binary, use libcurl.so instead" message is coming from?

Janos G. Komaromi (jankom) said : #8

Sorry, my fault leaving out the "-" from the option.

Repeated command with same result, except that before Mozilla Crash Report window appeared there was a quick appearance of a firefox small window. I could not make out what it was, but disappeared fast and the Mozilla Crash Report window showed up.

Screen copy would be exactly the same as before, including libcurl comment.

As far as the libcurl message is concerned - the only thing I can think of is that yesterday I just closed the Mozilla Crash Report window. Today I checked the boxes Notify Firefox about crash and gave my email address to Firefox so that they can contact me about the incident. I suppose the Mozilla Crash Report window uses libcurl to accept user input in check-boxes. But I could be wrong, as I say, I don't profess to be an expert.

Janos G. Komaromi (jankom) said : #9

Three pieces of additional information:
(1) I checked /var/log files and there is nothing obvious in them giving a clue to the firefox crash. Xorg log files also seem OK.
(2) My theory about libcurl is that Mozilla Crash Report uses curl to contact their server with the detailed crash report. It looks like Ubuntu 16.04 does not include curl into the distribution by default.
(3) My Ubuntu installation is plain vanilla. I have not done any customization, except maybe uninstalling games and pidgin. The only thing I do with it is keep it updated, keep it current. I dual boot to an old fedora-3 linux (on a second hard disk), and use normally the Fc-3 linux to play with and learn more about *ix and C. Web browsing is not working well on Fc-3 due to most of https connections, and so far I have not been able to correct this or use newer versions of browsers. This is why I use Ubuntu boot on that machine, so that I can surf the web, download stuff. There is another mysterious malfunction on the Ubuntu boot, for which I opened a bug long time ago but without any resolution. Scanner does not work, Ubuntu reports scanner busy. The scanner works from Fc-3 boot, and it works if I connect to it from my laptop Ubuntu 16.04. Anyway, this is totally unrelated to the current browser issue (firefox, chrome, and others).
Hope this helps - Janos

Manfred Hampl (m-hampl) said : #10

To be honest, I do not have an idea what might cause your problem.

Maybe the fastest solution is a new installation, what do you think of that?

Other options could be trying to debug the Firefox session, but I do not know whether that will really help finding the root cause.

For diagnostic purposes: does the command
sudo dpkg --audit
produce any output?

Manfred Hampl (m-hampl) said : #11

That is interesting: There currently are two quite similar questions about web browsers crashing
https://answers.launchpad.net/ubuntu/+question/590560
https://answers.launchpad.net/ubuntu/+source/ubuntu-release-upgrader/+question/592392

This may indicate an error in one of the packages that deserves a bug report.

Janos G. Komaromi (jankom) said : #12

(1) fastest solution - I'll try that later using the latest (Feb 2017) ISO
(2) debug firefox session - I did that and the SIGKILL comes from a process flashplugin-installer. So I did a sudo apt purge, autcoclean and autoremove. After that firefox is starting normally. In fact, I'm writing this from the other machine (the dual boot xubuntu/fc3 in xubuntu boot. Looks like one of the regular update in firefox or flashplugin-installer caused the hick-up.
(3) sudo dpkg --audit did not produce any output prior to or after removing fl;asjhplugin-installer.
How do we proceed to fix flashplugin-installer?

Manfred Hampl (m-hampl) said : #13

I suggest to try verifying this once more.

verify that the browsers are working
install flashplugin-installer
verify whether the browsers are working, and if crashing again
uninstall flashplugin-installer
verify whether the browsers are working.

If this confirms that the crash is related to flashplugin installer, then you should consider creating a bug report against flashplugin-nonfree.

(Remark, the last update of the flashplugin package was March 14, 2017)

Janos G. Komaromi (jankom) said : #14

I checked firefox now (in the meantime automatic software update went from kernel ...66 to kernel...70 - but his is besides the point), and everything works fine, including videos. I suppose this means that flashplayer or its equivalent is capable to display videos from the web.

I also checked my 64-bit laptop. It does have Shockwave Flash 25.0 r0, but my dual boot desktop which had the crashing issue does not.

When I looked in Add-ons Manager on the desktop machine there was a message from firefox that flashplayer will no longer be part of firefox because of security risks associated and mainly because a new web technology provides other methods of displaying movies. This is on 32-bit machines. They'll continue to support flashplayer for 64-bit Windows version of firefox.

Consequently, my suggestion is not to try to debug flashplayer-plugin, rather improve or modify the update system for 32-bit machines. Specifically: when updating firefox to 52 or newer on 32-bit machines remove flashplayer-plugin as part of the update process.