Can't upgrade to 14.10 due to error "Failed to fetch http://pl.archive.ubuntu.com/ubuntu/pool/universe/libk/libkgapi/libkgapi2-2_2.2.0-0ubuntu1_amd64.deb Błędny rozmiar (Invalid size)"

Asked by Olek on 2014-11-20

Message from upgrader:

Failed to fetch http://pl.archive.ubuntu.com/ubuntu/pool/universe/libk/libkgapi/libkgapi2-2_2.2.0-0ubuntu1_amd64.deb Błędny rozmiar
Failed to fetch http://pl.archive.ubuntu.com/ubuntu/pool/universe/libk/libkolab/libkolab0_0.5.2-0ubuntu1_amd64.deb Błędny rozmiar

Description: Ubuntu 14.04.1 LTS
Release: 14.04

Question information

Brian Murray (brian-murray) said : #1

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We understand the difficulties you are facing, but it is better to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. You can also find help posting your problem in the support forum of your local Ubuntu's community http://loco.ubuntu.com/ or asking at http://askubuntu.com. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs.

Manfred Hampl (m-hampl) said : #2

1. Are you aware that Ubuntu 14.10 will be supported only until July 2015 whilst Ubuntu 14.04 will be supported until April 2019?
If you upgrade to 14.10 you will have to upgrade to 15.04 and 15.10 and so on (a release upgrade every half year).

2. There might have been a temporary problem on the repository server.
Please execute the command

sudo apt-get update

and then try the upgrade again. Do you get the same error?

Olek (apyszny) said : #3

I cleared my apt-cacher cache and tried again - now it's ok. Thanks for your assist