File /var/mail/kline stays at zero-len

Asked by Gary Kline on 2014-05-13

guys,

i am completely stumped. i use mutt as i have for many years. [prev, "elm"]. i am physically disabled so that makes email essential. i am at 13.10 and until a week/week+ ago my email worked perfectly. i am not sure when email stopped, but i got it working {somehow}, mail beegan getting in. this morning, PDT, i did an apt-get update [[[or SOMETHING]]],, and the reboot icon showed up. Luckily, this was after i had exchanged emails with my docs as well as a couple friends.. upon rebooting, /var/mail/kline was 0-len. i've done everything that i cann think of, but nothing gets mail yo my user file in /var/mail.

i just noticed that if i send mail from root, on my konsole, it reads "To kline@tao" "tao" is my desktop. my volunteer sysadmin lives around 2400 clicks S.SE. of me. he was at a loss as we talked via my chat application. he was at a loss. i finally got local mail to <email address hidden> working. Not today.

Any insights?

> Include as much detail as possible: what you’re trying to achieve, what steps you take, what happens, and >what you think should happen instead.

i have fetchmail set up to bring maiil from my registrar. for a while, yesterday and early this morning, it worked. No more. i have F aliased to fetchmail. a few minutes ago,, i exed's fetchmail again. this is what shows up in /var/mail

pts/0 19:16 <tao> [5067] F /var/mail
fetchmail: background fetchmail at 11101 awakened.
pts/0 19:16 <tao> [5068] ls -ls /var/mail
total 28
 0 -rw------- 1 kline 0 May 13 13:38 kline
28 -rw------- 1 root 21604 May 13 16:55 root
pts/0 19:17 <tao> [5069]

Nothing i try gets incoming email to be displayed in /var/mail; i'd like some ideas.
i've tried traceroute to see what route mail should take to reach downntown Seattle. Zip. i'd out of ideas.

oh yeah; my sysadmin thinks i should wait a few months until he can get here and upgrade me to 14.04; i'm a bit wary about touching anything in the upgrade realm. at least nnow i can hack GTK3 and other stuff. i dont want to get stuck with a broken upgrade11.

So: ANybody??

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ubuntu-release-upgrader Edit question
Assignee:
No assignee Edit question
Solved by:
Gary Kline
Solved:
2014-05-14
Last query:
2014-05-14
Last reply:
2014-05-14

Is /var on a partition that is read only?

What is the output of :

lsb_release -a; uname -a; mount; df -h; df -i

Thanks

Gary Kline (kline) said : #2

I =think= things are startiing to work!
i've got a 4-port belkin switch. on the third button is an older version of the free version of Redhat. i didnt think it was live; but it is. or was. i've done a shutdowwn -h now. then on tao i reloaded postfix.

i havve been trying to figure out why mail wasnt showingg up here. it was queued up on "ethos", the dual/duo box that i bought used.

Can someone send me a test email to <email address hidden> ?

tx.

i'll mark this Solved once i get more email.

Gary Kline (kline) said : #3

tx, andrew