Why does ubuntu-minimal install mawk over gawk?

Asked by Chris Salch on 2019-09-16

Considering the current age of the mawk and numerous known incompatibilities with more modern tools like gawk, why is mawk currently the default in ubuntu-minimal? What would be needed to make a case for replacing it with gawk or similar?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu ubuntu-meta Edit question
Assignee:
No assignee Edit question
Last query:
2019-09-16
Last reply:
2019-09-16
Manfred Hampl (m-hampl) said : #1

There is already Bug #1841654 with a discussion about mawk vs. gawk

Can you help with this problem?

Provide an answer of your own, or ask Chris Salch for more information if necessary.

To post a message you must log in.