Fail to install ubuntu-desktop when upgrading to 14.04

Asked by leodream on 2014-06-20

I've been using ubuntu 13.10 and gnome 3.10 for a while.
Recently, I deciaded to upgrade to 14.04 but encountered some problem. And I am sure all the packages were up to date before upgrade.

1. Cannot upgrade to 14.04 in graphical
     At the begining, I tried to upgrade with invoking "update-manager -d". Everything was fine util the upgrade got into the "Installing the upgrades" stage. My GUI suddenly crashed, leaving a crusor blinking in the black. I was able to swith to tty1. And the upgrade seemed to be aborted. After I restarted the computer, the system got stuck at booting and the output messages stopped at starting the init service. Cannot swith to tty either.

2. ubuntu-desktop error occured while upgrading in command line
    I restored the system from previous backup and tried the upgrade again in command line.
    Then I executed the command "sudo do-release-upgrade -d" in tty1. The command could work as expected, but it showed a error about the ubuntu-desktop at the end of the output.
    After rebooted, I was able to login the system was fine. The Setting/Detail indicated the version was 14.04. But I got unmet dependencies warring about the ubuntu-desktop when executing to "sudo apt-get upgrade". Just like this:

     Reading package lists... Done
     Building dependency tree
     Reading state information... Done
     You might want to run 'apt-get -f install' to correct these.
     The following packages have unmet dependencies:
       ubuntu-desktop : Depends: ubuntu-session but it is not installed
                  Recommends: empathy but it is not installed
                  Recommends: ibus-pinyin
                  Recommends: ibus-table but it is not installed

Any help would be appreciated.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu ubuntu-meta Edit question
Assignee:
No assignee Edit question
Last query:
2014-06-20
Last reply:
2014-06-22

If you can wait until next month when Trusty goes to the first point release (14.04.1) it will be offered to you.

leodream (leodream2008-8) said : #2

Hi,
Do you mean such upgrade (from gnome 3.10) is not supported currently? Or something like a bug will be fixed ?
Thanks.

Manfred Hampl (m-hampl) said : #3

What is the output of the following terminal commands:

uname -a
lsb_relase -a
sudo apt-get update
sudo apt-get install -f
sudo dpkg --audit

Can you help with this problem?

Provide an answer of your own, or ask leodream for more information if necessary.

To post a message you must log in.