Unity is broken

Asked by Dave Jury on 2014-06-07

I have 14.04 Trusty installed, and I have broken it somehow while trying to fix the issue of resume from suspend (this is a separate issue). Now, after logging in, instead of the unity task bar I get "Activities" at the top (is this Gnome desktop?). So, I can use this to open a terminal, and run "dconf reset -f /org/compiz/" and then "setsid unity".

Now I get unity back (yay!) but when I reboot it doesn't stay there (boo!). Also, under System Settings my "Appearance" icon is missing and probably a few others I haven't noticed).

I have done ctl-alt-f1 and in the tty I have run "sudo apt-get install --reinstall unity" and "sudo apt-get install --reinstall ubuntu-desktop". Neither of these seem to help either.

Does anyone have any ideas, please, on how I can reset whatever could be broken so unity restarts. I do have a full backup, but it's a painful route to restore and then update with latest emails, documents etc changed since the backup.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ubuntu-meta Edit question
Assignee:
No assignee Edit question
Solved by:
Dave Jury
Solved:
2014-06-07
Last query:
2014-06-07
Last reply:
Dave Jury (djury-e) said : #1

I have fixed it now, through sheer blind luck, and in spite of my tremendous ignorance.

Here's what I did in a terminal window (not tty):
"sudo apt-get remove gnome-shell"
"sudo apt-get remove compiz" (this removed ubuntu-desktop and unity as well)
"sudo apt-get install ubuntu-desktop (this installed compiz and unity as well)

That's it! Fixed! I still don't know why gnome-shell would be messing this up, but just removing and installing compiz, ubuntu-desktop and unity on their own without removing gnome-shell didn't work.