Precise won't let me login

Asked by John Rose on 2013-01-02

I've just tried a clean install using Ubuntu 12.04.1 32 bit. After installing, it wouldn't boot. So I did a 32 bit boot-repair. It then booted & I logged in. I then invoked Update Manager. I chose the 100+ (or was it 200+) item update after the check. It system crashed with some stuff about jockey-gtk I think. Update manager said that I should Restart, so I did. I rebooted but I can't log in as the keyboard & mouse are frozen. Only interesting thing that I noriced is that the boot menu shows a PAE version of Ubuntu. My PC is 5+years old & has 2GB. What should I do?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ubuntu-meta Edit question
Assignee:
No assignee Edit question
Solved by:
John Rose
Solved:
2013-01-02
Last query:
2013-01-02
Last reply:
2013-01-02
Warren Hill (warren-hill) said : #1

Ubuntu 12.04 has a PAE Kernal so wont run on processors that don't support PAE. That being the case I'm surprised it installed as the installer should check for this.

If your computer is old enough that it can't support PAE then running Ubuntu 12.04 even with a non-pae kernel you probably would find it too slow to use comfortably.

I would recommend Lubuntu 12.04, Lubuntu 12.10 has PAE kernel so wont work. However 12.04 was non PAE.

Download is here

http://cdimage.ubuntu.com/lubuntu/releases/12.04/release/

Or take a look here

http://www.webupd8.org/2012/05/how-to-install-ubuntu-1204-on-non-pae.html

If your computer

N1ck 7h0m4d4k15 (nicktux) said : #2

Hi ,

when you stuck at login screen press CTRL+ALT+F2 and login to console mode. Give username & password.

Then apply the commands below one at time

sudo apt-get purge nvidia* fglrx*
sudo apt-get install --reinstall ubuntu-desktop
rm ~/.Xauthority
sudo apt-get install -f
sudo apt-get update
sudo apt-get dist-upgrade

Then reboot with command

sudo reboot

and see if problem solved.

TIP: Write down above commands carefully because in console mode you will not have a desktop environment.

Thanks

Also, if you run:

df -h

Do you see free space on your partitions?

John Rose (johnaaronrose) said : #4

I got round the 'stuck at login' by rebooting followed by selecting the recovery linux kernel. The mouse & keyboard still wouldn't workd so I moved them to different usb sockets & I could use them! All was OK (with proper restart with normal linux module) after doing the appropriate things in recovery..

I assume that the PC is PAE since it's now OK.

BTW df -h showed lots of free space on partitions.