After update, most OS text changed to oriental script

Asked by Mark Stock on 2012-11-18

I installed 12.10 four days ago (my first time with Ubuntu after being with Fedora for 10+ years), and I just accepted an automatic update. It told me to restart, and I did. When it came up, most of the dialog boxes in the OS and firefox are now in an oriental symbol script. Since I can't read it, I don't know how to change it back to all-English. Plus, a large number of my customizations are now gone/reset to default.

Here is a screen-capture of what I am dealing with: http://markjstock.org/tr/switchedToKanji.png

Does anyone know how to change this back?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ubuntu-meta Edit question
Assignee:
No assignee Edit question
Solved by:
Mark Stock
Solved:
2012-11-18
Last query:
2012-11-18
Last reply:
2012-11-18

Get to the point you are at in your screenshot. Use the left hand tab and drop down the top most dropdown box and choose your language

Also click the button underneath to apply systems wide.

Mark Stock (mstock-v) said : #3

HI! Thanks for the tip, but I'm afraid it didn't work.

One thing I didn't mention earlier was that when I opened the language settings window, a dialog box opened that looks like this:
http://markjstock.org/tr/switchedToKanji2.png
I always clicked on the left button because I was pretty sure that was the "cancel" button, and I didn't want to mess more things up.

When I open the left tab, this is what I see:
http://markjstock.org/tr/switchedToKanji3.png
Which button applies the settings system-wide?

Could this problem be related to the fact that most of my other settings have been reverted? For example, all of my modifications to the window manager keyboard shortcuts are gone, everything from gnome-tweak-tool was reverted, etc.

Thanks again!

Try the right hand one. I am not presented with that dialogue.

Mark Stock (mstock-v) said : #5

The "apply system wide" button is the top of the two buttons.

But I found out that the ~/.pam_environment file can just be edited. I made sure that the following two lines were in there:

LANGUAGE=en_US.UTF-8
LANG=en_US.UTF-8

They had been set to "zh", for Chinese, I presume.