Can't login as "no space" left

Asked by Paul Brown on 2012-11-11

I installed Ubuntu 12.04 Windows loader version several weeks ago onto a newly bought desktop PC with an 80Gb hard drive. I'm not sure how it manages to work sharing a partition with Windows XP Professional. Neither OS can find any sign on the other OS on the drive. Before this, I always used Ubuntu on a partitioned drive. Earlier today, after going to bed very late last night, I got up, and found I could no longer login to Ubuntu, no matter what I tried. The main problem is various reports of "no space left on device". I've downloaded several video files using the Transmission torrent client and have recently been getting error messages something like "Can't save resume file. No space left on device". I checked my remaining disk space using Disk usage analyser, which told me I still had over 50% free. After this, I wondered what device Transmission was referring to. I managed to resume the downloads by quitting Transmission and/or rebooting. Today, I've found that I can't login and can't get round this or fix the problem using recovery mode in any Linux Kernal version I have available through GRUB, because there is "no space left on device". I've tried using Clean which reported the same error, but went on to say something like 17Gb used 100% full. Finally, I tried FSCK which I left running for over 5 minutes without any indication it was doing anything at all. How did this problem occur without me getting any warnings of how much disk space was left and how do I fix it?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ubuntu-meta Edit question
Assignee:
No assignee Edit question
Solved by:
Joakim Langvand
Solved:
2012-11-15
Last query:
2012-11-15
Last reply:
2012-11-15

If you press CTRL+ALT+F1 and log in there, you can run:

sudo apt-get clean

Then press CTRL+ALT+F7 and log in, may help. I suggest you remove old kernels once you get logged in

Paul Brown (roughcut35) said : #2

I pressed CTRL+ALT+F1, which gave me the login prompt. Unfortunately, I'm not used to logging in to Linux at a text prompt. I had to type an account name, which I thought was either Administrator, Admin, Paul, or Paul Brown. I then typed the password and it said "login incorrect". I also had an account called Guest set up, with I don't think required a password at all, so then I just pressed Enter at the password prompt. That also resulted in the message "login incorrect". I then typed the password fred, followed by Fred, but both these attempts still got the response "login incorrect". What should I try next?

Joakim Langvand (jlangvand) said : #3

Your username is probably "paul", lowercase without quotes. Try that. When you set up your account, you were asked to enter some info about yourself. As far as I remember, the username field defaults to your first name when you enter your full name.

You can also get a hint from the prompt on the screen. It may say something like "paul-computername login: ", where in this case "paul" would most probably be your username.

I'd also run fsck in liveCD. You can also use it to find out your username by acessing your internal partition and looking in the home folder, the names of the folders are the usernames on the system.

Paul Brown (roughcut35) said : #5

OK, I'll have to try a live CD then. Unfortunately, I haven't got a CD of Ubuntu Linux at the moment. Can I use a CD from a magazine if it contains any other distro except Ubuntu? I originally installed Ubuntu onto a laptop from V9.10, but both those CDs are either lost or damaged now.

Sure as long as the distro can read, write etc Ext4 (Which modern distros do).

Paul Brown (roughcut35) said : #7

As I thought you'd know, because I installed using the Windows loader, the whole hard drive is still formatted in NTFS. This doesn't matter, does it? I thought Linux could read virtually any format of hard drive, although Windows is limited to NTFS, FAT32, and FAT16.

Paul Brown (roughcut35) said : #8

The latest news is as follows.

I bought a copy of Linux Format magazine No. 165. This has a DVD containing live versions of the distros AntiX and Trisquel, which I'd never heard of before.

Unfortunately, it seems that neither of these live distros can see the files I've created or downloaded under Ubuntu 12.04 wubi version. I found a folder called Ubuntu, but this only contains the most basic stuff about installing and uninstalling that distro.

I now think that what I need is a way of seeing these files which have been hidden from view, in spite of being on the same partition. Can anyone tell me how to do this?

Joakim Langvand (jlangvand) said : #9

Alright, I had to read up a bit. I`ve never touched the Wubi installer (ditched Windows totally), but it seems like you should have a disk image residing in C:\ubuntu\disks\root.disk. That could probably be opened in some way in Windows.

That means you`re quite right your disk is partitioned with NTFS, but Ubuntu boots up a virtual disk formatted using Ext4.

Another solution would be to boot Ubuntu in single-user mode, then type `ls /home`.

Paul Brown (roughcut35) said : #10

I've clicked on the root.disk image, but I just get a message telling me that Windows doesn't know how to open this file.

I've never heard of any "single-user mode" under Ubuntu or any other Linux distro. Please explain how I could select this mode.

Since my last post, I've found a way to view "hidden files" under Windows. All I did was go through the right path to a window where I can click on an option to view hidden files. This allows me to view various files in the Windows folder, where you normally can't view any files. Unforuntately, there's no sign of files created using Ubuntu Linux. I also searched for files with the extension .avi , but all I found was one Windows file.

I feel that in about two days from now I'll have to reformat my hard drive. I hoped to get rid of Windows altogether, but when I installed Ubuntu Linux using wubi , I had very little money at all, so I didn't want to buy a blank CD. After this, I was convinced to keep my Windows installed to run games which wouldn't run under WINE or even under Crossover.

Joakim Langvand (jlangvand) said : #11

1) You`re right - Windows won`t be able to open this file directly. You will need a program to "mount" this disk, so Windows can see it as a hard disk, just like Ubuntu does when you boot it. Then you will need another program to read the Ext4 file system. It might be a bit complicated, and as I`m no Windows user, I`m sorry I can`t help you there.

2) To boot in single user mode, you will have to bring up the GRUB menu. GRUB is the program that makes Ubuntu able to boot, just as the black menu where you can choose between Windows and Ubuntu is a part of Windows` bootloader. Again, I`ve never used Wubi, but i suppose you can bring the GRUB menu up by pressing the escape key just after you`ve selected Ubuntu, after turning on the computer. If that doesn`t help you can try holding shift.

In the menu, select Recovery mode. When you get a menu on the screen, you can select Drop to Root Shell (or something similar, I don`t remember exactly). When you get to a command line, you can type:

ls /home

..which should give you a list of usernames (or, actually the users home folders, which has the same name as their respective users)

3) No, that won`t help as all Ubuntu`s files resides in one single file, which is unreadable by Windows.

4) I hope you`ll be ready for the switch one day :) see bug #1

Paul Brown (roughcut35) said : #12

Thank you so much!

I managed to log in based on your advice, by doing the following. From GRUB I selected Recovery Mode, then drop to Root Prompt. Once there, I typed ls /home , which is a version of this command I'd never heard of before. This listed one account name, based on my name Paul Brown, but in a format I hadn't used before. I typed the exact name from the list, followed by the password. This logged me in! After that, I was able to use ls and cd. I used cd to get to the Downloads folder and did an ls of the files there. Unfortunately, when I typed rm , followed by a filename including the * character, but which matched only ONE of the large .avi files, I was told that the Filesystem was read only.

So, to sum up, I can now log in to my Ubuntu installation, but I need to log in to the Filesystem while it's set to Read/Write. How do I do that?

sudo mount -o rw,remount /

Will make it writeable

Paul Brown (roughcut35) said : #14

Here's what happened.

First of all, I should ask that I wonder exactly where spaces should or shouldn't be left in this command. I tried it both without a space following the comma, as well as with a space, but it made no difference. I always left a space after remount and before / .

The output of this was as below, where my account name is paulb

Unable to open /var/lib/paulb/console: Read-only file system
mount: Special device remount does not exist

I also wondered why I needed to type sudo , because I'd logged in from the root prompt. Without sudo I got the message

mount: only root can do that

I have no way of backing up any Linux files AFAIK, my patience is running out and I plan to reformat my hard drive late on Friday night/Saturday morning GMT. I will probably then partition the hard drive as 60Gb for Linux and 20Gb for WIndows so I can run some WIndows games.

Joakim Langvand (jlangvand) said : #15

Hi Paul

Now that you`ve figured out your username, the easiest way to log in and delete files would probably be to boot Ubuntu, press ctrl+alt+F1, and log in there. From there, you can use cd, ls and rm to find and delete unneeded files, so you can log in as normal again.

`df -h` and `du -h` can come in handy, too - you can use them to see used and free space.

But a reinstall would probably be the easiest solution in the long run. If you want to dual boot, I recommend installing Windows first. Make sure to leave free space on the disk for Ubuntu. Then you can boot from the Ubuntu install CD/DVD and install Ubuntu from there - just make sure you let Ubuntu create its partitions in the free space left by Windows. It`s quite easy using the Ubuntu installer. After the install, GRUB will let you choose which OS to boot when you turn on the computer. If you do it the other way around, Windows will overwrite GRUB, and Windows starts automatically without letting you choose.

Paul Brown (roughcut35) said : #16

Thanks Joakim! I managed to log in by pressing those three keys. The first thing I did was to delete all the torrent files instead of any video files, then I was suddenly presented with a graphic login screen for the first time in a few days! From there, I managed to log in and bring up a window of the Downloads folder. I typed df -h and it said I was still using 100% of 17Gb. I deleted one video file, as well as a few .zip and .lha archives, now it says 99% used and 314Mb free. These figures are all for the Filesystem /dev/loop0 which I don't think I'd ever heard of before I had this problem. I can't help wondering where this 17Gb limit came from.

Best Joakim Langvand (jlangvand) said : #17

I thought I ansvered you hours ago. Must`ve missed the comment button..

Anyway, I`m glad to hear you made some progress! The 17GB limit probably comes from when you installed using Wubi. It`s more than enough to run Ubuntu, but with daily desktop use, it`ll be filled up quite rapidly.

You can try deleting some more stuff you don`t need. If you have an external hard drive, you could use that for storage, and just keep the system in Ubuntus virtual disk. If you can access Windows` partition from Ubuntu, a good idea would be to store things like movies and music there. That way, both Ubuntu and Windows can access the files.

Paul Brown (roughcut35) said : #18

Thanks Joakim Langvand, that solved my question.