when i reboot into a different ubuntu, the time is 4 hours different, but both /etc/localtime's are the same. where is the setting that controls whether the hardware is set to UTC or not?

Asked by gregrwm on 2012-10-20

when i reboot into a different ubuntu, the time is 4 hours different, but both /etc/localtime's are the same. where is the setting that controls whether the hardware is set to UTC or not?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ubuntu-meta Edit question
Assignee:
No assignee Edit question
Solved by:
marcobra (Marco Braida)
Solved:
2012-11-01
Last query:
2012-11-01
Last reply:
2012-10-21

Try:

sudo ntpdate ntp.ubuntu.com

gregrwm (gregrwm) said : #2

yes ntp is able to correct the time, but still, whenever i boot into the other ubuntu, i get the 4 hour time difference again. i believe there's a setting somewhere that controls whether the hardware clock is set to local time or UTC. i just don't know where to find that setting.

then run:

gksudo gedit /etc/rc.local

above the 'exit 0' line, add:

ntpdate ntp.ubuntu.com

Save the new file, close gedit, reboot to test. It should get you by til you can work out what is going on. Once you do, remove the line from the file :)

Look into the /etc/default/rcS setting...

gregrwm (gregrwm) said : #5

Thanks marcobra (Marco Braida), that solved my question.