Oneiric crawls on my 1 GB RAM laptop

Asked by KushalSharma

I upgraded to Oneiric on my Lenovo N100, 3000 series laptop.

Oneiric literally crawls on this laptop and I'm unable to understand why.

 I see my RAM usage, and it's usually never 500 MB (unless I have some app on or leave Opera browser with its 200 MB appetite on for long).

Despite this, my apps don't open up quickly, the shutdown takes forever, and the "alt+tab" is so slow I don't even use it anymore -- I just open windows in different virtual desktops and do ctrl+alt-arrow to navigate between different windows.

Maverick worked like a charm on this computer (I went straight from Maverick to Oneiric), and every other version I've had before that (Lucid, Karmic, Jaunty, Intrepid, and Hardy) have all worked amazingly fast. In fact, it would shut down within 5-7 seconds. But now, it takes longer for that shutdown screen to even show up, and then that screen goes through 3 - 4 rounds of those dots before the system completely shuts down.

How do I figure out what's wrong? I went to a Best Buy and got the hardware checked out. They said everything seemed OK. Here's another weird thing: I created a startup disk on a 16 GB external portable hard drive with Kubuntu 11.10 on it. When I use Kubuntu from that USB disk on this same laptop, it works faster than Oneiric does from the hard disk. Is that normal?

Let me know if I can use the terminal to understand if there's something wrong, or if I should just put a lighter version of Ubuntu and forget about Unity before I get a new, more powerful laptop.

Question information

English Edit question
Ubuntu ubuntu-meta Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Joel Pickett (jpickett) said :

I'd try out Xubuntu or Lubuntu. They don't come with Unity but you'll be able to confirm if the performance issue is Unity-based.

Revision history for this message
actionparsnip (andrew-woodhead666) said :

Install the lxde package, log off then log in to the lxde desktop.

What GPU does the system have?

Revision history for this message
KushalSharma (kushalsharma83) said :

Here's what output of the lspci command (was I supposed to do this?)

kushal@kushal-laptop:~$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)

Let me know if you need any more information.

Revision history for this message
actionparsnip (andrew-woodhead666) said :

Sure, dead useful. Not the most powerful GPU but should be ok

Did you try lxde?

Revision history for this message
KushalSharma (kushalsharma83) said :


Sorry for the late response -- had the final part of the semester coming up so couldn't concentrate on other stuff. Nope, I haven't tried LXDE, but maybe I could. I just installed Kubuntu Oneiric today, and it seems to run a little faster than Ubuntu.

I'm wondering, however, what made Ubuntu's previous versions (Karmic and before that) run so fast on this very same system... Shutdown would take less than 5-7 seconds, and on the same computer, Oneiric takes about 30-35 seconds. Of course, this is still miles ahead of Windows and I'm not complaining -- I'm just a little confused about why this would happen...

Revision history for this message
actionparsnip (andrew-woodhead666) said :

Different driver versions, different Xorg, different kernel. You could report a bug too

Can you help with this problem?

Provide an answer of your own, or ask KushalSharma for more information if necessary.

To post a message you must log in.