there are two choices"versions" from different channels to upgrade the package "ubuntu-drivers-common" in ubuntu 20.04.2

Asked by Hesham Mohamed Khalil Youssif Ali on 2021-02-07

after running "sudo apt update"

it showed me that there is 1 package can be upgraded

then i run apt list --upgradable

it showed me :

Listing... Done
ubuntu-drivers-common/focal-updates 1:0.8.6.5~0.20.04.1 amd64 [upgradable from: 1:0.8.6.4~0.20.04.1]
N: There are 2 additional versions. Please use the '-a' switch to see them.

----------------------------------------------------------------------------------
then run the "apt list --upgradable -a" to see the additional versions

is showed me :

Listing... Done
ubuntu-drivers-common/focal-updates 1:0.8.6.5~0.20.04.1 amd64 [upgradable from: 1:0.8.6.4~0.20.04.1]
ubuntu-drivers-common/now 1:0.8.6.4~0.20.04.1 amd64 [installed,upgradable to: 1:0.8.6.5~0.20.04.1]
ubuntu-drivers-common/focal 1:0.8.1 amd64

-----------------------------------------------------------------------------------
then to check the version of ubuntu-drivers-common

i run the following command :apt-cache policy ubuntu-drivers-common

it showed me :

ubuntu-drivers-common:
  Installed: 1:0.8.6.4~0.20.04.1
  Candidate: 1:0.8.6.5~0.20.04.1
  Version table:
     1:0.8.6.5~0.20.04.1 500
        500 http://eg.archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages
 *** 1:0.8.6.4~0.20.04.1 100
        100 /var/lib/dpkg/status
     1:0.8.1 500
        500 http://eg.archive.ubuntu.com/ubuntu focal/main amd64 Packages

--------------------------------------------------------------

***and notes that the package version from "focal" channel reposatory is really old ( 1:0.8.1) and the is the installed one is (1:0.8.6.4~0.20.04.1 )

what should I do ?
----------------------------------------------------
these are the channel reposatories that are in use in my configration:

deb http://eg.archive.ubuntu.com/ubuntu/ focal main restricted
deb http://eg.archive.ubuntu.com/ubuntu/ focal-updates main restricted
deb http://eg.archive.ubuntu.com/ubuntu/ focal universe
deb http://eg.archive.ubuntu.com/ubuntu/ focal-updates universe
deb http://eg.archive.ubuntu.com/ubuntu/ focal multiverse
deb http://eg.archive.ubuntu.com/ubuntu/ focal-updates multiverse
deb http://archive.canonical.com/ubuntu focal partner
deb http://security.ubuntu.com/ubuntu focal-security main restricted
deb http://security.ubuntu.com/ubuntu focal-security universe
deb http://security.ubuntu.com/ubuntu focal-security multiverse

**there is no ppa
------------------------------------------------------------------
information about OS.

OS: Ubuntu 20.04.2 LTS x86_64

Kernel: 5.4.0-65-generic

Shell: bash 5.0.17

DE: GNOME 3.6.8

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ubuntu-drivers-common Edit question
Assignee:
No assignee Edit question
Solved by:
Bashing-om
Solved:
2021-02-08
Last query:
2021-02-08
Last reply:
2021-02-08
Best Bashing-om (bashing-om) said : #1

Hello esham Mohamed Khalil Youssif Ali -

As to "what should I do ?" --- well, do:
sudo apt update
sudo apt upgrade
Which will bring in the lastest version that the repository hold, 1:0.8.6.5~0.20.04.1 . Though the repo does indeed hold older versions.

My updated system:
" sysop@2004x-c:~$ apt list ubuntu-drivers-common
Listing... Done
ubuntu-drivers-common/focal-updates,now 1:0.8.6.5~0.20.04.1 amd64 [installed]
N: There is 1 additional version. Please use the '-a' switch to see it

sysop@2004x-c:~$ apt policy ubuntu-drivers-common
ubuntu-drivers-common:
  Installed: 1:0.8.6.5~0.20.04.1
  Candidate: 1:0.8.6.5~0.20.04.1
  Version table:
 *** 1:0.8.6.5~0.20.04.1 500
        500 http://mirror.steadfast.net/ubuntu focal-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     1:0.8.1 500
        500 http://mirror.steadfast.net/ubuntu focal/main amd64 Packages
sysop@2004x-c:~$ "

-my bit to try and help-

Thanks Bashing-om, that solved my question.