gpu-manager should be disabling UBB when using nvidia proprietary drivers on Quadro based chipsets

Asked by Sidrew on 2020-10-10

Is there any way to get gpu-manager to disable the UBB feature of the proprietary nvidia drivers when using Quadro chipsets? This is recommended by nvidia in such a configuration when trying to run vulkan based games. Surely gpu-manager can detect this and disable it, no? From the nvidia driver search page:

Known issue:

Vulkan with flipping enabled on Quadro cards can lead to graphic corruption. If you think you have run into it you can do either of the following as a workaround:

- Disable flipping in nvidia-settings (uncheck "Allow Flipping" in the "OpenGL Settings" panel)
- Disable UBB (run 'nvidia-xconfig --no-ubb')
- Use a composited desktop

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu ubuntu-drivers-common Edit question
Assignee:
No assignee Edit question
Last query:
2020-10-10
Last reply:
Daniel Letzeisen (dtl131) said : #1

Well, I'm not an Ubuntu dev, but to me, it wouldn't make sense to disable UBB or flipping by default if they help with performance, unless a lot of Quadro users are having problems with Vulkan.

Also note that Ubuntu's default desktop/WM (GNOME/Mutter) as well as many of Ubuntu's "flavors" use compositing by default, which should make this much less of an issue.

If you're looking for a definitive answer, it's probably better to file a bug if you still think UBB should be disabled by default.

Can you help with this problem?

Provide an answer of your own, or ask Sidrew for more information if necessary.

To post a message you must log in.