9.10 ─┐ive cd not recognizing my hard drive to install ubuntu

Asked by Pieter16 on 2009-12-24

I have read relentlessly for about the last 7 hours now and tried everything that I could come up with. I am a noob to ubuntu but not computers.

Steps taken:

1 downloaded the latest Live CD and burned it properly onto disc.
2 used the shrink feature of vista to create a 3 gb unallocated partition
3 booted from cd and proceeded to installation
4 When the proceeding past the keyboard layout the install cd requested to use a 4gb usb drive I had mistakenly left in
5 I went back a step and then removed the usb key and proceeded to the next section (partition creator), but it did not recognize any drive to install to or create a partition on and I could not longer continue. The only option given at this point was a revert command.
6 I then cancelled install and rebooted to the virtual environment running of of the disc.
7 I used GParted to create a 6GB ext3 partition but have not had any options to configure the partition to / or \ root or whatever
8 I created a 16GB linux-swap partition for the swap, and again I did not have an option to give the drive the / \ swap name
9 I re-entered the installation from the available install icon on the ubuntu desktop provided
10 Still could not progress past the step described above as no drive or partition or anything for that matter was being recognized.
11 Rebooted into windows to check with ComputerManagement to ensure the partions were created properly. They showed up as healthy primary partitions.
12 Retried the install again with no success on drive or partition being recognized

Am I missing something? I am at a complete loss now other than to try downloading and creating another install live cd.

If any other details are needed please ask and I would like to say thank you ahead of time for any effort that anyone puts into helping me out

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ubuntu-docs Edit question
Assignee:
No assignee Edit question
Solved by:
hadi
Solved:
2009-12-28
Last query:
2009-12-28
Last reply:
2009-12-26
Pieter16 (babby18-sk8) said : #1

I have also found that the next time I attempted to install the OS using the ext3 partition created whilst still having the usb and another external HD plugged in, I received a question that I have not got before this. It was something along the lines of either:

There appears to be unmounted or mounted drives. Would you like to have them mounted / unmounted now.
                               * I can not remember which option it gave. To mount or unmount.

Either way I clicked the x not thinking and hoping that it would pop back up next time I tried to install it, but I have yet to receive that message again.

Could it be that the partition I created (ext3) is either not mounted or mounted and I need to do the opposite to get the install cd to recognize the partition in order to install it there?

Pieter16 (babby18-sk8) said : #2

So, after remembering that I have not verified the message or the drives that were mounted and need to be unmounted I attempted the install again to see if I could get the message. I did and this is exactly what popped up with both a usb key and an external HD plugged in as you can tell from the drive names:

The installer has detected that the following disks have mounted partitions:

/dev/sdf, /dev/sdg

Do you want the installer to try to unmount the partitions on these disks before continuing? If you leave them mounted, you will not be able to create, delete, or resize partitions on these disks, but you may be able to install to existing partitions there.

This is obvious now that it is not the problem and I can still not install to the partition created.

Another thought that I had was to delete the two partitions that I created using GParted and go back to the Shrink Volume method using Vista. The issue here is that I have already done that and it did not recognize the unallocated partition at a size of about 2.9Gb.

Best hadi (modarres-zadeh-gmail) said : #3

hi
i had the same problem as yours with ubuntu 9.10
try this :
when you boot with live cd remove this package : dmraid
if you dont know how to do that type this command in the terminal :

sudo apt-get purge dmraid

or simply run the synaptic package manager search for dmraid package and remove it .
and then run the installer .

Pieter16 (babby18-sk8) said : #4

Thanks hadi, that solved my question.

Pieter16 (babby18-sk8) said : #5

Thank you, thank you, thank you hadi!

I cannot believe that I could not find that out on my own over the 2 days I spent trying to get it installed.

It worked and now I understand what my problem was.

Cheers