9.10 Dual Boot

Asked by Skeezics on 2009-11-11

I just installed Ubuntu 9.10 on my system which already contains Windows XP . It installed itself in a previously unallocated portion of my hard disk along with a small swap drive. When I boot up the computer, the boot menu shows Ubuntu as item number 1. Then Ununtu in recovery mode, then 2 memory test choices and finally Windows XP as item 5. I would prefer XP to be first until I get familiar with Ubuntu. Also, my wife will go crazy on me. I have no previous experience with "Linux" systems. I remember a few commands from an old Unix system at work many years ago. The documentation shows that GRUB 2 is now being used, but it is quite confusing.

If I am reading correctly, I should change /etc/default/grub ...... the first line 'grub default = 0' to 'grub default = 4' (4 being the fifth item). Then run sudo update-grub. Is that correct? Thanks in advance.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ubuntu-docs Edit question
Assignee:
No assignee Edit question
Solved by:
Luke Jennings
Solved:
2009-11-14
Last query:
2009-11-14
Last reply:
2009-11-11
Best Luke Jennings (ubuntujenkins) said : #1

You are right. The commands you need to run are as follows just so it is clear.

cd /etc/default
sudo gedit grub

you may have to enter your user password, then change the value to what ever value you need it to be, save it, then close it.

Then run

sudo update-grub

Hope this is alright, you seam to have a clear idea of it already just thought i would make it clear.

Skeezics (rcflyer4) said : #2

Thanks very much. That worked perfectly. I still have to read up on why
'sudo' has to be used. Typing commands again is taking me back to DOS 5.0

On Wed, Nov 11, 2009 at 5:49 PM, UnbuntuJenkins <
<email address hidden>> wrote:

> Your question #89749 on ubuntu-docs in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/ubuntu-docs/+question/89749
>
> Status: Open => Answered
>
> UnbuntuJenkins proposed the following answer:
> You are right. The commands you need to run are as follows just so it is
> clear.
>
> cd /etc/default
> sudo gedit grub
>
> you may have to enter your user password, then change the value to what
> ever value you need it to be, save it, then close it.
>
> Then run
>
> sudo update-grub
>
> Hope this is alright, you seam to have a clear idea of it already just
> thought i would make it clear.
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
>
> https://answers.launchpad.net/ubuntu/+source/ubuntu-docs/+question/89749/+confirm?answer_id=0
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+source/ubuntu-docs/+question/89749
>
> You received this question notification because you are a direct
> subscriber of the question.
>

sudo = Super User DO [something]

It is like the "Run as administrator" option in Windows. It's safer than logging on as user "root", but if you need to do anything that affects the system as a whole (as opposed to user related files) you will need elevated rights.

Skeezics (rcflyer4) said : #4

My problem is solved...... everything works great

Skeezics (rcflyer4) said : #5

Thanks UnbuntuJenkins, that solved my question.

Moshe Dayan (mosh-day) said : #6

Moshe Dayan suggests this article as an answer to your question:
FAQ #65: “Dual Booting windows and *buntu”.