How do I find my admin password?

Asked by bhjohnston on 2009-04-28

I have a Dell Mini 9 with Umbuntu installed. As I don't recall entering an admin password, I have to assume that it either came from Dell or from Umbuntu. There is no info in the printed documentation that came with the netbook. Is there a 'standard' admin password from the Umbuntu install, or is this a Dell question? Thanks for any help.

bhjohnston 28APR2009

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ubuntu-docs Edit question
Assignee:
No assignee Edit question
Solved by:
S.Vikash Koushik
Solved:
2009-04-29
Last query:
2009-04-29
Last reply:
2009-04-29
midnightflash (midnightflash) said : #1

Usually you should have been aksed for a passwd for your (first) user.
This user has admin-rights. You will be asked for that passwd if you want to change system-settings.

Greetings

bhjohnston (bhjohnston) said : #2

I have somewhat of a 'standard' password that I use for similar situations. I have tried it, and a couple of other guesses, with no luck. Thus, I want to believe that an admin password was entered before I got the unit. The problem is that there are multiple software updates to be downloaded and I cannot do that without the admin password. I think that I might pose this question to Dell to see if they might have a clue.

I know that there must be a way to work around this with a 'lost password' procedure, but I was trying the direct assault first.

Again, thanks for any help.

bhjohnston 28APR2009

midnightflash (midnightflash) said : #3

If you forgot you password for your ubuntu system you can recover using the following steps

Turn your computer on.
Press ESC at the grub prompt or at the beginning of the boot (before that Ubuntu-logo is seen).
Select the RECOVERY-kernel and then enter.
Your system will boot up to a passwordless root shell.

There type (and don't type the "#"):

# passwd [YOURUSERNAME]

(while [YOURUSERNAME] should be your username)
and give the NEW password twice.

then type:

# shutdown -r now

Your system will do a reboot.

That should do it.

greetings

bhjohnston (bhjohnston) said : #4

Thanks for trying to help me, but I think that I am messing things up more. Not knowing what the 'grub' prompt was to look like, I have tried pressing Esc a couple of time during the initial part of the boot process. The first time, I was too late and the computer continued to boot. But, the second time, I am not sure what I did, as the boot continued, but the touch pad/cursor was locked out. I could not figure out how to shut down! I'll continue trying to see what I have done. There is a 'Ubuntu 8.04+ LTS Recovery Media' disk that came with the computer. So, I guess reloading Ubutu might be an option.

bhjohnston 28APR2009

midnightflash (midnightflash) said : #5

Would not be my option... but indeed it is an available option.

bhjohnston (bhjohnston) said : #6

Had to start this one again, as Firefox crashed for the third time in the last 2 days! Something new since the last software update.

Back to my original question: I don't know if Dell has messed with the Linux start-up options, as I never saw any options (e.g. 'RECOVERY-kernel') when I pressed Esc during the system start up. The first thing that I see is a faint Dell screen with a tracker showing something is loading. Then, I see several characters in the upper left corner of a black screen. Finally, I see the 'Ubuntu' logo. I have pressed Esc when I see the screen with the few characters, and afterwards, when those characters leave the screen. All times after I have pressed Esc, the computer continues to boot and the cursor is 'locked up'.

Should I press Esc just after I turn the power on, as there is a blank screen just before I seen the initial screen with the Dell name and indication that something is loading? Because of that screen, I am wondering if Dell hasn't messed with the Linux start-up.

bhjohnston 28APR2009

Hey bhjohnston,

     By default there won't be any root password assigned.Just go into your account and open the terminal from Applications -> Accessories.There type sudo su root. Now type passwd.You will be asked to type the password twice.This will create your new password for the root.

(NOTE: While typing the password,the characters will not appear.)

Good Luck

bhjohnston (bhjohnston) said : #8

Problem solved!

Thanks to 'S. Vikash Koushik' and 'midnightflash' for your help. I don't know why I couldn't solve the problem with the initial instructions, but it has been solved.

Again thanks.

bhjohnston 29APR2009

bhjohnston (bhjohnston) said : #9

Thanks S.Vikash Koushik, that solved my question.