Firefox repeatedly crashing since Ubuntu Upgrades 01-11-2019

Asked by Snooper on 2019-01-12

Firefox repeatedly crashing since Ubuntu Upgrades 01-11-2019

The Ubuntu Default Firefox Browser was performing well until the most recent 16.04LTS Upgrades of 01-11-2019. Now it is repeatedly Crashing Both Tabs and the entire browser on Various Web Sites and pages. What was changed to cause this sudden and erratic browser behavior? And, When will it be remedied? I am fastidious about updating/upgrading Ubuntu Daily. And this date is precisely when that upgrade was released/implemented.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ubuntu-docs Edit question
Assignee:
No assignee Edit question
Solved by:
Snooper
Solved:
2019-01-23
Last query:
2019-01-23
Last reply:
2019-01-20

If you disable extensions / addons does it work OK?

Manfred Hampl (m-hampl) said : #2

There is no way that anybody else knows which package updates have been installed on a certain day except yourself.
The list of updates available to you depends on configuration settings on your system.

You can check the list of packages installed or updated on a certain day by looking into /var/log/dpkg.log and /var/log/apt/history.log

And the last update for Firefox on Ubuntu 16.04 (version 64.0+build3-0ubuntu0.16.04.1) was published on 2018- 12-11.

And a general question: Why are you posting your questions in the area of "ubuntu-docs" which is the the Ubuntu online help (e.g. the contents of http://help.ubuntu.com). Whatever problem you have with Firefox, it cannot have anything to do with the Ubuntu online documentation.

Snooper (ghos282) said : #3

I am NOT a programmer. The logs would be of no avail to me.

AS STATED: IT WAS UBUNTU LIBRARY - UPGRADES!! (Not Updates).

THIS was the trigger of the Firefox Browser Now CRASHING LESS THAN EVERY FIVE MINUTES regardless of Web Site (But more pronouncedly on YouTube and Facebook)! WHICH IS UNTENABLE!!
We Just want what was BROKEN by those upgrades, whatever it was, to be FIXED!
(Not a run-around by those Misinterpreting the Question.)

Snooper (ghos282) said : #4

Unfortunately Ubuntu does Not give us "KB numbers" on its individual upgrades, does it?

Why would it have KB numbers? That’s how Microsoft name their updates. That’s only Microsoft that do that....?

As initially stated, did you try disabling add ins?

Snooper (ghos282) said : #7

Yesterday 01-15-2019 there was another Library UPGRADE, which seemed to TEMPORARILY solve this issue: However, Today there was another UPGRADE of four packages, after the which the Browser Freezing up and Crashing behavior returned: Those UPGRADES were the following packages: Libpolkit - agent - 1 -0, libpolkit - backend -1-0, libpolkit - gobject - 1 -0, policykit -1.

Snooper (ghos282) said : #8

I was previously stated: I am not a programmer nor technical geek. What I do know is that the Ubuntu Operating System and its default Firefox browser WERE working without issue: But then Several Library packages were "UPGRADED" .."X Packages can be upgraded" And as a result, now BOTH the Browser and Operating system are REPEATEDLY CRASHING every dew minutes with numerous strings of 'Orphaned Inodes' Often with the Ubuntu Operating System completely Freezing up, and requiring a hard reboot to break out of it. As the ability to have a functional FSCK has been Removed from 'Recovery Mode' that is no longer a viable option, and the System Restart clearing of 'Orphaned Inodes' has to be relied upon. -- What is obvious is this, Something was done that has Broken something causing this behavior. And this Issue 'String' keeps being closed WITHOUT REMEDY to this ISSUE.

Snooper (ghos282) said : #9

Now I cannot even scroll down more than 3 or 4 posts on the Facebook page without their malfunctioning Notification System Repeatedly misdirecting me off the main web page, or the Entire Ubuntu Operating system suddenly and unexpectedly freezing up requiring a Hard (Reset Switch) restart to Unfreeze it. Or the Browser Tab being CRASHED. Also with Google/Youtube Repeatedly having the SAME behavior, after only one to three minutes of ANY video playback: Crashing Tabs, Freezing up the ENTIRE Ubuntu Operating System, Crashing the Browsers Tabs. In Either case leaving numerous strings of 'Orphaned Inodes'. This behavior WAS NOT occurring before these "UPGRADES" which you are apparently REFUSING to fix.

Do you use Thunderbird as your email client? If not then close all Firefox browsers and run:

mv -a ~/.mozilla ~/.mozilla_old

Then rerun the browser. Is it okay?

Manfred Hampl (m-hampl) said : #11

What you describe looks like hardware malfunction, and not to be caused by software programs.

I suggest that you perform a memory check by using the "memtest" entry in the grub menu.

If you have frequent problems with firefox, have you tried different browsers like chromium-browser?

Remark: As far as I know Firefox does not use any of the *polkit* packages. So your statement that the update of certain polkit packages might have helped, probably is a "red herring".

And again actionparsnip's question: Have you tried running firefox without add-ons? Does it crash in a similar way?

"As the ability to have a functional FSCK has been Removed from 'Recovery Mode' that is no longer a viable option": Can you please elaborate on this? I do not understand which "Removal" you are referring to.

Snooper (ghos282) said : #12

I am ALSO getting Repeated and Multiple "Ubuntu has experienced an internal Error" messages, along with these Repeated Browser AND Ubuntu Operating System CRASHES.. Freezing up of the Entire Ubuntu Operating System into complete Unresponsiveness. About 20 to 30 Percent of which I have managed to seemingly complete the reporting process of. the remainder I was unable to because of the Complete Unresponsiveness to input FREEZING. ..This Also has been going on since those Library UPGRADES! When will this be fixed?

Add Ons? What Add Ons?

Try running FSCK from recovery mode and see for yourself.

Snooper (ghos282) said : #13

To Action partnership:
Didn't work
mv: invalid option – 'a'

Snooper (ghos282) said : #14

"Do you use Thunderbird as your email client? If not then close all Firefox browsers and run:

mv -a ~/.mozilla ~/.mozilla_old

Then rerun the browser. Is it okay?"

I do not completely understand what the mv -a Terminal command is, or what it does. But if the intent is to 'roll back' Firefox to a previous version which Worked without these issues.. (or not).. What was the intended purpose of the '-a' switch (Which Terminal indicates to be an invalid option)? And how can I achieve whatever the mv command was supposed to be intended to be doing without messing it up (because of possibly incorrect switch options)?

Manfred Hampl (m-hampl) said : #15

I am not aware that it would have ever been possible to correctly run fsck from recovery mode.

fsck requires the file system not to be mounted, so it is not possible to run fsck on your root partition when you have booted from it. A full file system check has always required booting from another medium, e.g. a live system from an Ubuntu installer running in the "try Ubuntu without installing" mode.

I strongly recommend that you start with a memory check; this can be started from the grub menu.

If you do not know what add-ons are, please read e.g.
https://en.wikipedia.org/wiki/Browser_extension
https://en.wikipedia.org/wiki/Add-on_(Mozilla)
https://en.wikipedia.org/wiki/List_of_Firefox_extensions

Snooper (ghos282) said : #16

Tuesday January 23, 2019. PST. This morning there were 3 New UPGRADES involving 'libpoppler' Since then I have run the Firefox Browser for several Hours this morning/afternoon WITHOUT the crashing issue. Please make note of this. For now I will consider issue closed. However, If this Firefox Browser crashing recurs, I will open a new question.