FSCK Not Working System Recovery Menu

Asked by Snooper

Suddenly the Ubuntu DEFAULT Mozilla Firefox browser has begun Repeatedly Crashing on YouTube video playback at only 360P. I think I need to run FSCK, which i used to typically be able to do from the Recovery Mode MENU.. Only to find that UBUNTU HAS NOW DISABLED ITS FUNCTIONING FROM THE RECOVERY MENU!!! - So How Specifically do I now run FSCK which UBUNTU HAS DISABLED THIS MENU FUNCTION OF.??

Question information

English Edit question
Ubuntu ubuntu-docs Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Best actionparsnip (andrew-woodhead666) said :

You can do it from the install media in the live CD desktop. The file system needs to be unmounted to be fsck'd

You can also follow the official documentation which shows how it can be done at next bootup
sudo touch /forcefsck && sudo shutdown -r now

Calm down

Revision history for this message
Snooper (ghos282) said :

Thank you for answering. In the mean time I figured it out. Yes, boot from Bootable Install Flash Drive. Then in terminal sudo fdisk -l to determine what Partitions needed to be addressed. (I set up this install with a 40GB Root and a 2GB Swap and the remainder as /home) Then sudo fsck /dev/sda3 ..Clean Then sudo fsck /dev/sda2 ..Clean.

But then I think I disconnected the Flash Drive too soon when shutting down. And it wouldn't seem to boot. Wound up having to use Gparted (And Install gpart) then Highlight the Bootable Partition and select 'recover'.. This set the Flash Drive to continual blinking, and Gparted frozen on the screen. I then Used Right Click on the Gparted Icon on the Unity Bar to close it. The Flash Drive continued blinking. I then opened the 'Disks' Utility, and selected to 'power down' the Flash Drive. After this I shut the System down, and attempted to boot from the Flash Drive. Success!

However, this has not resolved the Youtube misbehavour on this end. (I'm thinking it may have been Google/Youtube attempting to crash the Adblocker Plus addon. Because every time they did this, I would reboot the system, and the addon would reinstall itself upon opening the Firefox Browser.)

Revision history for this message
Snooper (ghos282) said :

Thanks actionparsnip, that solved my question.