login screen following upgrade to 18.04

Asked by Peter Jordan on 2018-08-23

following an upgrade from 16.04 to 18.04 LTS when I arrive at the login screen it correctly shows my name but underneath states "not Listed" What does this mean? system lets me in okay when password entered.
When I select user settings for myself and unlock. It shows both standard and administrator boxes greyed out. The system won't let me change either setting.
I clearly have the correct administrator rights as I can install software. Why can't I correctly show this in my user settings. Is this in some way related to me showing as not listed as mentioned above.

How do I correct these issues.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu ubuntu-docs Edit question
Assignee:
No assignee Edit question
Last query:
2018-10-10
Last reply:
2018-10-10
Wim (launchpad-xs4all) said : #1

Dear Peter Jordan,

You are asking 2 questions:
.1. Not-Listed in the login screen
.2. Difficulties in changing user settings

.1. Login Screen
The login screen is designed to list the user names of everyone who is allowed to use the system.
Ubuntu offers the possibility to show not all names (e.g. when children are using the system too).
You can set the minimum user-ID to show in this list, for example:
   user-ID must be greater or equal 1234, in this case the first user (with user-ID=1000) is not shown in this list.
These "not-shown-users" can log in the following way:
 they first select "Not-Listed",
 now that person can enter the login name and the password in both fields.
For most systems this possibility is not used, so ignore it if you did not change the default setting.
Peter, you do not need to "correct" anything about the login screen.

.2. User Settings
If you do not have administrator rights, then you can not change user settings. But you state you can install software using you login name.
Peter, i have two questions:
+ Was you login name created which administrator rights, and did you NOT change anything after that moment ?
+ Were you able to change user settings in version 16.04 (from which you upgraded to 18.04.1) ?
If you reply "Yes" to both questions, then please describe more precisely what you are doing,
when you say "i select user settings" ...

Keep enjoying Ubuntu,
Wim

Peter Jordan (barule) said : #2

Hello Wim,

Thanks for clarifying point 1.

Regarding point2.

On version 16.04 I had administrator rights with no problems.

I then upgraded to version 18.04 and all seems fine.

In answer to your first question. The upgrade has created an account for
me. However if I enter settings/ user/ then unlock my account.

The fields for authority rights i.e. Standard and Administrator are both
greyed out and I cannot alter them. That is how they appeared after the
upgrade. I did nothing to set the account up myself.

In answer to your second question. Yes I could change user settings in
16.04.

To prove I still can. I have just created  a guest account with no
problems and I have also added another new account in my middle name as
a test and it happily let me set this as an administrator account.

However it still won't let me change anything in the original account of
mine which the system set up during the upgrade process.

The precise steps I take are as previously stated. Following login I
select Settings then User then select my account name then select unlock.

hope this is helpful

regards

Peter Jordan

On 07/09/18 08:23, Wim wrote:
> Your question #672653 on ubuntu-docs in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/ubuntu-docs/+question/672653
>
> Status: Open => Needs information
>
> Wim requested more information:
> Dear Peter Jordan,
>
>
> You are asking 2 questions:
> .1. Not-Listed in the login screen
> .2. Difficulties in changing user settings
>
>
> .1. Login Screen
> The login screen is designed to list the user names of everyone who is allowed to use the system.
> Ubuntu offers the possibility to show not all names (e.g. when children are using the system too).
> You can set the minimum user-ID to show in this list, for example:
> user-ID must be greater or equal 1234, in this case the first user (with user-ID=1000) is not shown in this list.
> These "not-shown-users" can log in the following way:
> they first select "Not-Listed",
> now that person can enter the login name and the password in both fields.
> For most systems this possibility is not used, so ignore it if you did not change the default setting.
> Peter, you do not need to "correct" anything about the login screen.
>
>
> .2. User Settings
> If you do not have administrator rights, then you can not change user settings. But you state you can install software using you login name.
> Peter, i have two questions:
> + Was you login name created which administrator rights, and did you NOT change anything after that moment ?
> + Were you able to change user settings in version 16.04 (from which you upgraded to 18.04.1) ?
> If you reply "Yes" to both questions, then please describe more precisely what you are doing,
> when you say "i select user settings" ...
>
> Keep enjoying Ubuntu,
> Wim
>

Launchpad Janitor (janitor) said : #3

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Peter Jordan (barule) said : #4

Wim
further to the above.
went into terminal today entered sudo apt-get update.
system asked me for password for< A > as usual.
when I entered my password the system returned the following.
<A> is not in the sudoers file. This incident will be reported.
This seems to be the root of the problem . Don't know how this has occurred as it was a straight system upgrade and I did not change any files during the upgrade. everything else is fine but obviously I cant use the terminal now as it wont accept my password. The same one it does accept when I log in.

How do I correct this sudoers file.

Manfred Hampl (m-hampl) said : #5

For diagnostic purposes please provide the full output that you receive for the commands

uname -a
lsb_release -crid
whoami
groups
id
sudo id

Peter Jordan (barule) said : #6

Hello Manfred,

These are the system results you requested.

austin@austin-Z97X-Gaming-3:~$ uname -a
Linux austin-Z97X-Gaming-3 4.15.0-36-generic #39-Ubuntu SMP Mon Sep 24
16:19:09 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

austin@austin-Z97X-Gaming-3:~$ lsb_release -crid
Distributor ID:    Ubuntu
Description:    Ubuntu 18.04.1 LTS
Release:    18.04
Codename:    bionic

austin@austin-Z97X-Gaming-3:~$ whoami
austin

austin@austin-Z97X-Gaming-3:~$ groups
austin adm cdrom dip plugdev lpadmin sambashare

austin@austin-Z97X-Gaming-3:~$ id
uid=1000(austin) gid=1000(austin)
groups=1000(austin),4(adm),24(cdrom),30(dip),46(plugdev),113(lpadmin),128(sambashare)

austin@austin-Z97X-Gaming-3:~$ sudo id
[sudo] password for austin:
Sorry, try again.
[sudo] password for austin:
austin is not in the sudoers file.  This incident will be reported.

Hope this is helpfull

On 07/10/18 13:32,

Manfred Hampl wrote:
> Your question #672653 on ubuntu-docs in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/ubuntu-docs/+question/672653
>
> Status: Open => Needs information
>
> Manfred Hampl requested more information:
> For diagnostic purposes please provide the full output that you receive
> for the commands
>
> uname -a
> lsb_release -crid
> whoami
> groups
> id
> sudo id
>

Manfred Hampl (m-hampl) said : #7

... austin is not in the sudoers file ...
Your user-ID has not been granted administrator rights.

If you have been admin in the past, then there are two possibilities how this might have got lost.
1. Either the sudoers file has been changed.
or
2. The group membership that has granted admin rights (usually named admin or sudo) has been removed from your user ID

What is the output of
grep ALL /etc/sudoers
?

Peter Jordan (barule) said : #8

Hello Manfred, This is the output you requested.

This seems to suggest I am not an Administrator. I have checked this in
users, settings, and "standard" is the field greyed out. I interpret
this to mean I am set as Administrator.

austin@austin-Z97X-Gaming-3:~$ grep ALL /etc/sudoers
grep: /etc/sudoers: Permission denied
austin@austin-Z97X-Gaming-3:~$

On 09/10/18 14:57, Manfred Hampl wrote:
> Your question #672653 on ubuntu-docs in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/ubuntu-docs/+question/672653
>
> Status: Open => Needs information
>
> Manfred Hampl requested more information:
> ... austin is not in the sudoers file ...
> Your user-ID has not been granted administrator rights.
>
> If you have been admin in the past, then there are two possibilities how this might have got lost.
> 1. Either the sudoers file has been changed.
> or
> 2. The group membership that has granted admin rights (usually named admin or sudo) has been removed from your user ID
>
> What is the output of
> grep ALL /etc/sudoers
> ?
>

Manfred Hampl (m-hampl) said : #9

Oops, my fault, of course you are not allowed to read the contents of the sudoers file.

Instead of trying to find out what happened, let's look for a solution:

Use the first part of the instructions in http://www.psychocats.net/ubuntu/resetpassword as starting point for reaching an administrative command prompt:
Boot your computer in recovery mode (by pressing the shift key during bootup) and then selecting advanced mode and root command prompt (the line to select nowadays probably reads "Advanced options for Ubuntu").
When you got a command prompt (probably "root@austin-Z97X-Gaming-3:~" issue the command
mount -o rw,remount /
and then issue the command
usermod -aG sudo austin
and finally resume normal operations with
exit
and selecting "resume" in the menu.

(What I assume as cause for the problem is the following: Apparently you played around with the user settings and selected/unselected the tick marks besides "normal user" and "administrator". As soon as you have once deselected "administrator", your user ID does not have admin rights any more, and so you cannot re-enable the admin property any more.)

Can you help with this problem?

Provide an answer of your own, or ask Peter Jordan for more information if necessary.

To post a message you must log in.