bad libcgi address prevents 14.04 to 16.04 upgrade

Asked by L. P. Luigi Espenlaub on 2016-08-22

 I created bug #1615771 in the ubuntu-release-upgrader package. [Hope I have successfully linked it above.] At that time I entered much more detail.

Here is the original. which did not include the detailed What I did and What I expected sections I added in #1615771
I can see there being a documentation side of this as I have been flying at the seat of my 8 and 16-bit DOS pants.

In upgrading from 14.04 to 16.04 at the end it displayed:
"aborted"
"some pakages could not be upgraded [or downloaded], System may be unstable."
After rebooting I received "System Problem" warnings [or rather my wife informed me of them.]

Knowing the boot menu provides options for this type of case I went looking and tried the repair pakages option.

At the Grub menu I chose:
Ubuntu with linux 4.4.0-34-generic (recovery mode)>>
Advanced Ubuntu menu>>
dpkg repair broken packages>>
download files continue yn details d
I entered y
lots of lines of "Doing this and that"

[Here was the firs clue as to what the "aborted"
"some pakages could not be upgraded... may be unstable." message received at the end of the upgrade program]

failed to fetch
Http://us.archive.ubuntu.com/ubuntu/pool/main/libc/libcgi-pm-perl_4.26-1_all.deb
temporary failure resolving "us.archive.ubuntu.com"

The same messages for:
libcgi-pm-perl_0.77-1build1_amd64.deb
and
libcgi-pm-fast-per1_2.10-1_all.deb]

Finally displaying
could not download the upgrades
upgrade aborted

Finally:
"aborting
finished please press enter"

I discovered wrong link information by going on line to:
Http://us.archive.ubuntu.com/ubuntu/pool/main/libc/
where I did not find:
 libcgi-pm-perl_4.26-1_all.deb
but a number of directories including "libcgi-pm-perl" which I selected.
and found a long list of libc files including
 libcgi-pm-perl_4.26-1_all.deb
and the other two files that "dpkg repair broken packages" could not find.

in each case the directory /libcgi-pm-perl/ has been left out of the fetch path and with that I concluded that all three were bad links.
If I am correct Broken Packages should be fetching from:
Http://us.archive.ubuntu.com/ubuntu/pool/main/libc/**libcgi-pm-perl**/libcgi-pm-perl_4.26-1_all.deb]
Instead.
I cannot modify the program and confirm this.

I have edited the original with a view towards documenters rather than programmers. If there is not "A what to do if" section; including how to reboot and run dpkg- repair pakages, and what to expect when it is run, that at some point consider including it.
It would help we babes in the Ubuntu woods to not stumble so much.

Question information

Language:
English Edit question
Status:
Needs information
For:
Ubuntu ubuntu-docs Edit question
Assignee:
No assignee Edit question
Last query:
2016-08-24
Last reply:
2016-08-25

Please close as spam

The text of my post was replaced by someone or something with all that garbage. It is certainly not my original text.
I do apologize for posting a ubuntu-release-upgrader-core question in Ubuntu-doc.
I thought I was in Ubuntu, Not Ubuntu-doc.
How ever, again the text above is not my text. My text was was similar to:

the repair broken packages and I assume ubuntu-release-upgrader-core has same error because of trying to fetch libcgi-pm-perl_4.26-1_all.deb from
Http://us.archive.ubuntu.com/ubuntu/pool/main/libc/libcgi-pm-perl_4.26-1_all.deb
when it should be fetching from:
Http://us.archive.ubuntu.com/ubuntu/pool/main/libc/libcgi-pm-perl/libcgi-pm-perl_4.26-1_all.deb
same for:
libcgi-pm-perl_0.77-1build1_amd64.deb
and
libcgi-pm-fast-per1_2.10-1_all.deb

Has someone hacked Launchpad??

Manfred Hampl (m-hampl) said : #8

You should be able to edit the question text with this link https://answers.launchpad.net/ubuntu/+source/ubuntu-docs/+question/356282/+edit (or click on any of the yellow buttons with a pencil that are shown in the header of the question document)

What is the current status of your problem? Can you boot into the graphical desktop?

Do you still get the same 'file not found in the directory' problem after updating the package inventory with "sudo apt-get update"?

'temporary failure resolving "us.archive.ubuntu.com"' in my opinion indicates a network problem, and not necessarily wrong file path.

Ack! I left that out.
I copied the failed to fetch addresses into into the address bar of Firefox ie:

Http://us.archive.ubuntu.com/ubuntu/pool/main/libc/libcgi-pm-perl_4.26-1_all.deb

and received:

404 not found The requested URL /ubuntu/pool/main/libc/libcgi-pm-perl_4.26-1_all.deb was not found on this server.

Apache/2.4.18 (Ubuntu) Server at us.archive.ubuntu.com Port 80

I then shortened the addresses to

Http://us.archive.ubuntu.com/ubuntu/pool/main/libc/

and found myself on the archive page for libc where I found the omitted directory /libcgi-pm-perl/

You can substantiate what I found by following what I did here.
'temporary failure resolving "us.archive.ubuntu.com' message is puzzling for me too. By doing what I did above I eliminated a network problem as the cause.

I will add this comment to bug #1615771 as well.
Thank you for your questions, they helped me clarify my thinking and discover things I had left out.
And thank you for your time and effort.

Ok, I thought the edit buttons were exclamation points indicating importance of the bug in the scheme of things not pencils. It is so obvious now. Will do better next time. Thanks

Manfred Hampl (m-hampl) said : #11

Now that the spam high-jacking of your question document has been cleared, let's try getting back to resolving your problem.

What is the current status of your system?
Can you boot normally into the desktop environment?
If yes, what does the command "lsb_release -crid" show?
And is there output from the command "sudo dpkg --audit"?

Can you help with this problem?

Provide an answer of your own, or ask L. P. Luigi Espenlaub for more information if necessary.

To post a message you must log in.