How do you specify read only access to a server

Asked by david braun on 2015-03-30

How do you specify that Nautilus should mount a windows share read-only? The old "connect to server" dialog had a check box for this. The new URL based "connect to server" doesn't.

I'm using Ubuntu 14.10 and the file manager calls itself "Files" version 3.10.1.
BTW - calling itself Files is ... totally unfriendly especially since the process is Nautilus. That detail cost me an hour.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu ubuntu-docs Edit question
Assignee:
No assignee Edit question
Last query:
2015-03-31
Last reply:
2015-03-31

If you add an entry for the partition in fstab, you can specify mount options.

david braun (braunster) said : #2

good answer to the wrong question. The old dialog had an option for read
only. The new one doesn't.

How do I specify Read Only in a URL

On Mon, Mar 30, 2015 at 4:06 PM, actionparsnip <
<email address hidden>> wrote:

> Your question #264372 on ubuntu-docs in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/ubuntu-docs/+question/264372
>
> Status: Open => Answered
>
> actionparsnip proposed the following answer:
> If you add an entry for the partition in fstab, you can specify mount
> options.
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
>
> https://answers.launchpad.net/ubuntu/+source/ubuntu-docs/+question/264372/+confirm?answer_id=0
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+source/ubuntu-docs/+question/264372
>
> You received this question notification because you asked the question.
>

What is the URL?

david braun (braunster) said : #4

It doesn't matter. Where would the read-only part go? An example - smb://pogo@stick/dancer
If I had to guess, the RO part would be a parameter at the end but there's no documentation so ...

Sent from my iPhone

> On Mar 31, 2015, at 2:41 AM, actionparsnip <email address hidden> wrote:
>
> Your question #264372 on ubuntu-docs in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/ubuntu-docs/+question/264372
>
> Status: Open => Needs information
>
> actionparsnip requested more information:
> What is the URL?
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/ubuntu/+source/ubuntu-docs/+question/264372
>
> You received this question notification because you asked the question.

No.... no documentation at all
https://duckduckgo.com/?q=fstab+samba

Can you help with this problem?

Provide an answer of your own, or ask david braun for more information if necessary.

To post a message you must log in.