Networking Stopped Working

Asked by Stephen Andreas on 2014-04-16

I have a Dell Inspiron 640m. Installed 13.10 just find. During installation I had it connected via a CAT 5 cable to my home network, the install connected to the network and was able to download a lot of stuff. When I finished the install and rebooted the system, the network does not work. I also cannot activate the wifi. Is there a process that I must do on this system to activate the hardward?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ubuntu-docs Edit question
Assignee:
No assignee Edit question
Solved by:
Stephen Andreas
Solved:
2014-04-17
Last query:
2014-04-17
Last reply:
2014-04-17

If you run :

ping -c 4 8.8.8.8

Do you get replies?

Stephen Andreas (sandreas-q) said : #2

I am a noob. So, how do I run ping and see the results?

Press CTRL + ALT + T
Run the command there.

Stephen Andreas (sandreas-q) said : #4

ping output is "connect: Network is unreachable."

Additional info:

When I click on the network icon on the top bar, the top line of the pop down menu is "No network devices available"

If you run :

sudo lshw -C network

Is it disabled? What Ethernet controller are you using? What driver module is it using?

Stephen Andreas (sandreas-q) said : #6

Output is:
  *-network
     description: Network controller
     product: BCM4311 802.11b/g WLAN
     Broadcom Corporation
     physical id: 0
     bus info: pci@0000:0c:00.0
     version: 01
     width: 32 bits
     clock: 33MHz
     capabilities : pm msi pciexpress bus_master cap_list
     configuration: driver=wl latency=0
     resources: irq:17 memory:efdfc000-efdfffff
  *-network UNCLAIMED
     description: Ethernet controller
     product: BCM4401-B0 100Base-TX
     Broadcom Corporation
     physical id: 0
     bus info: pci@0000:02:00.0
     version: 02
     width: 32 bits
     clock: 33MHz
     capabilities : pm bus_master cap_list
     configuration: latency=64
     resources: memory:efdfe000-efdfffff

Stephen Andreas (sandreas-q) said : #7

I found a post to a similar problem by Hadaka

These commands made the CAT5 ethernet work

sudo apt-get remove --purge bcmwl-kernel-source
sudo rm /etc/modprobe.d/blacklist-bcm43.conf
sudo modprobe -rf wl

After a reboot, the CAT5 ethernet worked and I did

sudo apt-get install b43-fwcutter firmware-b43-installer
sudo modprobe -rf b43
sudo modprobe b43

After a reboot, the popdown menu when I mouse over the network icon has a note that

Wi-Fi is disabled by a hardware switch

My laptop does not have such a switch. Will look in the bios settings.

If my system needs something other than b43, please let me know.

Stephen Andreas (sandreas-q) said : #8

Changed the bios to ignore the hardware switch.

All is now working.

Is there a recommended linux book I should get?

Thanks for all of your support.