Ubuntu

Doc search returns old 8.04 pages

Asked by memilanuk on 2011-11-12

When searching for information using the Community Documentation page on subjects that should be in the Official help documents (say for example, 'partitioning'), all results listed under the 'Official' tab are from 8.04 - not the current release, not even the current LTS, even though a manual search of similar pages for say, 10.04, show that the same information is available in the newer documents.

Are the help documents for releases newer than 8.04 not being indexed for the Community Docs search for some reason? It would seem to make sense that the search would return the most current and (hopefully) up-to-date documents available - if not for the most current release, then at least for the most current LTS release.

Thanks,

Monte

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu ubuntu-docs Edit question
Assignee:
No assignee Edit question
Last query:
2011-11-12
Last reply:
2011-11-12
Chris (fabricator4) said : #1

The vagaries of search engines, I think. When I do a search for "partitioning" it shows many generic results from this year and last year. If I click on the 'official' tab it shows all results for 10.04 LTS which I think is appropriate.

Try searching for "10.04 partitiion" and you will see 10.04 results. Now just do a search for "partitioning" again. Do you get a different, more current set of results?

At some point the old manual pages will probably have to be deprecated and quarantined away from the more recent manual pages.

Chris

memilanuk (memilanuk) said : #2

Maybe I'm going about this wrong...

When I go here: https://help.ubuntu.com/community

...and type in 'partitioning' in the search box near the top, I get this page back:

https://help.ubuntu.com/search.html?cof=FORID%3A9&cx=004599128559784038176%3Avj_p0xo-nng&ie=UTF-8&q=partitioning

...which does have a fair amount of recent community docs on the topic. But if you look at the official docs interspersed in there, or click on the 'Official' tab, *all* the documents are from 8.04, none are from any other release.

https://help.ubuntu.com/search.html?cof=FORID%3A9&cx=004599128559784038176%3Avj_p0xo-nng&ie=UTF-8&q=partitioning

(hopefully those URLs will work so you can see what I mean)

When I put '10.04 partitioning' in the search box, it does change which community docs are returned:

https://help.ubuntu.com/search.html?cof=FORID%3A9&cx=004599128559784038176%3Avj_p0xo-nng&ie=UTF-8&q=10.04+partitioning

...but still all the 'Official' documents are from 8.04 LTS:

https://help.ubuntu.com/search.html?cof=FORID%3A9&cx=004599128559784038176%3Avj_p0xo-nng&ie=UTF-8&q=10.04+partitioning

FWIW, this seems to be happening only with the *Community* documentation search. If I go to the page https://help.ubuntu.com/ and enter '10.04 partitioning' like you mentioned, I get lots of 10.04-related *official* docs (like it should).

Not sure why the Community documentation search is not returning any official documentation later than 8.04...

Monte

Chris (fabricator4) said : #3

"...and type in 'partitioning' in the search box near the top, I get this page back:
https://help.ubuntu.com/search.html?cof=FORID%3A9&cx=004599128559784038176%3Avj_p0xo-nng&ie=UTF-8&q=partitioning"

I went to your link and clicked "official" and saw 8.04 documentation. I then clicked on search again, then "official" and I got 10.04 docs.

https://help.ubuntu.com/search.html?cof=FORID%3A9&cx=003883529982892832976%3Ae2vwumte3fq&ie=UTF-8&q=partitioning&sa=Search

The URL is https://help.ubuntu.com/search.html?cof=FORID%3A9&cx=003883529982892832976%3Ae2vwumte3fq&ie=UTF-8&q=partitioning&sa=Search

I note that my links have '&sa-Search' on the end for some reason. I'm wondering if it's some kind of obscure locale or browser issue?

Chris

Chris

Can you help with this problem?

Provide an answer of your own, or ask memilanuk for more information if necessary.

To post a message you must log in.