Doc search returns old 8.04 pages

Asked by memilanuk on 2011-11-12

When searching for information using the Community Documentation page on subjects that should be in the Official help documents (say for example, 'partitioning'), all results listed under the 'Official' tab are from 8.04 - not the current release, not even the current LTS, even though a manual search of similar pages for say, 10.04, show that the same information is available in the newer documents.

Are the help documents for releases newer than 8.04 not being indexed for the Community Docs search for some reason? It would seem to make sense that the search would return the most current and (hopefully) up-to-date documents available - if not for the most current release, then at least for the most current LTS release.



Question information

English Edit question
Ubuntu ubuntu-docs Edit question
No assignee Edit question
Last query:
Last reply:
Chris (fabricator4) said : #1

The vagaries of search engines, I think. When I do a search for "partitioning" it shows many generic results from this year and last year. If I click on the 'official' tab it shows all results for 10.04 LTS which I think is appropriate.

Try searching for "10.04 partitiion" and you will see 10.04 results. Now just do a search for "partitioning" again. Do you get a different, more current set of results?

At some point the old manual pages will probably have to be deprecated and quarantined away from the more recent manual pages.


memilanuk (memilanuk) said : #2

Maybe I'm going about this wrong...

When I go here:

...and type in 'partitioning' in the search box near the top, I get this page back:

...which does have a fair amount of recent community docs on the topic. But if you look at the official docs interspersed in there, or click on the 'Official' tab, *all* the documents are from 8.04, none are from any other release.

(hopefully those URLs will work so you can see what I mean)

When I put '10.04 partitioning' in the search box, it does change which community docs are returned:

...but still all the 'Official' documents are from 8.04 LTS:

FWIW, this seems to be happening only with the *Community* documentation search. If I go to the page and enter '10.04 partitioning' like you mentioned, I get lots of 10.04-related *official* docs (like it should).

Not sure why the Community documentation search is not returning any official documentation later than 8.04...


Chris (fabricator4) said : #3

"...and type in 'partitioning' in the search box near the top, I get this page back:"

I went to your link and clicked "official" and saw 8.04 documentation. I then clicked on search again, then "official" and I got 10.04 docs.

The URL is

I note that my links have '&sa-Search' on the end for some reason. I'm wondering if it's some kind of obscure locale or browser issue?



Can you help with this problem?

Provide an answer of your own, or ask memilanuk for more information if necessary.

To post a message you must log in.