Why does 11.04 (Natty Narwhal) display as my current version?

Asked by Conan Librarian


Yesterday I upgraded from Kubuntu Lucid Lynx (10.04) to what I thought would be Maverick Meerkat (10.10). After four hours spent on the upgrade I was looking forward to seeing what 10.10 looks like. However, I've had a series of problems the most critical being that mouse control stops working in an application, effectively freezing me out and I don't know how to gain control except to turn off the laptop and restart. When I looked to find if I have the right version (in the System>About Ubuntu) I read "You are using Ubuntu 11.04 - the Natty Narwhal - released in April 2011 and supported until October 2012." I'm really puzzled - why I'm told I'm using a version that is not due out until April of this year? I'm starting to regret I did the upgrade. Things worked smoothly with Lucid Lynx.


Question information

English Edit question
Ubuntu ubuntu-docs Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
marcobra (Marco Braida) (marcobra) said :

Please open a terminal and type:

lsb_release -a

to check your release...

Revision history for this message
Conan Librarian (conan-lib) said :

I executed the command:

lsb_release -a

and received this output:

Distributor ID: Ubuntu
Description: Ubuntu 10.10
Release: 10.10
Codename: maverick

So I'm still left with the question why, when I am running Maverick (10.10) do I read in System>About Ubuntu that I am running Natty Narwhal (11.04)?

Revision history for this message
Eliah Kagan (degeneracypressure) said :

You are indeed running Maverick 10.10. I'm sorry it's not working for you as well as Lucid 10.04 did.

Your incorrect documentation is due to Bug 690248, which is in the process of being fixed. This bug is due to an update with Natty-specific content being applied against Maverick as well. When it's fixed, you will receive an update to your Maverick system that corrects the documentation and makes System > About Ubuntu display the correct version.

If you wish, you can go to that bug and indicate that the issue affects you by using the green link near the top that says, "This bug affects N people. Does this bug affect you?" There is no need for you to post a comment to the bug, unless you have additional information (or questions) about it. If you want to receive email notifications about progress on the bug, you can subscribe to it (with the green "Subscribe" link on the right, under the long list of duplicates).

Since the title of this question does not indicate anything about your mouse control problem (or other problems you've been experiencing with Maverick 10.10), if you want to receive support on that issue (and/or others) pertaining to Maverick, you will probably get best results by asking a separate question.

Usually upgrades work well, but sometimes they do not, and problems can sometimes be solved with a fresh install. I recommend researching the problems you've been having further before doing that, however, as you might well continue to experience them in a fresh Maverick system. Of course, if you're going to perform a fresh reinstallation, you could just as easily reinstall Lucid, which would almost certainly eliminate your problems (as you didn't have them in your old Lucid system).

Revision history for this message
Jeb E. (jebeld17) said :

Yeah, I noticed that before, too! lol
But with the most recent stable build of 10.10, it actually registers AS 10.10! lol

Revision history for this message
Eliah Kagan (degeneracypressure) said :

Yes, bug 690248 has been fixed, so with a fully updated system, the version displayed in About Ubuntu should be correct.

Can you help with this problem?

Provide an answer of your own, or ask Conan Librarian for more information if necessary.

To post a message you must log in.