package downgrade with aws custom ami

Asked by Jim Murphy on 2019-11-06

Trying to install ubuntu-esm package, ubuntu_advantage_tools.deb on our aws ec2 ami -

ubuntu/images/hvm/ubuntu-trusty-14.04-amd64-server-20180818 (ami-0b092e110910e6eba)

Getting the following downgrade warning when we try to install with dpkg,

+ dpkg -i --force-all /tmp/ubuntu_advantage_tools.deb
dpkg: warning: downgrading ubuntu-advantage-tools from 19.6~ubuntu14.04.3 to 10ubuntu0.14.04.4

How can we install the latest version without the downgrade occurring?

md5 for the package we're trying to install -

md5sum /tmp/ubuntu_advantage_tools.deb
529a4db2c1ca2c9ba6b18347f6ad628d /tmp/ubuntu_advantage_tools.deb

Question information

Language:
English Edit question
Status:
Needs information
For:
Ubuntu ubuntu-advantage-tools Edit question
Assignee:
No assignee Edit question
Last query:
2019-11-06
Last reply:
2019-11-07

What version is I the repos / do you have installed and which version is the one you downloaded?

Can you help with this problem?

Provide an answer of your own, or ask Jim Murphy for more information if necessary.

To post a message you must log in.