No EFI System Partition was found

Asked by ChrisOfBristol on 2020-10-08

This error happens when I attempt to install Ubuntu Budgie 20.10 on a system that has Ubuntu (vanilla) 20.04. I was using ext4 partitions.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ubiquity Edit question
Assignee:
No assignee Edit question
Solved by:
ChrisOfBristol
Solved:
2020-10-09
Last query:
2020-10-09
Last reply:
2020-10-09
Bernard Stafford (bernard010) said : #1

Did you open GParted in your Ubuntu 20.04 to check for the ext partitions for 20.10.
Open Boot Repair and reinstall GRUB if necessary. If it is found by GParted, Boot Repair should find it too.
https://help.ubuntu.com/community/Grub2/Troubleshooting
I hope that this helps.

Bernard
"Did you open GParted" I didn't do any checks - it's never been a problem before and the partitions are normally shown and selectable/changeable as part of the Ubuntu installation process, which I assume should detect errors.

"Open Boot Repair" That is a useful suggestion. However I have already gone on to install Ubuntu Budgie 20.04 and there were no problems. That suggests to me that there is nothing wrong with GRUB.

I think it's likely there is a new version of Ubiquity with 20.10 and that there is a bug in it. I'm not sure whether to report it as my technical knowledge of the situation is probably too poor to be sure it's a bug or to explain it properly.

Bernard Stafford (bernard010) said : #3

https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1896525 I suggest that you go to this bug report and click on this bug affects you and fill out a detailed bug report. Thanks

Bernard, That is the right answer :).

Bernard Stafford (bernard010) said : #5

The Official release of Ubuntu 20.10 and its Flavors si 2020/10/22. Might wait till the 22nd and retry. Please close as solved.
Unless their is more questions. Thank You

That's what I plan to do.
I didn't close the thing because it hasn't solved my problem, but I imagine what the "This Solved My Problem" button really means is "This has answered my question", so I will close it.
Thanks for your help.