[Feature request] Beyond OEM mode

Asked by Don B. Cilly on 2020-07-02

I've been experimenting with Ubiquity's OEM installation (on neon User).
What I was trying to achieve was:

· Install neon on a test system.
· Customise it to my liking
· Make a tarball of it that I could send to my customers, friends and relations - so they could install it as such.

What I managed to achieve was:
. Install it (in OEM mode)
· Boot it and customise it (even though it did not copy the personal settings to /etc/skel
· Successfully copy the OEM install (prepared for "shipping") to another partition and boot it.

After "minimal setup" on the final install, the newly created user's settings disappeared.
All installed apps were there, but not configured.
Copying the settings to /etc/skel before "shipping" worked. Why the installer doesn't do that to start with is a bit... mysterious.

What I could not achieve was:
· Copy the install partition to a different machine and boot it successfully.
Boot fails with multiple hardware issues.

Since the (let's call it) mini-installer at first boot does say "configuring hardware", I was hoping the first boot itself would be somewhat "hardware-agnostic" - like the ISO boot is. It isn't.

I was hoping someone on this team would want to look into making a "universal OEM-mode installer" feature.
Which I believe would open a world of possibilities for Linux installs - not least of which finally creating an option to install it without "live media" - or rather obscure and failure-prone grub-ISO-booting - which IMO should definitely be available.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ubiquity Edit question
Assignee:
No assignee Edit question
Solved by:
Don B. Cilly
Solved:
2020-07-02
Last query:
2020-07-02
Last reply:
2020-07-02

A bug report (marked as a feature request) will achieve your goal

Don B. Cilly (donbcilly) said : #2

Thanks. I hope I did it properly :·/

It's cool. The bug guys can help jiggle it around. As long as it's close and you communicate with them (if and when they reply) then awesome

Don B. Cilly (donbcilly) said : #4

Yes, I do seem to be getting email notifications "properly" :·)