Unable to install libxt-dev in docker

Asked by Hao Yan on 2020-02-12

I am trying to build docker image for running R shiny apps. The docker file went fine a month ago, but when I re-run it today. It gives the error. Could anyone help me with this dependency problem? Thanks a lot!

Dockerfile:

FROM r-base:latest
ENV http_proxy ""
ENV https_proxy ""

RUN cat /etc/apt/sources.list

RUN apt-get update && apt-get install -y --allow-downgrades \
    gdebi-core \
    gsl-bin \
    libcurl4-gnutls-dev \
    libgsl0-dev \
    libxt6=1:1.1.5-1+b3 \
    libxt-dev \
    pandoc \
    pandoc-citeproc \
    sudo \
    libglib2.0-0 \
    libglib2.0-dev \
    libcairo2-dev \
    rrdtool \
    libpq-dev \
    libgdal-dev \
    libudunits2-dev \
    libssl-dev \
    psmisc

Output:

Sending build context to Docker daemon 177.4MB
Step 1/26 : FROM r-base:latest
 ---> 78ace8280b3d
Step 2/26 : ENV http_proxy ""
 ---> Using cache
 ---> 38bdaf4f9a8a
Step 3/26 : ENV https_proxy ""
 ---> Using cache
 ---> fb67716d09a9
Step 4/26 : RUN cat /etc/apt/sources.list
 ---> Running in 56d320ac2133
# deb http://snapshot.debian.org/archive/debian/20200130T000000Z testing main
deb http://deb.debian.org/debian testing main
Removing intermediate container 56d320ac2133
 ---> d311b80421db
Step 5/26 : RUN apt-get update && apt-get install -y --allow-downgrades gdebi-core gsl-bin libcurl4-gnutls-dev libgsl0-dev libxt6=1:1.1.5-1+b3 libxt-dev pandoc pandoc-citeproc sudo libglib2.0-0 libglib2.0-dev libcairo2-dev rrdtool libpq-dev libgdal-dev libudunits2-dev libssl-dev psmisc
 ---> Running in 2e2177d7af2e
Get:1 http://deb.debian.org/debian testing InRelease [113 kB]
Get:3 http://deb.debian.org/debian testing/main amd64 Packages [7,618 kB]
Get:2 http://cdn-fastly.deb.debian.org/debian sid InRelease [142 kB]
Get:4 http://cdn-fastly.deb.debian.org/debian sid/main amd64 Packages [8,308 kB]
Fetched 16.2 MB in 4s (4,532 kB/s)
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
libglib2.0-0 is already the newest version (2.62.4-1+b1).
libglib2.0-0 set to manually installed.
libxt6 is already the newest version (1:1.1.5-1+b3).
libxt6 set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libcairo2-dev : Depends: libx11-dev but it is not going to be installed
                 Depends: libxrender-dev (>= 0.6) but it is not going to be installed
                 Depends: libxext-dev but it is not going to be installed
                 Depends: libxcb1-dev (>= 1.6) but it is not going to be installed
                 Depends: libxcb-render0-dev (>= 1.6) but it is not going to be installed
                 Depends: libxcb-shm0-dev but it is not going to be installed
 libxt-dev : Depends: libx11-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ubiquity Edit question
Assignee:
No assignee Edit question
Solved by:
Hao Yan
Solved:
2020-02-13
Last query:
2020-02-13
Last reply:
2020-02-13
Manfred Hampl (m-hampl) said : #1

Why are you asking this in the Ubuntu question area?
You are using Debian servers as repository and not Ubuntu.

Hao Yan (hyanucd) said : #2

My bad, I will ask the Debian support.
Thanks for pointing it out.

Hao Yan (hyanucd) said : #3

Solved.