installation fails with error message "???-???"

Asked by Jim C on 2015-01-02

I've been trying to install Ubuntu 14.04 (32-bit) on an older AMD Sempron computer alongside the existing Windows XP installation. Every time I start the installation, it gets as far as asking my time zone, then a strange message box pops up with an error icon and the text "??? - ???". No error message except the text "??? -???". I click OK and it goes back to the start of the installation.

It doesn't matter whether I choose the "Install alongside" default, or if I choose the "Something else" option and specify partitions, the result is the same.

The computer is working fine when I boot the Windows XP partition. There's plenty of free disk space on the drive.

I verified the DVD when I burned it from 14.04.1-desktop-i386.iso

So what is the error message "???-???" supposed to mean?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ubiquity Edit question
Assignee:
No assignee Edit question
Solved by:
Jim C
Solved:
2015-01-06
Last query:
2015-01-06
Last reply:
2015-01-02
Jim C (b647-11d7-aa56) said : #1

P.S. Yes, the MD5 checksum of the ISO is correct.

Run a full chkdsk on your NTFS partition so that you know that it is healthy. You can do this in XP.

Jim C (b647-11d7-aa56) said : #3

There are actually 3 NTFS partitions on the drive, and I've run chkdsk on them multiple times so I know they are healthy. (I'm not sure why that would matter, since I'm trying to install Ubuntu into the empty space on the drive, not in the NTFS partitions, but in any case we know that's not the problem.)

I see here http://askubuntu.com/questions/504055/ubuntu-14-04-not-installing-popup-error-at-where-are-you that someone else has had the exact same problem. But if they filed a bug report I can't find it.

Jim C (b647-11d7-aa56) said : #4

PS. The drive is MBR patitioned, not GPT.

Did you make a blank NTFS partition to store Ubuntu? If so then delete it so the space is unpartitioned and then run the installer.

Jim C (b647-11d7-aa56) said : #6

No, I am not trying to install Ubuntu into an NTFS partition. I'm trying to install it into the unpartitioned part of the drive.

The drive is 160 GiB with about half that unpartitioned.

I first tried taking the default "Install alongside" choice, where it allocated it's own partitions in the unused space (about 80GB total in multiple partitions) and that failed as described, leaving a bunch of new unformatted partitions.

Between each attempt I have been using other tools to delete the unformatted partitions left over from the previous failed install, restoring it back to it's original state, verifying that Windows still booted, and chkdsk the NTFS partitions. So each time I've tried it, I've started the install with plenty of unpartitioned space on a good drive.

I've also tried choosing the "Something else" option, allocating a 40 GiB Ext4 partition for "/" and a 5 GiB partition for swap. (CPU has 2 GiB of memory). Same result.

Could try updating just the installer package in the Live CD desktop if you have enough RAM. May help

Jim C (b647-11d7-aa56) said : #8

It took me a while, but I've figured out what the problem was: RAID controller.

To recap, I was trying to install Ubuntu alongside an existing Windows XP installation on an older machine which had an ATA RAID controller (sometimes called "fake raid" because they only function as hardware RAID in real mode and require a device driver to implement the RAID functions in software after Windows finishes booting and switches to protected mode.) The two drives were in a RAID 1 (mirror) array for improved reliability.

When the LiveCD boots up, the two drives appear as separate drives, and the DMRAID utility checks special locations on the drives for the metadata that these RAID controllers us to store their configuration information. If it finds them, then device mappings are set up to implement the same configuration in software RAID.

In this particular case, DMRAID found the metadata for the current RAID configuration. (An Adaptec 1200A RAID controller is recognized as type "hpt37x".) *BUT* it also found a second set of signatures on the drives! An older metadata configuration record from a Promise Technology controller (type "pdc"). So DMRAID attempted to set up two contradictory, conflicting, software RAID configurations for the same drives! causing device mapper errors that I found on a syslog.

I don't have a complete history of the drives, but they were probably originally a RAID 1 array on another computer with a Promise controller, and then at some point one or both of them were moved or copied to this computer with the Adaptec controller and the RAID array was rebuilt.

AFAICT, these conflicts/errors were the eventual cause of the failure of the installer. But not before the installer went ahead and tried to create new partitions on one of the drives for Ubuntu. But because of the failures of device mappings, the updated partition table data was only written to one of the drives in the mirror array. When I rebooted into Windows, the two drives were functioning as a mirror array again, meaning that when the OS tried to read data from a sector containing the MBR partition table or one of the extended partition table records, there was a 50-50 chance of it reading that sector from the updated drive versus the unaltered drive. So when I tried to clean up with the Windows Disk Manager, all of the Logical Partitions in the Extended partition abruptly disappeared!