unable access Guest Kubuntu 'shared" from host windows

Asked by S.S.Mani on 2014-08-07

I have created a virtual machine in my Windows 7, installing Kubuntu 14.04 LTS

i have made the folder "shared" in kubuntu a shared folder with guests allowed and sharing with samba

i have installed samba and configured also with following changes in short:

Virtuaql kubuntu Samba conf file additions made:
(Spelling at the beginning as mistakenly made by me while installing the system!)

 workgroup = mshome
 wins support = yes
 security = user
 [homes]
    comment = Home Directories
    browseable = yes
 valid users = %S
 path = /home/VirtuaqlKubuntu/shared
 guest ok = yes
 create mask = 0755

However i am not able to see this shared folder in my network anywhere:
does it appear as a seperate one there, or should i expand the Host computer under network to trace this?

Under smbtree, only the virtual machine folders get displayed

I have restarted smbd as well as nmbd also

Have i missed any configuration or is there some other error ?

Please advice.

Thanks

Mani

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ubiquity Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2014-08-07
Last query:
2014-08-07
Last reply:
2014-08-07

Did you set the network to be bridged in the configuration of the virtualbox?

It will then appear as a PC on the LAN and get an IP from your router. By default, virtualbox uses it's own subnet and you need to run commands to allow traffic through the guest which using the bridge setting alleviates

S.S.Mani (airomatic) said : #2

Please clarify:

1) Under network in setting now it is NAT. I find another option, bridge adpater, are you suggesting to choose this?

2) After the change does everything else remain the same as it is before, or does it add more problems in browsing, accessing the host by guest etc etc?

3) Subsequently can I reset to NAT and come back to old status, if there is any issue with bridge adapter, or will there be complications?

Sorry for my basic questions

I accept that at this stage i have no need for guest file access, but only for learning i am asking the question.

thanks

mani

S.S.Mani (airomatic) said : #3

Though I am not very sure, I found some guidance here:
http://microdevsys.com/wp/networking-sharing-folders-between-windows-and-linux-using-samba/2/

But looks very complicated.

Just set the network to bridged from NAT and you will get an IP from your router. You have seen it is a simple option to switch so why ask for any confirmation? Go for it! If it is not good you know how to switch back.....

S.S.Mani (airomatic) said : #5

Thanks lot actionparsnip. It is working.

At least oldies like me in India are not that much comfortable with experimenting with these new technonogies and hence my questions.

thanks again.
mani

S.S.Mani (airomatic) said : #6

Thanks actionparsnip, that solved my question.