cannot use CD-ROM nor DVD-ROM

Asked by Edmond Condillac on 2014-07-02

I upgraded to Trusty Tahr (14.04 LTS). Now I cannot get the CD-ROM nor DVD-ROM drives seen. Hence cannot use the drives for play back nor copying or burning .iso files to RW disks.
edmond@edmond-Dimension-2400:~$ sudo lshw -C disk
[sudo] password for edmond:
  *-disk
       description: ATA Disk
       product: Maxtor 6E040L0
       vendor: Maxtor
       physical id: 0.0.0
       bus info: scsi@0:0.0.0
       logical name: /dev/sda
       version: NAR6
       serial: E1M7PC4E
       size: 38GiB (41GB)
       capabilities: partitioned partitioned:dos
       configuration: ansiversion=5 sectorsize=512 signature=00019570
edmond@edmond-Dimension-2400:~$ uname -a
Linux edmond-Dimension-2400 3.13.0-30-generic #54-Ubuntu SMP Mon Jun 9 22:47:59 UTC 2014 i686 i686 i686 GNU/Linux
edmond@edmond-Dimension-2400:~$

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ubiquity Edit question
Assignee:
No assignee Edit question
Solved by:
Edmond Condillac
Solved:
2014-07-04
Last query:
2014-07-04
Last reply:
2014-07-03

What did you upgrade from?
Is it a clean install or an online upgrade?
Does the drive show in BIOS?
How does the drive connect to the system?

Edmond Condillac (econ22) said : #2

Precise Pangolin was upgraded from the terminal using sudo apt-get upgrade command. The CD-Rom drive shows as the Secondary M aster Drive The Secondary Slave Drive is an Unknown Device. In Drive Configuration menu in BIOS it shows: IDE Drive UDMA On.

If possible, check the jumper on the back of the drives are not set to cableselect. This can cause issues in Linux. If you are not comfortable with the inside of computers I don't suggest you explore this option. If you are then also check connections are solid

Edmond Condillac (econ22) said : #4

Thanks this solved my query.

> To: <email address hidden>
> From: <email address hidden>
> Subject: Re: [Question #251108]: cannot use CD-ROM nor DVD-ROM
> Date: Thu, 3 Jul 2014 06:56:44 +0000
>
> Your question #251108 on ubiquity in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/ubiquity/+question/251108
>
> Status: Open => Answered
>
> actionparsnip proposed the following answer:
> If possible, check the jumper on the back of the drives are not set to
> cableselect. This can cause issues in Linux. If you are not comfortable
> with the inside of computers I don't suggest you explore this option. If
> you are then also check connections are solid
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/ubuntu/+source/ubiquity/+question/251108/+confirm?answer_id=2
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+source/ubiquity/+question/251108
>
> You received this question notification because you asked the question.

What was the fix?
Please mark as solved

Thanks

Edmond Condillac (econ22) said : #6

The CD-ROM had to be set to slave.