Cannot create 1440x900 res using xandr

Asked by Alastair Hodder on 2014-03-04

Im trying to create the native resolution of 1440x900_60.00 for my lcd monitor in ubuntu studio 13.10

I've followed appropriate steps using cvt and xrandr but get an error at the --addmode step.

alastair@alastair-System-Product-Name:~$ sudo cvt 1440 900 60
# 1440x900 59.89 Hz (CVT 1.30MA) hsync: 55.93 kHz; pclk: 106.50 MHz
Modeline "1440x900_60.00" 106.50 1440 1528 1672 1904 900 903 909 934 -hsync +vsync

alastair@alastair-System-Product-Name:~$ sudo xrandr --newmode "1440x900_60.00" 106.50 1440 1528 1672 1904 900 903 909 934 -hsync +vsync

alastair@alastair-System-Product-Name:~$ sudo xrandr -q
Screen 0: minimum 8 x 8, current 1024 x 768, maximum 4096 x 4096
VGA-0 connected primary 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768 60.0*+
   1360x768 60.0 59.8
   1152x864 60.0
   800x600 72.2 60.3 56.2
   680x384 60.0 59.8
   640x480 59.9
   576x432 60.1
   512x384 60.0
   400x300 72.2 60.3 56.3
   320x240 60.1
  1440x900_60.00 (0x272) 106.5MHz
        h: width 1440 start 1528 end 1672 total 1904 skew 0 clock 55.9KHz
        v: height 900 start 903 end 909 total 934 clock 59.9Hz

alastair@alastair-System-Product-Name:~$ sudo xrandr --addmode VGA-0 1440x900_60.00
X Error of failed request: BadMatch (invalid parameter attributes)
  Major opcode of failed request: 140 (RANDR)
  Minor opcode of failed request: 18 (RRAddOutputMode)
  Serial number of failed request: 23
  Current serial number in output stream: 24

I'm not sure what im doing wrong here... I'm running a VGA output and have had this screen resolution work on older installs.

any guidance will be much appreciated.

Cheers

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu ubiquity Edit question
Assignee:
No assignee Edit question
Last query:
2014-03-04
Last reply:
2014-03-04

Can you help with this problem?

Provide an answer of your own, or ask Alastair Hodder for more information if necessary.

To post a message you must log in.