12.04 Does Not Offer Install Options

Asked by ThatGrrl on 2012-05-10

I've been happy using Ubuntu for a year on an old computer. I bought a new HP and have tried to install 12.04 since it came out. No luck.

Refer to this forum thread - http://askubuntu.com/questions/133612/cant-install-on-an-hp-pavillion-h8-1211

In short, I used the same DVD to successfully install 12.04 on another computer. No problem.

This computer is an HP h8 1211. Windows 7. I did shrink the partition - which was new for me. I've always installed over Windows and was thinking to do the same. But, I can't get that far when I try to install. Instead it skips the screen where you are offered to install Ubuntu with Windows or over Windows. I go right to the partition screen and get an error "No root file system is defined". It refers me back to the partition screen. I am unable to do anything from this screen on the install. It shows no partitions and none of the buttons lead to anything.

I tried installing Linux Mint just to try something else and I get the exact same results.

This is really bugging me! I don't know what else to do other than wipe the entire hard drive and start from scratch. But, I've reformatted drives before and I know it doesn't always go smoothly so I'm a bit reluctant to take that plunge.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu ubiquity Edit question
Assignee:
No assignee Edit question
Last query:
2012-05-11
Last reply:
2012-05-25
ThatGrrl (thatgrrl) said : #1

Could something be wrong with the install DVD I'm using? It did work for one computer. But that already had Ubuntu running on it.

I have noticed a quick message come up about updating the installer but it is just a blip - disappears too quickly for me to click it. Also, I don't get the screen about installing Ubuntu full or live. I have burned a second DVD with the alternate version and that did not get me anywhere either.

Barry Drake (b-drake) said : #2

When you say you 'installed over Windows' are you referring to a wubi installation? When you boot into the live-DVD it should give you the option to 'Try Ubuntu'. Please do that first just to check that your hardware is fully compatible with 12.04. If you are looking at wubi, the option you mention does not come up. You need to follow a very different procedure. Wubi is the Windows autorun application that operates when you insert the disk with Windows running. If you have an existing wubi installation, you could uninstall Ubuntu from inside Windows and then re-install from the new disk. If you want a native installation, you need to boot the live-DVD and please try it out from the DVD before attempting installation. Is all data properly backed up?

michael (yellupcm-gmail) said : #3

Could something be wrong with the install DVD I'm using? Your statement. Did you MD5sum (check) your disk? You should always burn disk, as slow as possiable.
Google: MD5sum Ubuntu, will bring up sites like these.
https://help.ubuntu.com/community/HowToMD5SUM
https://help.ubuntu.com/community/UbuntuHashes
https://help.ubuntu.com/community/VerifyIsoHowto
Also make sure it is ISO.

ThatGrrl (thatgrrl) said : #4

I did try WUBI later. It would not install either. My first choice was full install, not using WUBI. As far as I know WUBI treats Ubuntu like a Windows program rather than an actual OS.

I did not look into MD5ssum because the disk worked fine for the older computer when I updated it from Ubuntu 11. Is it possible a disk could work for one computer and then not another? Sounds pretty odd to me. But, I'm getting really frustrated.

It is ISO. Burned from the Ubuntu site two weeks ago. Will do the check just as another thing to be ruled out. I also got the ISO again today and will burn another fresh DVD with it today.

I just can't figure out how I could have no problem installing it dozens of times before this and only on this new computer is it not working out, easily. Thanks for your posts I was feeling really frustrated this morning.

Shrink the NTFS partition in WIndows, then install Ubuntu to the free space.

ThatGrrl (thatgrrl) said : #6

I did shrink the C drive. No change to my problem installing. Everything went exactly the same as every other time.

ThatGrrl (thatgrrl) said : #7

I don't get an option of WHERE to install Ubuntu. That never comes up.

michael (yellupcm-gmail) said : #8

Last week I installed Ubuntu 12.04 with Win 7 Pro. Had problem with Win 7 shrinking partition, would not leave Ubuntu enough room. I had to use G-Parted. Before Installing Ubuntu, did you partition the free space? Like "/" "swap" " /home" "ext3" "ext4" ect.?

Barry Drake (b-drake) said : #9

The option for where to install only comes up with the advanced options for partitioning manually. I doesn't make this the obvious choice because obviously you need to know what you are doing at this point.

ThatGrrl (thatgrrl) said : #10

Barry, I'm getting the advanced options before I get any other options. I go from choosing English to the screen that asks if I am online to this where I have partition options. There is no inbetween. So something is screwed up.

Michael, I did try it with free space. I shrunk the Windows C: partition. But I did not add files. I'm going to figure out how to do that over the weekend.

Last night I almost reformatted C: to get Windows off of it. But, I thought that might not work either because I still wouldn't have anything but dev/ sda. I think that is the problem. Somehow the ISO for Ubuntu isn't able to create the partition it needs on my computer. It may be something MS Windows has cooked up to make it hard to install Linux or to keep Windows from being pirated. I don't know. But, I think you are right about manually getting the / swap and so on in there myself. People keep telling me to use the partitioning from the install but they don't understand that I am not given that option.

Thank you for your help here, all of you. I'm so glad to have a place to get help. I will check back in here and let you know if I got it worked out. I know someone else will have the same problem at some point.

Barry Drake (b-drake) said : #11

It could be that Ubuntu is taking you straight to the partitioning option because what it sees is a complex partitioning scheme. Use gparted from the live-DVD and delete ann the partitions. Make one new partition with ext4 and then you should be able to install Ubuntu using the defaults. If you want Windows, make the partition formatted NTFS and install Windows first. But usually the live-DVD offers the option to use the entire drive and it doex it before it asks for partitioning options, so I'm a bit unsure what is happening here. Anyone else have any more thoughts on this?

ThatGrrl (thatgrrl) said : #12

If I rename dev/sda to dev/ext4 that should work?

ThatGrrl (thatgrrl) said : #13

I repartitioned and added ext4 as a Ubuntu partition, in addition to the allocated space I cleared. Still the very same results. I just never get any option to install Ubuntu in any partition. All I get is a notice that it can't find a root file - see above.

At this point I am giving up. I will miss running Ubuntu. But, the installation is not working. Game Over. I don't even think reformatting the entire hard drive will fix whatever this problem is. I might try again with the next version of Ubuntu.

Peter (pgarver-c) said : #14

It's probably too late for the OP, but I found the answer to this (and have already posted it elsewhere - want to make it widely available).

There is some kind of conflict between the ubiquity partition editor and dmraid, and uninstalling dmraid fixed it for me. Try opening a terminal window and running:

sudo apt-get remove dmraid

I found this answer here:
http://askubuntu.com/questions/135705/ubuntu-12-04-installation-error-no-root-file-system-is-defined

Can you help with this problem?

Provide an answer of your own, or ask ThatGrrl for more information if necessary.

To post a message you must log in.