Cannot boot due to "Gave up waiting for root device." after upgrade to 12.04 from 11.10 on Hyper-V host

Asked by Matthäus G. Chajdas on 2012-05-09

I have an Ubuntu VM running under a Windows 2003 Hyper-V hypervisor. Previously, we used Ubuntu 11.10 and that worked fine, after manually enabling the hyper-v modules as discussed here: http://blogs.msdn.com/b/virtual_pc_guy/archive/2010/10/21/installing-ubuntu-server-10-10-on-hyper-v.aspx

Upgrading to Ubuntu 12.04 worked fine, but now the machine won't boot using the 3.2.0 Kernel. It stops with:

Gave up waiting for root device. Common problems:
 - Boot args (some more text)
ALERT! /dev/mapped/uvm-root does not exist. Dropping to shell!

BusyBox v1.18.5 (Ubuntu 1:1.18.5-1ubuntu4) built-in shell (ash)

When I select the 3.0 kernel in grub, everything works fine: Output of uname -a: "Linux uvm 3.0.0-17-server #30-Ubuntu SMP Thu Mar 8 22:15:30 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux"

I've exported the VM disk image and tried to boot it inside a VirtualBox, and that works fine as well (except for some hyper-v related warnings), so I wonder if this is a hyper-V bug in Ubuntu, some failure during the upgrade, and how I can figure out what is going wrong here?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu ubiquity Edit question
Assignee:
No assignee Edit question
Last query:
2012-05-09
Last reply:
2012-05-09
Wyatt Smith (wyatt-smith) said : #1

If I understand this correctly, 12.04 works properly under 3.0.0.17 kernel but not the 3.2.0 kernel.

To me this sounds more like a kernel issue than anything else. I would suggest reinstalling the kernel and headers, then rebuild the initramsfs image.

Matthäus G. Chajdas (anteru) said : #2

Correctly. I'll try to reinstall the kernel and see if that helps.

Wyatt Smith (wyatt-smith) said : #3

Since the error that occurred under 3.2 appears to be related to drive mapping, I thought there may be an issues with the hv_blkvsc module.

I checked the bug reports and saw that there was one filed to enable all hv drivers and export them in the initramfs.
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/917135

Although this issue has been fixed, I see no mention of the hv_blkvsc module. If re-installation of the kernel and headers with a rebuild of initramfs does not fix this problem, I would considering filing a new bug report.

Can you help with this problem?

Provide an answer of your own, or ask Matthäus G. Chajdas for more information if necessary.

To post a message you must log in.