Trouble installing Ubuntu...

Asked by SemperFI

I used wubi to install the ver LTS ver 12.0... PP 32 bit
previosly I had installed in the same machine Xubuntu 11. ... 64 bit

 to me seems that the 32 bit install kept some 64bit libs or config file (in the boot give me the option to go to a previous linux install) .... is that possible?

The hardware is 6 year old pentium d 950 with 3 gb of ram and 2 disk an 80 Gb sata 2 and a 500 gb sata2 on an intel ICH7 motherboard.

Trying to find the best version to use because i want to move all my work environment to a linux system (Win 8 is running on the 80gb and i dont like where MS is going with their OS working toghether with the big watcher :) )

1) given the HW could someone suggest which is the best version to use:
2) How can i make sure that one install is not going on top opf the others (clean up PC of any install) do I need to repartition or format the disk?
3) could someone suggest a good book on using ruby to develop testing gig)

Thank you

Question information

English Edit question
Ubuntu ubiquity Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:

This question was originally filed as bug #987051.

Revision history for this message
SemperFI (filosofico) said :

that was a question not a bug (I dont think is was anyhow)

Revision history for this message
Best actionparsnip (andrew-woodhead666) said :

I suggest you use the 64bit OS as it will allow you to upgrade RAM easier later.

If you used wubi you can use the add/remove programs in Windows to remove it. You can also check it's all gone using this:

How do I manually uninstall Wubi?

Remove C:\ubuntu and C:\wubildr*

In Windows XP you need to edit C:\boot.ini and delete the Ubuntu/Wubi line. Alternatively you can modify the boot menu via Control Panel > System > Advanced > Startup and Recovery and pressing "Edit". For Windows 98 you have to edit C:\config.sys and remove the Wubi block. For Windows Vista/7, you can use the built-in bcdedit command or install EasyBCD to edit the boot menu. To use bcdedit, run cmd.exe as an administrator, then enter bcdedit to show all boot entries, note the {GUID} specified for the Ubuntu entry, and then remove it: bcdedit /delete {GUID}

To remove Wubi from the add/remove list, delete the registry key: HKLM\Software\Microsoft\Windows\CurrentVersion\Uninstall\Wubi

An easy method of removing this registry key is to paste the following text into a plain editor such as Notepad, close and save the file as something like removeWubiKey.reg (you may wish to go to Folder Options > View and disable the "Hide file extensions for known file types" option to check that the .reg extension has been applied correctly). Then you can perform the rest automatically by opening the file in the normal Windows manner, or choosing the "Merge" option from the right click context menu. Note: The formatting is rather strict, so copy the text exactly for best results. You may need to be logged in as the administrator to delete the key, depending on the version of Windows you are using. User Account Control in Vista may also ask for permission, in the typical fashion.


After deleting the registry key, Ubuntu may still appear in the program list. If this is the case, you may be asked if you would like to remove the item from the list.


Revision history for this message
actionparsnip (andrew-woodhead666) said :

If you use Win7 you can resize your NTFS partition and install Ubuntu to it's own partition. It will run better and is a LOT easier to troubleshoot

Revision history for this message
SemperFI (filosofico) said :

Thanks actionparsnip, that solved my question.

Revision history for this message
SemperFI (filosofico) said :

Pentium D is an EMT 64 processor. running a full 64 bit OS i9n emulation will cripple processor speed this is why I choose a 32bit OS it is installed and run in is own partition on a different disk.

i have read that this will impact sidk performance because it runs on an NTFS disk.
anyhow thank you for the answers

I resoved tru synoptic mgr removing the unused libs and that removed the entry on boot.