unable to install ubuntu 10.04 lts in parallel with macintosh in macbook 4.1

Asked by vivek mittal on 2011-12-05

the error which i got "no root file system defined " while defining partition for installation of ubuntu
please give me a brief solution as i am a new user of both ubuntu and mac osx and have a very little knowledge of system
thnx............

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ubiquity Edit question
Assignee:
No assignee Edit question
Solved by:
vivek mittal
Solved:
2011-12-12
Last query:
2011-12-12
Last reply:
2011-12-10
marcus aurelius (adbiz) said : #1

this is an issue with parallels. you'll have to ask on a mac forum. and since it is a paid-for software, you might be able to contact parallels tech support for help.

marcus aurelius (adbiz) said : #2

oops. if you're not using parallels, you have to find the powerpc version of ubuntu. i doubt there is a powerpc version for 11.10. but there should be one for 10.04. you can easily do a google on "ubuntu powerpc" to look for it.

vivek mittal (viv-mttl) said : #3

i have mac10.5 and i don't think it is a power pc version..............

vivek mittal (viv-mttl) said : #4

how to use BIOS in mac actually i have made the startup disk the only problem i am gettting is to run the startupdisk at the time when my sysem boots ......i had used a software named rEFIt that solved my problem of booting with the disk but i am unable to partion the hard-drive and seeting up the partition manually i get an error: NO ROOT FILE SYSTEM DEFINED
but if i remove the mac os x completely then i am able to install ubuntu 10.04lts but i need both the osx and ubuntu installed at my laptop ..........basically that is the problem ........................

José Antonio Rey (jose) said : #5

Have you selected a mount point in the ext4 partition when doing it?

vivek mittal (viv-mttl) said : #6

thnx very much guys for ur replies
actually i didn't selected the root partition ,swap area and boot partiton
nw it is resolved