Ubuntu

Installing Ubuntu 10.04 with Win7 fails

Asked by Zoandar on 2010-12-16

I am trying to install Ubuntu 10.01 LTS along side Windows 7 x 64 Home Premium to select between them at boot. But despite everyting I have tried in regard to partition selections, the same 2 things keep happening:

1 - Ubuntu's installer never detects that WIndows is installed on the PC

2- it runs through the entire installation routine, I press restart, the disk ejects, several lines of text scroll on the black display which look like they are probably normal. Then a line starts repeating, scrolls down about 3/4 of the black screen, and the PC freezes. The repeating line has slight variations in the numbers presented, but essentially they are similar to this last line where it freezes:

[ 1020.620216] end_request: I/O error, dev sr0, sector 524560

I can hold my own when it comes to managing Windows. But Linux is completely new to me, so I am totally clueless here. Running the disc I made as a Live CD it runs perfectly fine on this PC. I just can't get it to actually install. I would 'prefer' NOT to have it installed on the C drive, which has about 41GB free, behind nearly 100GB of WIndows 7 stuff. I have half a terabyte of unallocated space on another drive I would like to install it to. But trying that did not work even after creating partitions in EXT format and a swap partition. So I tried the default choice to allow it to install beside Win7 and provide a boot choice just to see if it could work at all, and still keep getting the exact same result as above.

As I understand it, I need 3 partitions. A primary EXT for the boot partition. A Primary EXT for Linux to install to, and a Logical SWAP partition. But I am not having any luck trying to do that, using Easus Partition Mgr. to make them. I used "mount point" of /boot for the boot partition, and mount point "/" for the Ubuntu OS partition. But I admit I am guessing in that stage of the installation.

If I could find out what is happening at the end to cause that statement (presumably some kind of error message) then maybe I could get somewhere.

Zoandar

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ubiquity Edit question
Assignee:
No assignee Edit question
Solved by:
Zoandar
Solved:
2010-12-18
Last query:
2010-12-18
Last reply:
2010-12-17
Zoandar (repairs) said : #1

I can't find any settings here to subscribe by instant email notification ( or not ). Is that automatic on this forum?

Did you MD5 test the ISO you downloaded?
Did you burn the CD as slowly as possible?
Did you check the CD for defects once first booted to?
Did you test your RAM?

Zoandar (repairs) said : #3

1- No, I did not. I didn't notice an MD5 hash for the iso on the download site. I'll check that out.

2 - No, I generally do not have to do that, but I can try re-burning the CD. I have a WinXP PC which is serving only as a method to burn discs with Nero. Nothing else runs while it is doing that. But I suppose that doesn't mean I can't make a coaster anyway. :-)

3- Check CD for defects? I am not sure how to do that. It runs as a LiveCD just great. Beyond that I don't know what you mean.

4- I suppose I could test the RAM, but since I never have any problems running Win7 on it I would be surprised if that is an issue. I just built this PC this year. It has 8GB RAM.

From what I have learned so far, this error refers to the CD drive. And indeed it only shows up at the end of the installation when it it time to remove the disc or if the disc auto-ejects. I just tried a tutorial taking a different approach, which installs from within the LiveCD running OS. Got the same error when it was time to remove the disc. On a hunch I then pressed the enter key, and the text on the screen resumed and seemed to shut down OK as near as I can tell. But when I booted back up there was no choice to boot to Ubuntu. It went straight to Win7 without hesitation. Is there a way I can manually go to the boot menu, like with F8 or something?

Thanks. I'll look into the suggestions above.

So you basically haven't check the media at any point (Don't worry most windows users don't)

You need to test the ISO so you know its complete and consistent. Burning the CD slowly makes the image not only transfer stronger to the disk but reduces the impact of jitter

When you boot the CD and see the stickman, press SPACE and select 'Check CD for defects', once its finished repeat but select test RAM.

Zoandar (repairs) said : #5

OK Thanks. As it turns out, I do NOT get a verification on the MD5 hash. :-( I'll have to re-download the iso and start over. Sorry I did not think of this, but as you say it is often something overlooked. I like it when file servers provide an MD5 hash right on the same page under the file download, because it puts the idea to check it into my mind.

I am guessing by "stick man" you are referring to the left-most icon when I boot the Live CD, but I really can't tell what it is. I use a triple display setup and until I get to the point where I can change the monitor settings the screen image being displayed is fuzzy and stretched across all 3 displays, so distorting that icon beyond easy recognition.

But first things first. I'll get a 'reliable' download and start over. Thanks!!!

Zoandar (repairs) said : #6

I have a newly made CD (slow speed burn) from an MD5 verified ISO now. But I have a problem. When I see the stick man and press space nothing happens. It just keeps doing the start-up process I had seen before. I am never asked to check the CD or memory. Is there any other way to get those to show up on the screen? I am using a USB keyboard. Does that matter?

Zoandar (repairs) said : #7

OK, I managed to snag the stick man with the spacebar on a subsequent try. It is checking the CD now.

Zoandar (repairs) said : #8

Well, here is how it played out:

__ / __ >Burn MD5 verified Ubuntu 10.04.1 ISO using Nero 8 at minimum 16X speed (helps minimize jitter errors).
__ OK __ >Test CD during Live CD Boot
__ OK __ >Run memtest86 during Live CD Boot
Reboot and

 Install Ubuntu 10.04.1 following this article http://lifehacker.com/5403100/dual+boot-windows-7-and-ubuntu-in-perfect-harmony
This time I did not even change to “log in automatically”. I left the default “use a password to log in” choice (hopefully that can be changed later). Everything has checked out OK so far, so this 'should' work (FINALLY).
One the installation process ejected the disc, I got the same long list of errors ending in the line I first posted above. I removed the disc and pressed Enter, and the screen said “now rebooting”.
There is STILL NO BOOT MENU. The PC boots directly into Windows 7. I have no way to know if Ubuntu is even correctly installed?? I need to figure out why there is no boot menu??

Zoandar (repairs) said : #9

Well, I thank you for trying to help me, but it is obvious to me this is never going to work. I can't even get it to install "inside windows" using wubi. I tried twice in succession, and each time it looks good right down to the last 5 seconds, and then throws an error on the screen about an Invalid Argument, and gives me the supposed path for a log file to read more details. The folder at the end of that path is always empty after it fails.

Since the disc was proven not to be corrupt and I don't have any problems running Windows it seems to me there has to be something wrong within the download package. I have read dozens of forum posts tonight where others had exactly the same issue trying to install it with Windows 7, and failing the exact same way. So something needs to be addressed in the installation files.

Thanks again, but that is enough frustration for me.

Zoandar (repairs) said : #10

Sleeping on this issue led me to only one logical conclusion. The source of the download files must have corrupted data. Using MD5 and a slow speed burning process for the disc does as much as can be done for me to get the 'same' files as those on the server, but as they say "GIGO". If those files were somehow bad, I would have a carefully copied set of 'bad files'. So, I decided to try again, but selected a different download, and went with the version 10.10 32-bit desktop download.

I used MD5 again and this time burned them to a DVD instead of a CD, allowing for a much slower 4x burn speed. I am happy to report that I now have Ubuntu 10.10 up and running on BOTH my Windows XP and my Windows 7 PCs. The new files installed without incident.

Thanks for the help! I really do appreciate it. You might want to take a look at the server files though.

Zoandar

Colin Watson (cjwatson) said : #11

I'm certain that the files are correct on the server side - we test
every single image before release. Of course that doesn't exclude the
possibility of bugs.

Your problem sounds very much like bug 628630, and since we reduced the
incidence of that bug in 10.10 that would explain why you don't see it
there. For the record, MD5-testing and slow burning had nothing to do
with this, but a workaround would have been to press Enter after all
those I/O request errors - it should reboot and be just fine.

delance (olivier-delance) said : #12

Is issue solved ? If not, reopen it and run following procedure:
--
There is a standard script provided to analyse boot configuration.

Could you download script at:

   http://sourceforge.net/projects/bootinfoscript/

Then in a terminal (Ctrl+Alt+T) run command:

    sudo bash boot_info_script055.sh

This will produce a file named: RESULTS.txt

Paste content of this file in http://paste.ubuntu.com/ and provide in this thread the link to Web page.

Please don't post file directly in thread, else it will make thread difficult to read.
--
I will have a look.
If issue has really changed from start of thread, it could be better to open another one as this one start to be hard to read.

Zoandar (repairs) said : #13

I solved the issue by *not* using version 10.04.1. :-)

I did try pressing the spacebar when the above problem showed the repeating
[ 1020.620216] end_request: I/O error, dev sr0, sector 524560
lines, to see if the system was frozen. When nothing happened, I then tried pressing Enter, which did resume boot process text on the screen and eventually reboot the PC. But having now seen what the 'entire' setup process looks like with the successful installation of 10.10 on 2 different PCs using WinXP and Win7, I can say that what I had been seeing while trying 10.04.1 might possibly have been HALF of the total installation process, at which point it would always fail repeatedly.

Since I have 10.10 working and it is newer anyway, and since this issue is apparently a known bug in 10.04.1, I am not inclined to repeat that attempt and try to debug why it didn't work. But thanks for posting the additional information.

I feel this issue is resolved to my satisfaction. However, being an issue known to exist in 10.04.1, which is entitled "Long Term Support", and being that it is not mentioned anywhere in the published Getting Started with Ubuntu 10.04.1 guide, it might be helpful to others to add a "known issues" section in that guide and mention this problem. I know it certainly would have saved me from 2 days of frustration.

Thanks.