Ubuntu

Ubuntu 10.04.1 32-bit iso file has no boot folder

Asked by Michael Sioutis on 2010-10-13

Hello,

i tried to install Ubuntu 10.04 LTS and right before the end of the installation it gave me an error "Could not install
bootloader in the following location ..., try another location"

So I canceled installation and tried to figure out what happened. I opened the iso file and I cannot see any boot folder inside.
I downloaded it again from the site and still there is no boot folder inside.

This is not the case with Ubuntu 10.10, they have a boot folder that contains the grub AND a usb-creator.exe.

What is wrong?

Thank you,
mike

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ubiquity Edit question
Assignee:
No assignee Edit question
Solved by:
Michael Sioutis
Solved:
2010-10-17
Last query:
2010-10-17
Last reply:
2010-10-16

This question was reopened

Did you MD5 test the ISO you downloaded?
If you burned a CD did you burn it slowly, did you test the CD for errors once first booted to?

marcus aurelius (adbiz) said : #2

looking at the 10.04 iso file i have, there's no boot folder for 10.04, so that's not the issue.

in addition to actionparsnip's comments,

- how much disk space did you have before you tried to install 10.04?

- are you installing it on a different partition than 10.10?

- is 10.10 still on your computer?

- did you let the installer automatically choose where to put things?

- did you have windoze on the computer before you installed 10.04?

etc.

Michael Sioutis (trelopedo) said : #3

I did not MD5 tested the ISO, but I burnt it slowly.

I tried to install it in a 80gb disk, letting the installer use all space.
I don't have ubuntu 10.10 on my desktop, I just have the ISO file.

The disk had ubuntu 8.04 previously, but that should be no issue since I
erased it using KillDisk.
Now I am erasing it with EASEUS partiotion manager, I will burn a fresh copy
of 10.04 and I will try again later this day.

I use 10.04 on my laptop which I installed with wubi through vista and I liked
it so much I wanted to use it on my desktop.

Mike

marcus aurelius (adbiz) said : #4

1. killdisk probably cause the problem that you had with the bootloader

2. why don't you let the ubuntu installer erase the partition instead of using easus partition manager. save yourself like $50 from having to buy it.

3. it's necessary to do an md5sum check to determine if you have a good or bad download

Michael Sioutis (trelopedo) said : #5

1. I tend to believe so too

2. I use the free version (home edition) and I honestly thought it would be a good practice
to provide the Ubuntu installer with a fresh unallocated disk, like having it bought new from a store.

3. I will do!

Mike

Colin Watson (cjwatson) said : #6

Regarding a point in your original message: yes, Ubuntu 10.10 has a boot directory at the top of the CD while Ubuntu 10.04 LTS didn't. However, this is not a bug and has nothing to do with your problem. (If you care, /boot/grub was added to the CD to support booting the image from Super GRUB Disk.)

https://help.ubuntu.com/community/HowToMD5SUM

I'm going to go with you have a bad image, MD5 summing would have captured this but like many windows users it gets ignored. You should also test the CD, when you see the screen with the keyboard and the stick man, press SPACEBAR then select "Test CD for defects". If it is bad then you will need to reburn, if the ISO is bad you will need to re-download and re-burn and re-test.

HTH

Here some general note on install Ubuntu and howto to get a good ubuntu iso cd image (.iso) to burn on a cd:
(some examples and videos links refers to Ubuntu 10.04.1 but the install stepa are similar for Ubuntu 10.10)

- Here the steps to install Ubuntu 10.04.1 https://help.ubuntu.com/community/GraphicalInstall

- Here install Ubuntu video http://www.youtube.com/watch?v=XaqaDZZ_P0g&feature=fvw
(The example used in the video is Ubuntu 10.04.1. The process may be similar for other versions.)

Below there are some intructions to:
--- 1) Ubuntu prerequisites... and Ubuntu for pc with low power
--- 2) download the iso...
--- 3) check the md5sum of the iso image, please don't forget to check...
--- 4) burn the iso image to a cd ...
--- 5) install Ubuntu using the self made cd ...
--- 6) trouble screen at installation or at first boot after installation ...
--- 7) Ubuntu manual and online help...
--- 8) Relax and fun...

The main ubuntu site is this: www.ubuntu.com and the download location is this
http://www.ubuntu.com/desktop/get-ubuntu/download

--- 1) Ubuntu prerequisites: https://help.ubuntu.com/community/Installation/SystemRequirements

Ubuntu 10.04.1 release notes: https://wiki.ubuntu.com/MaverickMeerkat/ReleaseNotes

If your ram is less than the recommended amount, you won't be able to install with the graphical installer,
but you might be able to use the Alternative cd, where you can use a text based installer - that uses less memory.
If your machine does have plenty of ram, you might want to try running Memcheck (which is also an option from the live cd, see below)
to just make sure your ram isn't failing.

- if your pc doesn't meet the Ubuntu prerequisites, you can try:

xubuntu http://www.xubuntu.org/get
lubuntu http://lubuntu.net/blog/lubuntu-1010-released

here a list from distrowatch: http://distrowatch.com/search.php?category=Old%20computers

- if you pc is a very low resource pc you can try different Linux distribution something like:
 Slitaz http://www.slitaz.org/ : Slitaz 3.0 release note http://www.slitaz.org/en/doc/releases/3.0/relnotes.en.html
 DSL http://www.damnsmalllinux.org/
 Puppy Linux http://www.puppylinux.org/

1.a) Please always prefer to download them using torrent if you can...

1.b) BE ABSOLUTELY SURE to verify the md5sum https://help.ubuntu.com/community/HowToMD5SUM
of the downloaded iso image BEFORE to burn it

1.c) burn it using infrarecorder http://infrarecorder.org/ if you are using Windows at lower speed you can do

1.d) boot your pc from cd and install...

--- 2) please download the 700 mb file http://www.ubuntu.com/desktop/get-ubuntu/download simply press on download button
To avoid download errors download the desired ubuntu iso install cd image using the torrent protocol.

- if you are using Windows please install a torrent client i suggest you http://deluge-torrent.org/
and download the iso using a .torrent link from here:
http://releases.ubuntu.com/10.10/ubuntu-10.10-desktop-i386.iso.torrent

--- 3) PLEASE BE SURE TO CHECK the md5sum of downloaded file to be sure it have no error https://help.ubuntu.com/community/HowToMD5SUM
Only if the md5sum number match with this: http://releases.ubuntu.com/10.10/MD5SUMS go to the next steps.

--- 4) burn the iso image onto a cd, to do it install and use http://infrarecorder.org/?page_id=5 burn the cd at lower speed you can do and activate the data verify

--- 5) insert the self made install cd into your pc cdrom drive and reboot your pc. YOU MUST NOT SEE Windows starting and you can try Ubuntu from cdrom and then install it

--- 6) If you have trouble with installation (the system freeze or you can't complete it) be sure to read the above suggestions, then:

Please boot entirely (you must not see windows starting) from Ubuntu live install cd and when the system start to boot from cd you will see two bottom screen icons ( keyboard and man inside circle ) please press space (choose your desired language) then a screen textual center menu will appear to you with this items in it:

Try Ubuntu without installing
Install Ubuntu
Check disc for defects
Test memory
Boot from first hard disk

Please select "Test Memory" to deeply test your ram healty, if your pc freeze at installation or installation doesn't start.

Please select "Check disc for defects" and press enter to test if your cd-driver can read in a good way the live install cd... or if the install cd have some defective files in it.
Then please also perform a Test memory to be sure your pc RAM memory have not any issue

Using this mode by pressing F6 you can select and add special kernel parameters that may help if the installation doesn't start

------

If you get a blank screen at boot after install or booting from the Ubuntu install cd please read:

http://www.ubuntugeek.com/how-to-fix-ubuntu-10-04-lts-lucid-blank-screen-at-startup.html

If you have trouble with intel8xxx graphic cards:

please try this: https://wiki.ubuntu.com/X/Bugs/Lucidi8xxFreezes

If you cannot boot you can also try some kernel boot options: https://help.ubuntu.com/community/BootOptions to solve.

--- 7) Ubuntu Manual, it's very informative: http://ubuntu-manual.org/
Click on the "download Button" to download the latest PDF version.

The online help https://help.ubuntu.com/10.04/index.html

--- 8) Relax and fun
http://planet.ubuntu.com/ and Full Circle Magazine http://fullcirclemagazine.org/

marcus aurelius (adbiz) said : #9

@marcobra && actionparsnip

I might be a good idea to instruct people to download via a torrent, which will result in better downloads. Windoze users, especially, are more familiar with torrents than md5sums.

Michael Sioutis (trelopedo) said : #10

I am defeated...

md5 was ok, disk was ok, installation went ok until "Error: cannot instal bootloader in /dev/sda"

So I am booting with LiveCD and do this->https://wiki.ubuntu.com/Grub2#Recover%20Grub%202%20via%20LiveCD
nothing

I am booting again with LiveCD and do this->http://ubuntuforums.org/showthread.php?t=1466033
nothing

I boot without LiveCD and get the GRUB prompt (grub>).
I do: grub> configfile (hd0,1)/boot/grub/menu.lst
nothing

I boot again with LiveCD, go in command line and do this:
grub>find /boot/grub/stage1
Answer: No filesystem found..

Disk is damaged? I really can't think of sth else. It is a sata drive.

delance (olivier-delance) said : #11

10.04 uses Grub2 and menu.lst is a file of previous Grub Legacy.
So command "configfile (hd0,1)/boot/grub/menu.lst" can't work (and I believe there is no stage1 in Grub2).
First time I hear from "Error: cannot instal bootloader in /dev/sda". I see many explanations:

1) sda is not the right device
With the last installer, MBR is sometimes installed on wrong device.
Boot on Ubuntu CD, and choose "Try without install".
In a terminal (Applications->Accessories->Terminal), type the following command:
     sudo parted -l
where "-l" is lowercase "L". This will display list of partition. Check sda is the hard drive, and not other device.
Please post result in this thread.

2) It's possible there is a bad sector on the first track.
See if dd can read it with
dd if=/dev/sda of=/root/1sttrack.backup bs=512 count=64
and then write it with
dd if=/root/1sttrack.backup of=/dev/sda bs=512 count=64

Michael Sioutis (trelopedo) said : #12

ubuntu@ubuntu:~$ sudo parted -l
Model: ATA ST380815AS (scsi)
Disk /dev/sda: 80.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
 1 1049kB 80.0GB 80.0GB primary ntfs boot

Model: ATA ST380811AS (scsi)
Disk /dev/sdb: 80.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
 1 1049kB 76.7GB 76.7GB primary ext4
 2 76.7GB 80.0GB 3305MB extended
 5 76.7GB 80.0GB 3305MB logical linux-swap(v1)

Model: ATA WDC WD1200JB-00G (scsi)
Disk /dev/sdc: 120GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
 1 32.3kB 31.5GB 31.5GB primary ntfs boot
 2 31.5GB 120GB 88.6GB extended lba
 5 31.5GB 120GB 88.6GB logical ntfs

Warning: Unable to open /dev/sr0 read-write (Read-only file system). /dev/sr0
has been opened read-only.
Error: /dev/sr0: unrecognised disk label
-------------------------------------------------

ubuntu@ubuntu:~$ sudo dd if=/dev/sdb of=/root/1sttrack.backup bs=512 count=64
64+0 records in
64+0 records out
32768 bytes (33 kB) copied, 0.0233025 s, 1.4 MB/s

ubuntu@ubuntu:~$ sudo dd if=/root/1sttrack.backup of=/dev/sdb bs=512 count=64
64+0 records in
64+0 records out
32768 bytes (33 kB) copied, 0.00111144 s, 29.5 MB/s
ubuntu@ubuntu:~$
---------------------------------------------------

So seems it is /dev/sdb right? /dev/sda belongs to vista and /dev/sdc is storage. If you are wondering why I can still boot in vista after "grub-instal dev/sda etc" it is because I had that drive disconnected. But wouldn't it ther /dev/sdb turn to /dev/sda..? I don't know..

MIke

delance (olivier-delance) said : #13

Model: ATA ST380815AS (scsi)
Disk /dev/sda: 80.0GB
Sda is a hard disk, so it looks right and should work. As you have many disk, sdb should be a better choice (and will avoid to interfere with Vista disk, avoiding some problem). If you choose sdb, simply set Ubuntu disk before Vista disk in BIOS boot order.
"I had that drive disconnected": it's a definitive explanation!
What I propose is:
1) disconnect Vista drive
2) reinstall Grub following https://help.ubuntu.com/community/Grub2#Reinstalling%20from%20LiveCD
As you disconnected Vista drive, Ubuntu disk name can change. So check with "sudo parted -l" if it is currently sda or sdb
3) plug Vista drive
4) in BIOS boot order, set Ubuntu disk before Vista drive
5) boot on Ubuntu and run command "sudo update-grub". So Vista should be added in multi boot list.

Michael Sioutis (trelopedo) said : #14

Could this scenario be valid?

1)I disconnected the vista and the storage drive when installing ubuntu
2)Ubuntu disk name remained sdb
3)Installer tried writing bootloader in /dev/sda ->failed
4)I tried writing bootloader in /dev/sda -> seemed to have worked, but reallly failed

My mobo has 4 sata slots on it (1,2,3,4). I have vista in 1 and Ubuntu in 2. I reckon the problem to be
that I left Ubuntu in slot 2, without having anything else in slot1.
I don't know how this can create a problem, but it seems stupid and stupid things usually turn to problems.

I will find out for sure once I unplug the drives again an run sudo parted -l to see whether it is sda or sdb.
It should be sdb.

Mike

PS:I will try later on cause i need to go to work

delance (olivier-delance) said : #15

In last installation screen, there is an "expert" button. Click on it, and it should ask you where you want to install the boot. Choose sdb.
The 10.10 installer enumerates disk not like previous 10.04, so I have difficulties to guess what he will do.
Perhaps the simplest is:
  1) Connect Ubuntu disk in SATA 1, so it will be sda, which is default case
  2) Connect Vista disk in SATA 2, so ti will be sdb.
  3) Boot on Ubuntu CD and check that Ubuntu is sda and Vista sdb
  4) Install Ubuntu. Grub will be installed in sda by default
  5) Reboot. You should see a menu with Ubuntu/Ubuntu recover/Vista.

Michael Sioutis (trelopedo) said : #16

I will do as you said, except the fact I will install Ubuntu without vista in sata 2, i will connect later.
I will set the ubuntu drive 1st priority boot device (well 2nd after cd-rom to be precise) and if I ever want to
boot into windows I will access the boot menu in the begining (f8 in my case).

This has worked in the past with Ubuntu 8.04, but for reasons I can't quite remember I switched vista to sata 1
and Ubuntu to sata 2, cause if I remember well, 8.04 was installed with the drive in sata 1.
I am not 100% sure for that, but I will find out tonight.

I thank you all so very much for the support, I didn't expect it and I am much obliged.

If I succed tonight I hope sth usefull will come out of it, like "if you plan to install Ubuntu on a sata drive, without anything else
connected, make sure it is an sda device".
I think I got the installer mixed up, which is based on the simple fact that sata slots should be filled from top to bottom.
This was pretty dum of me.

Mike

Michael Sioutis (trelopedo) said : #17

Nothing...

I placed the Ubuntu drive in sata 1 slot with nth else connected, I installed Ubuntu and @ about 93%:
"Error: cannot install boot loader in /dev/sda, try another location", /dev/sda1 was available, but it wouldn't install it there either.

Continued without boot loader, I opened the terminal "sudo parted -l", ubuntu drive was listed as /dev/sda.
Tried again mount .. grub-instal /dev/sda umount.. etc, rebooted, nothing..

I rebooted again without LiveCD, the grub prompt came up:
grub>root (hd0,1)
filesystem is ex2
grub>setup (hd0,1)
unknown command setup

I even downloaded Super Grub Disc, burnt the iso, booted with the CD, followed the steps to restore MBR and it failed.

So I really don't know if there is anything else I can do.
If there is, I'll try it for you.

Mike

Michael Sioutis (trelopedo) said : #18

I tried to install Windows 7, the installer doesn't even see the drive!!

I can see the drive:
In BIOS
In Windows through device manager
In Windows through disk utilities like Killdisk, Partition Master etc
In Linux with sudo part -l

But when coming to install either Linux or Windows, it says can't write boot loader
or can't see the device in the latter case.

Shall I trash the disk?

Mike

Michael Sioutis (trelopedo) said : #19

I found an Ubuntu 8.10 64-bit LiveCD, which I ad installed in the past. It installed fine!

I now have upgraded to 9.04 64-bit and I'll continue upgrading up to 10.04 :D See if it succeds.

Mike

Good as 9.04 is due to die in under 2 weeks :)

Let us know how you get on. Personally I would have gone for a clean install of Lucid as it will require a LOT less downloading. You could also have upgraded from Hardy directly to Lucid as both are LTS.

Michael Sioutis (trelopedo) said : #21

YEEEEEEEEEEEEEEEEEEEEEESSSSSSSSSSSSSS!! Ubuntu 10.04.1 LTS 64-bit bootable and operational!

Gone from 8.10 to 9.04 to 9.10 to 10.04.
Only glitch I came upon was a graphic configuration issue when rebooting to 9.10. It said an error was encountered
and it would run the session in low graphic resolution, but it seemed good graphic resolution to me.

Upgrading and rebooting to 10.04.1 came with no errors, so now I have Ubuntu both in my laptop and my desktop!!

I still don't know what the issue was though, not being able to install 10.04 from the beginning. I think I'll go
for bad CD quality which led to problems when overheating or incompatibility with DVD-R(?), cause checksums
were ok and so was the CD for any errors.
I'll go for USB installations in the future.

I'll leave this open for a while, in case someone wants to add something like "a lesson we learned here" and have the
topic as future reference for people with same kind of problem and I'll press problem solved after.

DVD-R is: NEC ND-3540A with latest firmware 1.04
CDs were: Maxell CD-R 700mb 80min speed 1x - 52x

I thank you all for keeping me company and baring with me!!
Mike

delance (olivier-delance) said : #22

Please, could you mark question "Solved".

Michael Sioutis (trelopedo) said : #23

Ok :)