Booting Ubuntu from Intel Mac OSX Laptop

Asked by

I acquired a recent MAC OS-X Laptop from work. I am in charge of completely wiping data from PCs before they are either recycled or disposed of. Anyway, I ran a disk wipe utility on the HDD to completely remove all possible confidential information. However it seemed a shame to throw the machine away if it could be re-used. The keyboard is sticky, battery is dead but it still works off the power cord.

I installed Ubuntu 9.10 and it will boot off the live CD and can boot into the installed system provided I start off with the CD in the drive (well, usually!).

However, it does not boot into Ubuntu on its own. I believe this is something to do with the EFI bootloader but I thought this should be supported in Linux, since I can get my O2 joggler to boot off an SD card into Ubuntu.

My question is:
How do I get an old MAC OS-X system to boot correctly from scratch into Ubuntu. I do NOT have the original MAC-OS installed or have access to the install DVD. I do NOT intend to purchase proprietary software for this machine. I am happy to consider other Linux variants and don't mind restarting from scratch.

Thanks in advance.


Question information

English Edit question
Ubuntu ubiquity Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
delance (olivier-delance) said :

Use the Ubuntu CD, and choose "Try but not install".
Then open Gparted (upper bar, Administration->System->Gparted).
Gparted should display partitions of disks.
Remove all partitions and then remove partition table (today EFI).
Then create a DOS partition table (i.e. Windows Boot Sector).
And after install as a usual PC.
I never used Gparted on disk with EFI as boot sector, but it is supposed to work.

Revision history for this message
actionparsnip (andrew-woodhead666) said :
Revision history for this message (warp-factor-three) said :

Thanks a lot guys.
Unfortunately the MacBook still doesn't boot reliably. I'm beginning to think there is a hardware fault. It only booted once out of about 20 attempts and has started being difficult about ejecting CDs and DVDs. I'll try a few more times but think it has nearly died. Thanks again.

Revision history for this message
AJenbo (ajenbo) said :

Did you install rEFIt?

Revision history for this message (warp-factor-three) said :

I don't think this problem is due to rEFIt. However I'll give it a go!. I am still thinking it is now in fact a hardware problem, but have not really had enough time to mess with it properly. It only rarely now boots from the CD and then only if I hammer on the keyboard.

Anyway, thanks all for the suggestions

Revision history for this message
jfhd sdf (ery44432) said :

Same for me at ubuntu 18.04.1, gdm3, GeForce MX150 (nvidia-motive force-390).
When I even have establishing Android Emulator, switching between workspaces causes to system crash and logout! Visit here for more detail here

Can you help with this problem?

Provide an answer of your own, or ask for more information if necessary.

To post a message you must log in.