Can't save user owned file to desktop of new install from cd desktop

Asked by Tom Pino on 2010-03-16

Binary package hint: ubiquity

I hope ubiquity is the right package,

I wanted to save a chroot script to the desktop of the new install. Retrieved script from another 10.04 install and placed on desktop of Live seasion.

Tried to copy to the desktop of new install. Wouldn't work.

Opened script in gedit and tried to save to new install. Claimed I didn't have permission. This is a user owned script.

Owner is "Ubuntu Live session user".

ProblemType: Bug
Architecture: amd64
Date: Tue Mar 16 15:04:05 2010
DistroRelease: Ubuntu 10.04
LiveMediaBuild: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100316)
Package: ubiquity 2.2.0
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
SourcePackage: ubiquity
Uname: Linux 2.6.32-16-generic x86_64

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu ubiquity Edit question
Assignee:
No assignee Edit question
Last query:
2010-03-16
Last reply:
2010-03-17
Tom Pino (metalsmith-rangeweb) said : #1
Evan (ev) said : #2

This doesn't appear to be a bug in ubiquity, but rather confusion as to how installation is done (it doesn't copy modifications live CD desktop to the target system) or how permissions work.

Converting to a question.

Check the ownership with:

ls -la ./scriptname

If it is not owned by your user, run:

sudo chown $USER:USER ./scriptname

The onluy thing to change above is 'scriptname', $USER will magically translate to the user running the command. You will then be the exclusive owner of the script and will have full access

Can you help with this problem?

Provide an answer of your own, or ask Tom Pino for more information if necessary.

To post a message you must log in.