USB tv wont work.

Asked by warren on 2011-04-13

I just moved my Acer Aspire R3610 over to unbuntu for the sole purpose of getting a usb tv tuner to work for my house.

The usb tv tuner is a Kworld UB435-Q that worked ok under windows but experienced lags in the video display.

When i do a lsusb it shows that its connected on BUS 002 Device 003 : ID 04f2:0963 Chicony Electronics co ltd.

Does anybody know how I can get this to work ?

I must be missing something. I tried downlaoding tv time television viewer from the unbuntu site but it lanches and then closes right away.

Thanks for the help.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu tvtime Edit question
Assignee:
No assignee Edit question
Last query:
2011-04-15
Last reply:
2011-04-15

Can you boot with the device detached and run:

lsb_release -a; uname -a; lsusb

Then attach the device and wait 10 seconds, then run:

dmesg | tail -n 15; lsusb

Copy all the output and paste here as an update

Thanks

Also:

(1) Where did you go to get tvtime? How did you install it? tvtime is provided through the standard Ubuntu software sources (i.e., you can install it in Applications > Ubuntu Software Center). Is this not how you installed it?

(2) Please open a Terminal window (Ctrl+Alt+T or Applications > Accessories > Terminal -- the same thing you must do in order to be able to run the commands that actionparsnip gave you), type in "tvtime" (without the quotes), and press enter. Then select all the text in the Terminal (Edit > Select All), copy it to the clipboard (Edit > Copy), and paste it here.

warren (wdavies-69) said : #3

I downloaded tvtime from unbuntu site as you mentioned above Eliah and did let it do its own install. Heres what i get when i run it from the command line.

Running tvtime 1.0.2.
Reading configuration from /etc/tvtime/tvtime.xml
Reading configuration from /home/xxxxx/.tvtime/tvtime.xml
videoinput: Cannot open capture device /dev/video0: Permission denied
mixer: Can't open device /dev/mixer, mixer volume and mute unavailable.
Segmentation fault

Can you provide the information that actionparsnip requested?

Can you give the output of the commands I gave please..

warren (wdavies-69) said : #6

Here's what actionparsnip asked for. Looks like it doesnt see it at all. Sorry my mistake still getting use to the new operating system have been using windows for 20 years,,,,,

with the usb disconnected.....
xxxx@xxx-xxx:~$ lsb_release -a; uname -a; lsusb
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 10.10
Release: 10.10
Codename: maverick
Linux xxx-xxx 2.6.35-28-generic #49-Ubuntu SMP Tue Mar 1 14:40:58 UTC 2011 i686 GNU/Linux
Bus 002 Device 003: ID 04f2:0963 Chicony Electronics Co., Ltd
Bus 002 Device 002: ID 03f0:0024 Hewlett-Packard KU-0316 Keyboard
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

with it attached.....
xxx@xxxx-xxxxx:~$ dmesg | tail -n 15; lsusb
[ 12.429086] nvidia 0000:00:03.5: PCI INT B -> Link[LPMU] -> GSI 21 (level, low) -> IRQ 21
[ 12.430493] ACPI: PCI Interrupt Link [SGRU] enabled at IRQ 20
[ 12.430506] nvidia 0000:03:00.0: PCI INT A -> Link[SGRU] -> GSI 20 (level, low) -> IRQ 20
[ 12.430524] nvidia 0000:03:00.0: setting latency timer to 64
[ 12.430534] vgaarb: device changed decodes: PCI:0000:03:00.0,olddecodes=io+mem,decodes=none:owns=io+mem
[ 12.431306] NVRM: loading NVIDIA UNIX x86 Kernel Module 260.19.06 Mon Sep 13 06:35:06 PDT 2010
[ 15.239414] audit_printk_skb: 18 callbacks suppressed
[ 15.239424] type=1400 audit(1302873801.691:18): apparmor="STATUS" operation="profile_replace" name="/usr/lib/cups/backend/cups-pdf" pid=866 comm="apparmor_parser"
[ 15.240398] type=1400 audit(1302873801.691:19): apparmor="STATUS" operation="profile_replace" name="/usr/sbin/cupsd" pid=866 comm="apparmor_parser"
[ 15.653801] ppdev: user-space parallel port driver
[ 16.884703] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 24.000034] eth0: no IPv6 routers present
[ 25.503772] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro,commit=0
[ 32.953470] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro,commit=0
[ 199.276054] usb 1-3: new high speed USB device using ehci_hcd and address 4
Bus 002 Device 003: ID 04f2:0963 Chicony Electronics Co., Ltd
Bus 002 Device 002: ID 03f0:0024 Hewlett-Packard KU-0316 Keyboard
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 1b80:e346 Afatech
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

thanks again for the help

warren (wdavies-69) said : #7

ohh sorry to my previous post looks like its on bus 001 device 004

The ID to search for is:

1b80:e346

This identifys the device uniquely and should help find guides

The crash itself seems to be due to bug 630793. I recommend you go to the page for that bug, mark it as affecting you, and provide any missing information. In particular, it might be helpful if you provided your Ubuntu version, tvtime package version, and the make/model of your TV tuner there, in case the problem is device-specific or in case the crash occurs specifically for TV tuners that are not recognized.

There's a *slight* chance that your crash is not the same as bug 630793. If you feel like it, you could enable Apport (https://wiki.ubuntu.com/Apport#Howto%20enable%20apport) and reproduce the bug. When you go to report the bug, in your browser it should give suggestions for what your bug might be. If bug 630793 (and no other bugs with status other than Incomplete or Expired) comes up as a suggestion, then in this case you can be pretty sure that's your bug. You can then click the button indicating that that's the bug you're trying to report, which will automatically mark you as being affected by it and, optionally, subscribe you to the bug. (It will not automatically post any of the information that I'm suggesting you add to the bug report, however.)

If neither that bug nor any other reasonable suggestions come up--or reasonable suggestions come up, but viewing their descriptions makes clear that they are not similar to your problem--then you can continue with the process of reporting a new bug. If it comes to that, then you should make sure to read https://help.ubuntu.com/community/ReportingBugs carefully before submitting your bug report. If you end up submitting your own bug report, you can link that bug to this question using the "Link existing bug" link near the top of this question page (that's the link I used to link bug 630793). However, if you file a bug report, the report itself should be complete and self-contained--it should not be necessary for the Ubuntu developers to refer to this question to fully understand and appreciate your bug. Similarly, if you post in bug 630793 (or another existing bug), it's not a bad idea to post a link to this question page, but your post should include your Ubuntu version, tvtime package version, and TV tuner hardware information explicitly.

Did the information actionparsnip provided in his last two posts enable you to find a workaround the problem?

Can you help with this problem?

Provide an answer of your own, or ask warren for more information if necessary.

To post a message you must log in.