installed tuxguitar will not lauch when clicked on, why?

Asked by jlowman1

installed tuxguitar on ubuntu and it is in my programs list but will not open when i select it from my menu. any ideas what I can do to resolve this? would really like to use this program.

Question information

English Edit question
Ubuntu tuxguitar Edit question
No assignee Edit question
Solved by:
Wyatt Smith
Last query:
Last reply:
Revision history for this message
Wyatt Smith (wyatt-smith) said :

Just wondering if you installed it from the repositories or the website ?

Revision history for this message
Best Wyatt Smith (wyatt-smith) said :

Installations from the repositories seem to work fine.

If you installed from the website, the .deb package provided may have some dependency issues. It appears that the .deb package does not include the java dependency.

If that is the case, then open a Terminal and type
sudo apt-get install sun-java6-jre

If that fails to work for you, reinstall from synaptic package manager.

Hope this helps

Revision history for this message
marcobra (Marco Braida) (marcobra) said :

How to install tuxguitar and Java

Please first enable the multiverse repository:

Open System->Administration->Software sources-> [ Tab Ubuntu software ]
enable "Software restrictecd by copyright or legal issue ( multiverse )"
Close and confirm the repository reload.

Then open a Terminal from the menu Applications->Accessories->Terminal and type:

sudo aptitude update
sudo apt-get upgrade
sudo aptitude install sun-java6-bin sun-java6-jre sun-java6-plugin tuxguitar

give your user password when requested, you don't see nothing when you type it, then press enter.

and then select this as your default java jre with

sudo update-java-alternatives

Hope this helps

Revision history for this message
jlowman1 (jlowman1) said :

Thanks WWSmith36, that solved my question.

Revision history for this message
jlowman1 (jlowman1) said :

Thank you for your assistance in this matter, between WWSmith36 and Marcoba I was able to resolve this issue!
Thanks again!