Transmission BitTorrent 2.84 doesn't add and open URL

Asked by MadhuSoodanan on 2020-04-28

Ubuntu 16.04 LTS

Transmission BitTorrent Client 2.84 doesn't open after entering URL. No other window appears. No network problem. No indication of downloading on the screen.

Question information

English Edit question
Ubuntu transmission Edit question
No assignee Edit question
Solved by:
Manfred Hampl
Last query:
Last reply:

This question was reopened

MadhuSoodanan (mt-madhu) said : #1

madhu@madhu-desktop:~$ lsb_release -a; uname -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 16.04.6 LTS
Release: 16.04
Codename: xenial
Linux madhu-desktop 4.4.0-177-generic #207-Ubuntu SMP Mon Mar 16 01:15:50 UTC 2020 i686 i686 i686 GNU/Linux

What is the output of:

apt-cache policy transmission


Why such an old release of Ubuntu? Bionic is LTS and rock solid. Focal is also LTS but 64bit only. Do you have a. 32bit CPU?

MadhuSoodanan (mt-madhu) said : #3

madhu@madhu-desktop:~$ apt-cache policy transmission
  Installed: (none)
  Candidate: 2.84-3ubuntu3.1
  Version table:
     2.84-3ubuntu3.1 500
        500 xenial-updates/universe i386 Packages
        500 xenial-security/universe i386 Packages
     2.84-3ubuntu3 500
        500 xenial/universe i386 Packages


I was trying to download focal fossa. But other URLs also didn't work.

Now I am with 32bit CPU. It is still working without much problem. But didn't support Bionic Beaver

MadhuSoodanan (mt-madhu) said : #4

But I could download Bionic Beaver 2 yrs ago with this system without any problem.

MadhuSoodanan (mt-madhu) said : #5

Please see #3 and #4 also

Modem only shows some downloading is happening. But its indication is seen nowhere on the screen or in the folder. I believe it will not download before I click on the play button.

If you enable the Web interface can you see the downloads there?

MadhuSoodanan (mt-madhu) said : #7

Actually I didn't understand this question.

The only sign on the screen I could see is the tiny spinning mark we normally see when the mouse-pointer changes just after clicking on icons. There is no strip like (tub-like) part that we see when downloading happens.

Finally, after waiting for 15 minutes I got the following message (just now). It says

Sorry, the program "transmission-gtk" closed unexpectedly

Your computer does not have enough free memory to automatically analyze the problem and send a report to the developers.


But I am quite sure that I have enough space in my 1 TB hard disc.

MadhuSoodanan (mt-madhu) said : #8

See #7 also

My system Memory is 2.9GiB

If free space is the problem. I wish to increase the memory free space by removing unwanted things just for this download. But before that I wish to verify the unwanted apps/files

I don't know the commands for these.

MadhuSoodanan (mt-madhu) said : #9

See #7 and #8

madhu@madhu-desktop:~$ df
Filesystem 1K-blocks Used Available Use% Mounted on
udev 1524336 0 1524336 0% /dev
tmpfs 308968 5032 303936 2% /run
/dev/sda1 958217736 59018376 850501608 7% /
tmpfs 1544832 90628 1454204 6% /dev/shm
tmpfs 5120 4 5116 1% /run/lock
tmpfs 1544832 0 1544832 0% /sys/fs/cgroup
/dev/loop0 53504 53504 0 100% /snap/core18/1703
/dev/loop2 109056 109056 0 100% /snap/video-downloader/317
/dev/loop1 163584 163584 0 100% /snap/gnome-3-28-1804/111
/dev/loop3 63616 63616 0 100% /snap/gtk-common-themes/1506
/dev/loop4 167296 167296 0 100% /snap/gnome-3-28-1804/115
/dev/loop5 109056 109056 0 100% /snap/video-downloader/312
/dev/loop7 56192 56192 0 100% /snap/gtk-common-themes/1502
/dev/loop6 91648 91648 0 100% /snap/core/8933
/dev/loop8 91904 91904 0 100% /snap/core/9065
/dev/loop9 53248 53248 0 100% /snap/core18/1669
tmpfs 308968 64 308904 1% /run/user/1000

Manfred Hampl (m-hampl) said : #10

"Your computer does not have enough free memory" does not relate to disk space, but to RAM Memory.

You wrote "My system Memory is 2.9GiB". That is the limiting factor. Recommended minimum for Ubuntu Desktop is 4 GiB

What is the output of the command

free -m

MadhuSoodanan (mt-madhu) said : #12

I think 4GB is from 18.04 onwards

madhu@madhu-desktop:~$ free -m
              total used free shared buff/cache available
Mem: 3017 438 1624 291 953 1983
Swap: 3058 0 3058

Manfred Hampl (m-hampl) said : #13

Your last output shows sufficient free memory.

Which output do you receive for "free -m" while transmission is running?

MadhuSoodanan (mt-madhu) said : #15

I can't open the URL. What should I do to run it?

MadhuSoodanan (mt-madhu) said : #16

This is the output when it is trying to open URL

madhu@madhu-desktop:~$ free -m
              total used free shared buff/cache available
Mem: 3017 1264 341 428 1411 1013
Swap: 3058 0 3058

MadhuSoodanan (mt-madhu) said : #17

While I was sending the post #16 a video live was running. The following result is after I stopped the live programme.

madhu@madhu-desktop:~$ free -m
              total used free shared buff/cache available
Mem: 3017 860 816 324 1339 1521
Swap: 3058 0 3058

Manfred Hampl (m-hampl) said : #18

What happens if you open a terminal and run


and try opening a URL.
Do you see any messages in the terminal window?

MadhuSoodanan (mt-madhu) said : #20

When I used terminal command, the Transmission window appeared.

Before copying URL I clicked on file --> Open URL

The output is as follows:

madhu@madhu-desktop:~$ transmission-gtk

(transmission-gtk:2786): GLib-CRITICAL **: g_strchug: assertion 'string != NULL' failed

(transmission-gtk:2786): GLib-CRITICAL **: g_strchomp: assertion 'string != NULL' failed

Manfred Hampl (m-hampl) said : #21

Does transmission work when started from the terminal?
Does it show more messages?
Or does it crash?

MadhuSoodanan (mt-madhu) said : #22

Transmission BitTorrent ---> Help ---> About shows 2.84 (14307) and this number is quite different from the number given in the crash message. You may check the says (transmission-gtk:2786). I don't know whether this is a defect.

This is the result after the complete removal and re-installation of transmission-gtk using Terminal command. The number was the same as before removal. I couldn't activate any ofl the 4 buttons on the window except "open" so far. Start, pause, remove & properties are in idle mode. So I have no hope of its download before the two buttons come in working mode.

The only problem I am facing with my 32bit system is a bit slowness while downloading and using videos in chromium. But it works. Firefox is ok. I shall try to do what you suggested and post the reply within a few hours.

MadhuSoodanan (mt-madhu) said : #23

Yes, it crashed. The pop-up window appeared shows "Sorry, the program "transmission-gtk" closed unexpectedly

Your computer does not have enough free memory to automatically analyze the problem and send a report to the developers."

The message was not in the terminal.

The screenshot of transmissiion-gtk in synaptic:

MadhuSoodanan (mt-madhu) said : #24

Please don't forget to read the last two messages (#22 & #23)

Do other torrent clients run OK?

MadhuSoodanan (mt-madhu) said : #27

Using terminal command I tried to use transmission-gtk for downloading a small file. This time there was no crash message. But couldn't make it work. Unlike in the iso image, the spinning of the mouse pointer stopped within one minute. In the case of iso image, it took more than 10 minutes to appear the crash message.

madhu@madhu-desktop:~$ transmission-gtk

(transmission-gtk:2920): GLib-CRITICAL **: g_strchug: assertion 'string != NULL' failed

(transmission-gtk:2920): GLib-CRITICAL **: g_strchomp: assertion 'string != NULL' failed


Please note the gtk number. It is not the same in#20

Manfred Hampl (m-hampl) said : #28

"But couldn't make it work."

What exactly happened when you tried downloading the file?

Manfred Hampl (m-hampl) said : #29

And just to explain: the number in the message is the process id, which of course is different with each new start of the program.

MadhuSoodanan (mt-madhu) said : #31

Nothing disappeared or crashed. The spinning mouse pointer just stopped after a few seconds. Nothing downloaded or even the start button was not in the active mode.before and after this spinning.

The first dropdown menu to show 'active, downloading, seeding, paused, etc' always shows the number zero. I believe it couldn't download anything.

Manfred Hampl (m-hampl) said : #32

Can you upload an image showing the window?

MadhuSoodanan (mt-madhu) said : #33

This is the screen appeared when I entered the transmission command

This is the screen appeared when I clicked on "open URL"

This is the screen appeared when I entered the URL

This is the screen appeared while the process is going on. Shutter couldn't take the screenshot of the spinning mouse pointer. I waited for more than half an hour to get a crash report. So I gave up this attempt for the time being.

MadhuSoodanan (mt-madhu) said : #35

Please note #33

I didn't give up all the attempt. It was about that particular attempt for waiting the final result (crash report) since it took a long time.
Today also I tried to download a small file. But it didn't open the URL. Experienced the same problem as with iso.

Still I didn't lose hope for downloading the new version through Transmission. Otherwise if I change the motherboard and other components, I will be compelled to reinstall this old version to download focal fossa.

Have you tried Deluge? Does that do the same thing? It's in the repositories

MadhuSoodanan (mt-madhu) said : #37

Need I install all these packages related to deluge?
Is this related to ubuntu?

Yes install those packages. You can even do it in terminal with:

sudo apt install deluge

(close software centre first).

Yes.... It's related to Ubuntu. How can it not be related to Ubuntu? It's a different torrent client. See if it behaves the same.

MadhuSoodanan (mt-madhu) said : #39

Ok. I shall try now

After I installed all these packages which app should I use? Torrent-gtk or Deluge?

Deluge. Try the new application

MadhuSoodanan (mt-madhu) said : #41

Yes, indeed. It is working. Thanks, actionparsnip for suggesting this alternative for solving my problem.

Thanks, Manfred Hampl for spending a lot time for helping me with this problem.

MadhuSoodanan (mt-madhu) said : #42

Thanks actionparsnip, that solved my question.

Cool. It does have a web interface which you can enable. You can then remote manage torrents from another PC. If there are clients for phones then you can manage them from your phone. Very handy. Check YouTube for guidance

Seems Transdrone on Android can do it. Depends if that interests you

MadhuSoodanan (mt-madhu) said : #49

I don't wish to use it on phone. I have only one PC.

A difference I found in Deluge is, no dialogue box that shows the content and from where it comes appears (the URL) before I click on for download.

But it was there with Transmission-gtk when I downloaded two times (a few years ago).

How can I make sure whether it is from the correct source before I click on?

How can I enable it?

 I have tried by enabling some items in preferences. But that wasn't enough to know the source before I download.

I couldn't see the tracker status and other things while dowloading

Please note the window on the screen shot while downloading. I tried several times using some other URLs. But I couldn't see the source, name, size etc on the window. Also, I couldn't confirm whether it is from the correct source before downloading as in Transmission-gtk.

If this thread is changing to Deluge let's close this because I think it may create complication.

If it (the display on the window regarding all the information about downloading) can be solved easily let's continue this thread.

Otherwise I wish to solve the issue related to Transmission-gtk.

MadhuSoodanan (mt-madhu) said : #50

The URL I copied was not correct. See this screenshot in #33.

Today I tried using a friend's PC and detected the problem. The problem was with the URL.

Thanks for actionparsnip and Manfred Hampl.

Best Manfred Hampl (m-hampl) said : #51

Is this problem now solved or still open?

If it is still open: Have you tried reinstalling transmission?
By the way, the output in comment #3 even told that it is not installed at all.

For diagnostic purposes, what is the output of the commands

uname -a
lsb_release -crid
dpkg -l | grep transm

or - if you have found a solution, then please mark this question document as "solved"

MadhuSoodanan (mt-madhu) said : #52

The status of this question is "SOLVED"

I have tried reinstalling transmission. No problem. It is working

What I mentioned was about comment #33 and about the 3rd screenshot. In that screenshot we can't view the URL completely.

madhu@madhu-desktop:~$ lscpu
Architecture: i686
CPU op-mode(s): 32-bit, 64-bit
Byte Order: Little Endian
CPU(s): 2
On-line CPU(s) list: 0,1
Thread(s) per core: 1
Core(s) per socket: 2
Socket(s): 1
Vendor ID: GenuineIntel
CPU family: 6
Model: 15
Model name: Intel(R) Pentium(R) Dual CPU E2140 @ 1.60GHz
Stepping: 13
CPU MHz: 1600.000
CPU max MHz: 1600.0000
CPU min MHz: 1200.0000
BogoMIPS: 3192.04
L1d cache: 32K
L1i cache: 32K
L2 cache: 1024K
Flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts aperfmperf pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm lahf_lm dtherm
madhu@madhu-desktop:~$ uname -a
Linux madhu-desktop 4.4.0-178-generic #208-Ubuntu SMP Sun Apr 5 23:45:27 UTC 2020 i686 i686 i686 GNU/Linux
madhu@madhu-desktop:~$ lsb_release -crid
Distributor ID: Ubuntu
Description: Ubuntu 16.04.6 LTS
Release: 16.04
Codename: xenial
madhu@madhu-desktop:~$ dpkg -l | grep transm

MadhuSoodanan (mt-madhu) said : #53

Thanks Manfred Hampl, that solved my question.

Manfred Hampl (m-hampl) said : #54

Additional comment:

4.4.0-178-generic #208-Ubuntu SMP Sun Apr 5 23:45:27 UTC 2020 i686 i686 i686 GNU/Linux
CPU op-mode(s): 32-bit, 64-bit

You currently are running the 32bit ("i386") variant of Ubuntu, but your CPU is also capable of running the 64bit variant ("amd64").

MadhuSoodanan (mt-madhu) said : #55


I downloaded 20.04, made and made a bootable USB and used the option TRY UBUNTU. It is working. But didn't try to install it because I had experienced some issues after I installed the last version (18.04) two years ago. Since the RAM and processor are of have low capacity I didn't make an attempt to install it now. I have no confidence to do it in this old system. Thank you.

If you have a low end system then you can use XFCE. It'll use fewer resources

MadhuSoodanan (mt-madhu) said : #57

Sometimes I'll be busy from next month onwards. There is a possibility of workload for a few years. So I think I'd better change this system than learning a new os. I haven't used other Linux systems so far. I like Ubuntu and Ubuntu community very much and so I wish to stay with this OS.

Actionparsnip, thank you for the good piece of information you shared.