Where did the tray icon go?

Asked by Duncan Hill on 2009-01-06

I remember that there used to be a tray icon for Transmission so that I could minimize the program to the tray and it seems to no longer exist. I tried looking around for any info on why it was removed but I couldn't find anything. I liked being able to minimize to tray because I hate having the Transmission icon on the panel taking up space that can be used by other things. There should at least be an option to let the user decide how they want it to function. Anyways, where did the tray icon go and will it be coming back?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu transmission Edit question
Assignee:
No assignee Edit question
Solved by:
plutino
Solved:
2009-01-08
Last query:
2009-01-08
Last reply:
2009-01-06
Duncan Hill (handl3r) said : #1

Also I am using Ubuntu 8.10 64bit

Best plutino (plutino) said : #2

In Transmission, go to the View menu and check the Tray Icon box.

Duncan Hill (handl3r) said : #3

Thanks plutino, that solved my question.

Daniel (hackie) said : #4

Same problem here, but not solvable this was: there is just no such Tray icon item in the view menu :-(

I now found the Option "Show desktop icon in notification area" in the preferences, enabling the icon. But when i minimize, the window remains in the task list - in contrast to rhythmbox which does what i want

$ dpkg -s transmission-gtk
Package: transmission-gtk
Status: install ok installed
Priority: optional
Section: net
Installed-Size: 2408
Maintainer: Ubuntu Core Developers <email address hidden>
Architecture: i386
Source: transmission
Version: 1.51-0ubuntu1

Chris Portway (chris-portway) said : #5

Daniel, try clicking the close button [X] in the window bar. Note that using the menubar to "quit" does not have the same effect.

I agree it is unfortunate that different default apps in ubuntu such as rhythmbox and transmission have different methods of minimizing to the taskbar, although in both cases clicking on the icon in the taskbar will hide/minimize the application to the task bar.

Daniel (hackie) said : #6

Thx Chris, that worked.

Shame on me that i did not see that.. :-(

Kutalion (kutalion) said : #7

Why don't you try with "Edit -> Preferences -> Desktop -> Show Transmission in system tray" that solves the problem completely ;)