After upgrade from 11.10 to 12.04 Transmission will not launch from shortcuts and torrent downloads.

Asked by henrym12 on 2012-11-10

After the upgrade Transmission will not start. I have tried info from question #208333 with no change. When I right click on a .torrent file to open with Transmission nothing happens. Also, when I download a torrent file from Firefox it will not start Transmission after I click on open file. I am thinking it could be a broken link to Transmission-gtk, because the only way i have found to launch Transmission is by clicking on /usr/bin/transmission-gtk. I would like to know how to check if the link is infact broken. After Transmission opens I have to open the .torrent file from within Transmission to start the download. The system is running Ubuntu 12.04 with Unitiy as my HTPC.

Question information

English Edit question
Ubuntu transmission Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
N1ck 7h0m4d4k15 (nicktux) said : #1

Try to purge and install again transmission .

~$ sudo apt-get remove --purge transmission
~$ rm -r .config/transmission
~$ rm -r .cache/transmission

~$ sudo apt-get install transmission


henrym12 (henrym12) said : #2

Thanks for the reply NikTh. I ran the commands and reinstalled Transmission. But the problem is still. :(

henrym12 (henrym12) said : #3

Well the problem has not changed. I do think its strange that it has only affected Transmission. I have tried other torrent software and they work fine, but I am not pleased with them. I am staying with Transmission because I still use it on my other pc's and I think its a great program.

N1ck 7h0m4d4k15 (nicktux) said : #4

Hi ,

run transmission through terminal and post back any messages (in terminal)

~$ transmission-gtk


henrym12 (henrym12) said : #5

ok this is what i got from the terminal:
transmission-gtk: error while loading shared libraries: cannot open shared object file: No such file or directory

I did see this file before and i think it was updated to So im thinking that there should be a link to each other if so im not sure how to do it. But I maybe wrong.

N1ck 7h0m4d4k15 (nicktux) said : #6

What version of transmission you have ?

~$ apt-cache policy transmission-gtk

Also try to install transmission-daemon

~$ sudo apt-get install transmission-daemon

reboot and see if problem solved. is the correct library. Newer versions of transmission should ask for this library and not . This is required library for transmission-daemon package.

If nothing of above works , then purge transmission again and try to install from PPA.

~$ sudo apt-get purge transmission-*
~$ rm -r .config/transmission
~$ rm -r .cache/transmission

Install from PPA
~$ sudo add-apt-repository ppa:transmissionbt/ppa
~$ sudo apt-get update
~$ sudo apt-get install transmission transmission-gtk transmission-daemon


henrym12 (henrym12) said : #7

I had ver 2.5.1 and now i have ver 2.7.2 installed. There was one error during the purge: E: Unable to locate package transmission-unity-launcher.
Also. I got one error from the install: * Starting bittorrent daemon transmission-daemon [18:20:46.495] Couldn't read "/home/media1/.config/user-dirs.dirs": Permission denied
Going to reboot again to see what happens. One more note I am using the 64bit version.

Thanks again for all of your time and help.

henrym12 (henrym12) said : #8

Here is a cut and paste after running transmission and apt-cache policy transmission-gtk. I looks like to me that some of the old file are not being updated unless im reading it wrong and its a history of the package.

transmission-gtk: error while loading shared libraries: cannot open shared object file: No such file or directory
apt-cache policy transmission-gtk
  Installed: 2.72-0ubuntu0.12.04.1
  Candidate: 2.72-0ubuntu0.12.04.1
  Version table:
 *** 2.72-0ubuntu0.12.04.1 0
        500 precise/main amd64 Packages
        100 /var/lib/dpkg/status
     2.51-0ubuntu1.1 0
        500 precise-updates/main amd64 Packages
        500 precise-security/main amd64 Packages
     2.51-0ubuntu1 0
        500 precise/main amd64 Packages

N1ck 7h0m4d4k15 (nicktux) said : #9

OK , as a last effort , try to install the libminiupnpc-dev package. This package not needed , is for developers , but maybe correct the problem.

~$ sudo apt-get install libminiupnpc-dev

If problem not solved , I suggest to close this question and open a bug report. Probably the problem created during the release (Ubuntu) upgrade.

A workaround here might be to "give" to transmission the library it needs . (try it)

~$ sudo touch /usr/lib/
~$ sudo ln -s /usr/lib/ /usr/lib/

The second command creates a soft link so the points to the real library , because is just a trick.

You have to keep in mind that if you decide to open a bug you have to revert the transmission to the original state .
So , remove transmission and the PPA and reinstall transmission.
~$ sudo apt-get remove --purge transmission-*
~$ sudo apt-get install ppa-purge
~$ sudo ppa-purge ppa:transmissionbt/ppa
~$ sudo apt-get update
~$ sudo apt-get install transmission-gtk


If you right click a torrent file and select 'open with...' then you can select the transmision app then tell the OS to remember the pairing.

If that is no god, try removing the PPA you added and install the transmission from the Ubuntu repo. Is that better?

Rajinder Sandhu (sandy744) said : #11

else try deluge that should work fine... had been using deluge for years now..
sudo apt-get install deluge
and download all your torrent files through deluge,

henrym12 (henrym12) said : #12

The libminiupnpc-dev package was installed and there was no change so now I just going to revert to the Ubuntu version. Also, I have set Transmission as default and when I click on open with Transmission nothing happens. I did try Deluge for a while and it did work but the GF did not like it one bit and I could not set the upload to 0 when I need too. :(

Thanks to everyone for all of your help,

henrym12 (henrym12) said : #13

After removing transmission with apt-get and purged ppa I still can run transmission-gtk and get and error: transmission-gtk: error while loading shared libraries: cannot open shared object file: No such file or directory. So I think at one time I did a source install and somehow its still installed. I have run find / transmission* and find ./ transmission* and cannot find anymore files to remove. Now I am going to try to search the path but I figure that find did that too. So at this time I have done all of the uninstall comands above and still get the error and not the error of file not found that I expect to get. What am I doing wrong why can't I purge it all. I also got the last 3 sources and did a make uninstall to see if that would do the trick but nothing has worked.

N1ck 7h0m4d4k15 (nicktux) said : #14

I would suggested to convert the question to a bug , but in my installation (same as yours) transmission works without problems.
And of course I have not the file , I have the updated .

Have you tried the trick with soft links ?

Try this to purge transmission completely

~$ sudo apt-get autoremove --purge transmission*
~$ sudo apt-get purge $(dpkg -l | awk '/^rc/ { print $2 }')

then give this command for any leftovers

~$ locate transmission


henrym12 (henrym12) said : #15

Well after all that and 314 removed files later I get this from locate transmission:


Also, I still get the same error message but only from my home folder and not from /. I did remove all the transmission files from Downloads before running locate transmission. I don't know but I do think that I broke it and its not a bug but who am I to say.

Thank you

Can you give the output of:

sudo updatedb; locate libminiupnpc

Also, did you compile transmission?

N1ck 7h0m4d4k15 (nicktux) said : #17

Yes , after the purge , you have to use the

~$ sudo updatedb

command first and then

~$ locate transmission

Give the results @andrew requested.


henrym12 (henrym12) said : #18

After looking at my last post for a while I found the two files:


Then after removeing them I got the error file not found would you like to install transmission-gtk and everything is working great now. I did compile transmission at one time and I guess installed because it was there caused most of my problems do to that file was only to be used on Ubuntu 11.04 and got left behind after all my distro upgrades.

BTW that command was great in cleaning up my file: sudo apt-get purge $(dpkg -l | awk '/^rc/ { print $2 }'). I will have to break it down to know whats going on with the | to awk...

It was nice working on the prompt again I can see how rusty I am. :)

Here is the output from sudo updatedb; locate libminiupnpc:


A lot of good info, I will be looking foward to applying it to other problems I come across.

Thank you

N1ck 7h0m4d4k15 (nicktux) said : #19

Hooray !!!

Glad you solved.