Torrent clients suddenly stopped downloading in Ubuntu 10.04

Asked by Vasilis Baltikas on 2012-04-07

A few days ago I noticed, that Transmission in my Ubuntu 10.04 machine suddenly couldn't download anything anymore.

To overcome this I have uninstalled and reinstalled Transmission and tried downloading well seeded torrents (ubuntu iso images for example), using other clients (Deluge, Vuze) without success.

On the same computer I also have installed Ubuntu 10.10 and Windows 7, which I rarely use. What makes the problem I encounter weirder, is the fact that downloading via torrents works fine in my Ubuntu 10.10 and Windows partitions but not in Lucid Lynx.

I am using my own Internet connection at home using a Thomson TG585 v.8 modem/router.

Two computers connect to the Internet using this connection: a) my Desktop PC (where I encounter this problem), connected to the modem/router with an Ethernet cable b) a laptop which occasionally connects to the Internet wirelessly.

Any help would be greatly appreciated.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu transmission Edit question
Assignee:
No assignee Edit question
Solved by:
Vasilis Baltikas
Solved:
2012-04-09
Last query:
2012-04-09
Last reply:
2012-04-08

Can you give the output of:

dpkg -l | grep transmission; lsb_release -a; uname -a; df -h

Thanks

Here is the requested output.
ii transmission-common 2.33-0ubuntu0.10.04.1 lightweight BitTorrent client (common files)
ii transmission-gtk 2.33-0ubuntu0.10.04.1 lightweight BitTorrent client (GTK interface)
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 10.04.4 LTS
Release: 10.04
Codename: lucid
Linux vasilis-desktop 2.6.32-40-generic #87-Ubuntu SMP Tue Mar 6 00:56:56 UTC 2012 x86_64 GNU/Linux
Filesystem Size Used Avail Use% Mounted on
/dev/sdb5 15G 12G 1.8G 87% /
none 2.0G 292K 2.0G 1% /dev
none 2.0G 2.1M 2.0G 1% /dev/shm
none 2.0G 236K 2.0G 1% /var/run
none 2.0G 0 2.0G 0% /var/lock
none 2.0G 0 2.0G 0% /lib/init/rw
/dev/sdb1 172G 139G 33G 81% /windows
/dev/sdb6 259G 231G 15G 94% /home

Try:

sudo add-apt-repository ppa:andreas-noteng/transmission; sudo apt-get update; sudo apt-get upgrade

That didn't help. Unfortunately the problem remains.

If you clear some space from home using bleachbit, does it help?

I'm not familiar with Bleachbit. Can you help a bit?

Sure, install it and run it as your user and as root (you'll get 2 icons in dash). You should avoid options which say they will take a long time as well as watch your options as it may remove the options you want.

I've run Bleachbit. Nothing changed.

Do you use a proxy or firewall?

No, I use neither a pxoxy nor a firewall.

If you make a new Ubuntu user and log in as that, do torrents work ok?

I have already tried that and torrents do not work. Actually I am preparing to use Wireshark (reading the documentation) and see if I can get more information about what's going on.

The problem is solved. My Peerguardian Linux installation caused all the trouble due to either some kind of a bug or some configuration adjustment I tried but can't remember. This was determined by the use of Wireshark (it informed me that the torrent clients connect to the trackers) and by getting the output of sudo iptables -L in a terminal (the output showed that pgl interfered with my machine's iptables rules). Temporarily terminating the appliance of these rules with sudo iptables -F proved the aforementioned hypothesis. Finally I uninstalled and reinstalled Peerguardian Linux and thus solved the problem.