Transmissions starts but does not download or save any changes

Asked by Konstantin Konev on 2011-05-02

When I change any setting, delete torrent files from queue and then restart everything is reverted when transmission is launched again. Purging and reinstalling does not help.
How can I reset everything about transmission to make it work?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu transmission Edit question
Assignee:
No assignee Edit question
Solved by:
Federico Tello Gentile
Solved:
2011-05-03
Last query:
2011-05-03
Last reply:
2011-05-02

there will be a config folder in ~/.config just rename the transmission folder after renaming it, when you run the app you will get vanilla settings

Konstantin Konev (skfd) said : #2

@actionparsnip I tried that and, even though setting got reset, if I change something it's not saved.

Can you give the output of:

lsb_release -a; apt-cache policy transmission

Thanks

Konstantin Konev (skfd) said : #4

lsb_release -a; apt-cache policy transmission

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.04
Release: 11.04
Codename: natty
transmission:
  Installed: (none)
  Candidate: 2.13-0ubuntu8
  Version table:
     2.13-0ubuntu8 0
        500 http://ua.archive.ubuntu.com/ubuntu/ natty/universe amd64 Packages

Could try:

sudo add-apt-repository ppa:transmissionbt/ppa; sudo apt-get update; sudo apt-get -y upgrade

May help

Can you also give the output of:

mount

Thanks

Konstantin Konev (skfd) said : #6

I'm aware of ppa, but I'd like to try fix installation from main repository, sorry.
Here is mount output:

/dev/sda8 on / type ext4 (rw,errors=remount-ro,commit=0)
proc on /proc type proc (rw,noexec,nosuid,nodev)
none on /sys type sysfs (rw,noexec,nosuid,nodev)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
none on /dev type devtmpfs (rw,mode=0755)
none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
none on /dev/shm type tmpfs (rw,nosuid,nodev)
none on /var/run type tmpfs (rw,nosuid,mode=0755)
none on /var/lock type tmpfs (rw,noexec,nosuid,nodev)
/dev/sda5 on /boot type ext4 (rw,commit=0)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
/dev/sdb on /media/backup type ext4 (rw,nosuid,nodev,uhelper=udisks)
/dev/sda7 on /media/mainland type ext3 (rw,nosuid,nodev,uhelper=udisks)
gvfs-fuse-daemon on /home/skfd/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=skfd)

Transmission has a message log in the help menu. See there if you find any message suggesting what can be wrong.

Konstantin Konev (skfd) said : #8

Thanks! Turns out it was something with UPnP. I just had to wait for 20 minutes until it stopped trying to reach bloody router. And after that Transmission is usable again. Turned of UPnP imminently!

Konstantin Konev (skfd) said : #9

Thanks Federico Tello Gentile, that solved my question.