Torrent not working despite peers

Asked by Drake Raul on 2010-12-19

So basically I'm trying to torrent this file, and I'm kind of new to this so bear with me, and the last bit won't download. I'm running off of Ubuntu Desktop 10.10 and I haven't messed with any of the Transmission settings. The file that I'm downloading is at 99.62% and has been for the past hour. It says that I am connected to three peers, however I am not downloading from them. Someone, anyone, save me from my ignorance.

Note: I am downloading other files via torrent as well, and they seem to be having no problem finishing the download.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu transmission Edit question
Assignee:
No assignee Edit question
Solved by:
Charles Kerr
Solved:
2010-12-21
Last query:
2010-12-21
Last reply:
2010-12-20
mycae (mycae) said : #1

Make sure that you have a port open on your router -- otherwise connections can be severely impeded.

http://en.wikipedia.org/wiki/Port_forwarding

Instructions for port forwarding for most routers is available at :
http://portforward.com/

The port you need to forward is in the preferences for transmission. There is also a "test port" button. THis should tell you if your port is OK or not

marcus aurelius (adbiz) said : #2

by peers, i'm assuing you mean seeders. 3 is not enough to complete a download if there are lots of leechers trying to download the same file. i have encountered this situation many times. you just have to be patient.

if the 3 peers are downloading the same file as you, they maybe be waiting for the last bits to download as well, as there may be no seeders who have the complete file on line.

Drake Raul (xeronos-frank) said : #3

@ Marcus's Answer: I don't know what a seeder is, but it says I am downloading from 0 of 3 connected peers. Where as your answer seems logical and probable, It gives me the least amount of potential action so I'm going to try and expand on mycae's answer. Thank you very much for trying to help me.

@Mycae's Answer: I did indeed hit the test port button and the port was closed. The link you gave me had a list of links on what to do on what computer, and my computer model was not listed. I'm using a samsung N135, in case that helps you any. I ended up on a site called "Team Viewer" that offered free downloadable port mappers. I'm going to try this and see what happens. Thank you for your input.

marcus aurelius (adbiz) said : #4

leechers = people downloading
seeders = people connected who are logged on and have complete files for sharing
peers = anyone else who are logged on but may not have complete files and are sharing the parts of the files that they have with everyone else

Drake Raul (xeronos-frank) said : #5

Ah. Thank you very much. I checked out the properties, and it showed that no one else had the complete file either. Although, I also checked out the preferences and the port was indeed closed. So this has been trying to finish downloading for the past twenty-four hours, and that's a bit ridiculous. Any suggestions other than sitting and being patient? I know patience is a virtue, but I'm thinking about downloading the individual files by themselves instead of waiting for it to finish.

mycae (mycae) said : #6

if the port is closed, people cannot connect to you, so it won't work if all the people with the info, and yourself have closed ports, as no-one can request information from anyone else.

Do *not* download any port mapper software. This is a setting on your router, not a software setting on your computer. It is not your computer that is needs configuring, but rather your modem.

Best Charles Kerr (charlesk) said : #7

Getting the ports open and forwarded is helpful, but a side-issue.

The problem is that there aren't any seeders in the swarm. If there were, the other three peers wouldn't be stuck too.

Drake Raul (xeronos-frank) said : #8

Thanks charles, that solved my question.